Bonjour, je ne suis pas habitué à poser des questions sur les forums, j'espère le faire au bon endroit ne pas faire de doublon, malgré mes recherches et être assez clair.
En résumé mes deux boutiques sous oscommerce MS2 hébergés par OVH ne fonctionnent plus depuis quelques jours et certainement depuis une mise à jour de apache 2.2 vers 2.4.
Avec l'erreur suivante
Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request.
OVH indique une solution ici, mais je ne comprends pas leur solution et malgré mes nombreux tests, pas de remise en route des boutiques.
En supprimant le fichier à la base du site htaccess, je retrouve les pages index, login, conditions générales etc... et l'ensemble de l'admin qui marche parfaitement, mais pas les pages produits et catégories produits de la boutique, j'avais installé une contribution Ultimate SEO Url qui avait modifié le fichier htaccess en ajoutant un code dans le but d'afficher le nom des produits dans l"url.
Je place le HTaccess de la racine ci-dessous, merci d'avance de votre aide

Code :Sélectionner tout -Visualiser dans une fenêtre à part
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)
 
# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers
 
<IfModule mod_setenvif.c>
  <IfDefine SSL>
    SetEnvIf User-Agent ".*MSIE.*" \
             nokeepalive ssl-unclean-shutdown \
             downgrade-1.0 force-response-1.0
  </IfDefine>
</IfModule>
 
# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter
#
# AcceptPathInfo On
 
# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)
#
#<IfModule mod_php4.c>
#  php_value session.use_trans_sid 0
#  php_value register_globals 1
#</IfModule>
 
# Ultimate SEO URLs BEGIN
Options +FollowSymLinks
RewriteEngine On 
RewriteBase /
 
RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-links-(.*).html$ links.php?lPath=$2&%{QUERY_STRING}
# Ultimate SEO URLs END
AuthName "Devim"
AuthType Basic
AuthUserFile /h.59/te/op/catalog/me/.htpasswd
<Files admin.php>
require valid-user
</Files>
<Files admin_create_account.php>
require valid-user
</Files>
<Files admin_list_products.php>
require valid-user
</Files>