1. #1
    Futur Membre du Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    septembre 2017
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Tourisme - Loisirs

    Informations forums :
    Inscription : septembre 2017
    Messages : 2
    Points : 7
    Points
    7

    Par défaut Crash apache plusieurs fois par jour

    Bonjour,

    J'ai un serveur tournant sous Debian hébergé chez OVH avec plusieurs sites internet.

    Depuis plusieurs mois, entre 5 et 20 fois par jours, apache devient inaccessible pendant 30 à 60 secondes puis fonctionne de nouveau.
    Et donc pour nos clients, le site rame jusqu'à la fin de la coupure...

    J'ai d’abord testé les autres services qui sont tous accessibles sans problème: SSH, FTP, mails

    Concernant les logs apache, ils s’arrêtent littéralement pendant la coupure et rien n'y apparait.

    Concernant la santé du serveur pendant ces coupures d'après Munin et NetData :
    - Apache : tous les graphiques s'arrêtent complétement d'enregistrer pendant la coupure puis l'activité reprend après
    - L'activité du serveur est normale et loin d'être en surcharge (CPU, RAM, Disque)
    - Aucun pic de fréquentation notable
    - Aucun script en cours d’exécution

    Je ne pense pas qu'une erreur de redirection ou dans un script PHP puisse provoquer ce genre de crash mais je me trompe peut-être (et ce serait a priori visible dans les logs).

    Ce problème a été détecté peu de temps après un changement de serveur et le passage de nos site en HTTPS mais nous n'avons rien trouvé qui laisse supposer que ça vienne directement de ça...

    Après avoir testé de nombreuses choses avec notre infogérant et notre contact de chez OVH, nous n’avons toujours pas trouvé comment résoudre notre problème.
    La carte mère du serveur ainsi que la mémoire ont été changées pour exclure un problème matériel.

    Si vous avez la moindre piste je suis preneur !!
    Merci d'avance.

    Geoffrey

    Pour infos :
    Configuration matériel :
    - CPU : Intel(R) Xeon(R) CPU E5-2650 v3 @ 2.30GHz 40 coeurs
    - RAM : 8x32Go
    - Disques : 4x800Go SSD
    Configuration Logiciel :
    - Debian
    - Apache 2.4.27
    - Php 7.0.23

    Nom : netdata.jpg
Affichages : 30
Taille : 187,7 Ko

  2. #2
    Futur Membre du Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    septembre 2017
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Tourisme - Loisirs

    Informations forums :
    Inscription : septembre 2017
    Messages : 2
    Points : 7
    Points
    7

    Par défaut

    Après des mois de galère notre infogérant à trouvé la réponse à nos problèmes !!!

    Nos dernières tentatives consistaient à désactiver les logs un par un pour s'assurer que l'un d'eux ne posait pas problème mais sans succès.
    Puis notre infogérant à désactivé les fichiers de quota utilisateur et groupe et là : plus aucun blocages pendant 24h.

    Depuis la re-création et remise en place des fichiers des quota, plus de blocages, plus aucun problème, probablement que l'un d'eux était juste corrompu...

    J'espère que ce topic servira à d'autres

  3. #3
    Modérateur

    Avatar de NoSmoking
    Homme Profil pro
    Inscrit en
    janvier 2011
    Messages
    11 953
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations forums :
    Inscription : janvier 2011
    Messages : 11 953
    Points : 25 544
    Points
    25 544

    Par défaut

    Bonjour,
    J'espère que ce topic servira à d'autres
    merci pour ce retour !

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Eclipse plante plusieurs fois par jour
    Par rc_29 dans le forum Eclipse
    Réponses: 2
    Dernier message: 28/06/2011, 09h48
  2. Exécuter un script, une fois par jour
    Par Poussy-Puce dans le forum ASP
    Réponses: 1
    Dernier message: 19/10/2006, 17h55
  3. Réponses: 2
    Dernier message: 04/07/2006, 03h32
  4. Réponses: 4
    Dernier message: 02/09/2004, 22h43

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo