1. #1
    Membre régulier
    Homme Profil pro
    Développeur indépendant
    Inscrit en
    mai 2002
    Messages
    225
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Développeur indépendant

    Informations forums :
    Inscription : mai 2002
    Messages : 225
    Points : 114
    Points
    114

    Par défaut Ucrt Runtime introuvable dans API ms win crt runtime

    Bonjour,

    Je faisais des envois via emaillanceappli et depuis quelques jours cela ne fonctionne plus et j'ai le message suivant

    Nom : crt_runtime.png
Affichages : 53
Taille : 6,5 Ko

    Il faut savoir que je n'ai rien installé ou désinstallé

    Merci pour vos propositions de solutions

    Philippe

  2. #2
    Rédacteur/Modérateur

    Homme Profil pro
    Ingénieur qualité méthodes
    Inscrit en
    décembre 2013
    Messages
    1 414
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur qualité méthodes
    Secteur : Conseil

    Informations forums :
    Inscription : décembre 2013
    Messages : 1 414
    Points : 2 977
    Points
    2 977

    Par défaut

    J'ai chercher api-win-ms-crt-runtime sur google, et ça paraît un problème courant et on trouve pas mal de conseils pour corriger.
    Avec Windows, dès que tu rebootes, Windows est susceptible d'installer un truc qui était en attente.

    Si tu veux, je déplace la question sur un forum plus adapté (forum Windows a priori).
    N'oubliez pas le bouton Résolu si vous avez obtenu une réponse à votre question.

  3. #3
    Membre régulier
    Homme Profil pro
    Développeur indépendant
    Inscrit en
    mai 2002
    Messages
    225
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Développeur indépendant

    Informations forums :
    Inscription : mai 2002
    Messages : 225
    Points : 114
    Points
    114

    Par défaut

    Bonsoir ,

    Merci pour ta réponse

    J'ai cherché également de mon coté et j'ai téléchargé la DLL api-win-ms-crt-runtime que j'ai placé dans le répertoire de l'EXe , sans succès.
    Le truc c'est qu'il semble bloquer sur cette histoire de point d'entrée de la procédure ucrtbase.terminate malgré la DLL dans le répertoire de l'EXE.
    J'ai retiré cette DLL du répertoire de l'EXE.

    Je tourne avec Seven sans faire de mise à jour de Windows.

    Effectivement beaucoup de message sur internet avec la même fenêtre que celle que j'ai indiqué

    Quand je lance emaillanceappli , j'ai le message et ensuite thunderbird s'ouvre sans mettre en place le mail préparé

    Voilà un mystère qui me laisse un peu pantois ....

    Philippe

  4. #4
    Membre régulier
    Homme Profil pro
    Développeur indépendant
    Inscrit en
    mai 2002
    Messages
    225
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Développeur indépendant

    Informations forums :
    Inscription : mai 2002
    Messages : 225
    Points : 114
    Points
    114

    Par défaut Envoi avec SMTP

    Je viens de revoir mon mode d'envoi des mails avec pièces jointes sans passer par emaillanceappli

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
     
    PROCEDURE Envoi_Mail_SMTP(var_serveur est une chaîne, var_expediteur est une chaîne, var_password est une chaîne,var_destinataire est une chaîne,var_sujet est une chaîne,var_message est une chaîne,var_nom_attache est une chaîne, var_fichier_attache est une chaîne,var_envoi est un booléen)
     
    // Ouverture d'une session SMTP
    MaSession est un EmailSessionSMTP
    MonMessage est un Email
    monAttache est un EmailAttache
     
    var_envoi = False 
     
    // Session 
    MaSession..AdresseServeur = var_serveur
    MaSession .Nom		     = var_expediteur
    MaSession .MotDePasse	     = var_password
    MaSession .Option	     =  emailOptionSécuriséTLS	
    MaSession .Port		     =  587
     
    SI EmailOuvreSession(MaSession)=False  ALORS	
    	Erreur("Session SMTP non ouverte")	
    	RETOUR	
    FIN
     
    // Remplissage email 
    MonMessage..Expediteur = var_expediteur
    MonMessage..Destinataire[1] = var_destinataire
    MonMessage..Sujet = var_sujet
    MonMessage..Message = var_message
     
    // Construction de la variable EmailAttache
    monAttache..Nom = var_nom_attache
    monAttache..Contenu = var_fichier_attache
    monAttache..ContentType = "application/pdf"
    monAttache..ContentDescription = "Un document PDF"
     
    // Ajout de la pièce jointe
    Ajoute(MonMessage..Attache, monAttache)
     
    // Envoi du message
    SI EmailEnvoieMessage(MaSession, MonMessage)=False ALORS 
    	Erreur("Problème d'envoi du mail")
    ELSE
    	var_envoi = True
    FIN
    Ca fonctionne le mail part avec la pièce jointe au format PDF ...

    Quand je veux ouvrir la pièce jointe au format PDF après réception par mail , j'ai le message suivant
    Nom : Sans titre.png
Affichages : 10
Taille : 7,7 Ko

    Initialement le fichier PDF est lisible avant l'envoi

    J'ai mis les paramètre PDF dans la construction de la pièce jointe

    J'aurais oublié quoi ?

    Merci d'avance

    Philippe

  5. #5
    Membre régulier
    Homme Profil pro
    Développeur indépendant
    Inscrit en
    mai 2002
    Messages
    225
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Développeur indépendant

    Informations forums :
    Inscription : mai 2002
    Messages : 225
    Points : 114
    Points
    114

    Par défaut

    J'avais dans cette ligne de faire un fchargetexte

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    monAttache..Contenu = fChargeTexte(var_fichier_attache)

    Philippe

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [Débutant] Visual Studio Code: Runtime 'node' introuvable dans PATH
    Par Joachim94 dans le forum Visual Studio
    Réponses: 0
    Dernier message: 29/12/2016, 08h08
  2. [Python 3.X] api-ms-win-crt-runtime-l1-1-0.dll is missing lors du lancement de Python
    Par Cat21 dans le forum Général Python
    Réponses: 0
    Dernier message: 30/11/2016, 00h45
  3. Réponses: 10
    Dernier message: 04/04/2007, 16h02
  4. Html dans API
    Par Sn@dg dans le forum Bibliothèques
    Réponses: 7
    Dernier message: 13/08/2005, 15h25
  5. Utilisation de Pointeurs dans API windows
    Par Drooxy dans le forum API, COM et SDKs
    Réponses: 4
    Dernier message: 13/03/2003, 22h39

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo