1. #1
    Nouveau membre du Club
    Inscrit en
    mai 2002
    Messages
    52
    Détails du profil
    Informations forums :
    Inscription : mai 2002
    Messages : 52
    Points : 38
    Points
    38

    Par défaut GlobaVar : Problème de / répertoire

    Bonjour,

    Je débute avec Talend et je galère sur un point tout bête ....

    Dans une variable Globale j'ai stocké le nom d'un répertoire et le début du nom du fichier : c:\PAUL\pol

    Le but est d'utiliser cette variable dans tAdvancedFileOutputXML pour gérer facilement les dossiers et noms de XML que je dois créer
    J'ai mis dans "nom de fichiers" : ((String) globalMap.get("myKey") + ".xml")

    Mais j'ai un souci avec ces satané "\" j'ai essayé pas mal de chose et rien ne semble fonctionner...

    c:\PAUL\pol
    c:\\PAUL\\pol
    c:/PAUL/pol


    Je tourne sous Windows7

    D'avance merci

    Nom : talend_1.png
Affichages : 20
Taille : 8,9 KoNom : talend_2.png
Affichages : 23
Taille : 6,9 Ko

  2. #2
    Membre éclairé Avatar de MythOnirie
    Homme Profil pro
    Développeur décisionnel
    Inscrit en
    juin 2012
    Messages
    333
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Puy de Dôme (Auvergne)

    Informations professionnelles :
    Activité : Développeur décisionnel

    Informations forums :
    Inscription : juin 2012
    Messages : 333
    Points : 680
    Points
    680

    Par défaut

    Bonjour,

    Quelle est l'erreur ?

  3. #3
    Nouveau membre du Club
    Inscrit en
    mai 2002
    Messages
    52
    Détails du profil
    Informations forums :
    Inscription : mai 2002
    Messages : 52
    Points : 38
    Points
    38

    Par défaut

    Aucune erreur Talend, mais il ne me crée pas le fichier dans le répertoire.

    Et si je met un "nom de fichier xml" directement dans l'objet "tAdvancedFileoutputXML" alors la ça fonctionne.

    du coup je me dis que mon répertoire stocké dans la globalVar ne doit pas être bon

  4. #4
    Membre éclairé Avatar de MythOnirie
    Homme Profil pro
    Développeur décisionnel
    Inscrit en
    juin 2012
    Messages
    333
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Puy de Dôme (Auvergne)

    Informations professionnelles :
    Activité : Développeur décisionnel

    Informations forums :
    Inscription : juin 2012
    Messages : 333
    Points : 680
    Points
    680

    Par défaut

    Comment sont liés les différents composants ?

  5. #5
    Nouveau membre du Club
    Inscrit en
    mai 2002
    Messages
    52
    Détails du profil
    Informations forums :
    Inscription : mai 2002
    Messages : 52
    Points : 38
    Points
    38

    Par défaut

    Tout est en OnSubJobOk :

    tMSSqlConnection_1 --> tSetGlobalVar_1 --> tRunJob_1


    tRunJob_1 contient ceci :

    tMSSqlConnection_1 --> tMSSqlInput_2 -[Main]-> tAdvancedFileOutputXML_2

  6. #6
    Membre éclairé Avatar de MythOnirie
    Homme Profil pro
    Développeur décisionnel
    Inscrit en
    juin 2012
    Messages
    333
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Puy de Dôme (Auvergne)

    Informations professionnelles :
    Activité : Développeur décisionnel

    Informations forums :
    Inscription : juin 2012
    Messages : 333
    Points : 680
    Points
    680

    Par défaut

    Les variables globales ne sont pas propagées aux jobs fils.

  7. #7
    Nouveau membre du Club
    Inscrit en
    mai 2002
    Messages
    52
    Détails du profil
    Informations forums :
    Inscription : mai 2002
    Messages : 52
    Points : 38
    Points
    38

    Par défaut

    Ok effectivement le souci vient de la.

    Du coup je vais re regarder du côté des contextes.

  8. #8
    Nouveau membre du Club
    Inscrit en
    mai 2002
    Messages
    52
    Détails du profil
    Informations forums :
    Inscription : mai 2002
    Messages : 52
    Points : 38
    Points
    38

    Par défaut

    Merci pour ton aide !!

    j'ai pu faire ce que je voulais avec les contextes

  9. #9
    Membre éclairé Avatar de MythOnirie
    Homme Profil pro
    Développeur décisionnel
    Inscrit en
    juin 2012
    Messages
    333
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Puy de Dôme (Auvergne)

    Informations professionnelles :
    Activité : Développeur décisionnel

    Informations forums :
    Inscription : juin 2012
    Messages : 333
    Points : 680
    Points
    680

    Par défaut

    De rien.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [JAR / Linux] Problème de répertoire courant
    Par Nanawel dans le forum Langage
    Réponses: 8
    Dernier message: 01/07/2007, 17h24
  2. Problème classpath/répertoires sources
    Par Aéris22 dans le forum Eclipse Java
    Réponses: 3
    Dernier message: 21/04/2007, 16h58
  3. Problème protection répertoire avec .htaccess
    Par Silvia12 dans le forum Apache
    Réponses: 1
    Dernier message: 13/05/2006, 13h40
  4. [File] Problème de répertoire courant
    Par seb_asm dans le forum Applets
    Réponses: 5
    Dernier message: 03/05/2005, 19h44

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo