1. #1
    Nouveau membre du Club
    Homme Profil pro
    Lycéen
    Inscrit en
    février 2013
    Messages
    48
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Lycéen
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : février 2013
    Messages : 48
    Points : 28
    Points
    28

    Par défaut quel version de sdk choisir

    bonjour à tous en voulant ,créer une application androïd de la version minsdk 16 à la version maximale =>24 , ou plutôt "target" je me suis rendu compte que sans même avoir installer la version 16 de l'API je pouvait quand même commencer à programmer ,pourriez vous m'expliquer comment , et quelle différence si j 'installe l'API 16 svp ?

  2. #2
    Modérateur
    Avatar de grunk
    Homme Profil pro
    Architecte Web / Android
    Inscrit en
    août 2003
    Messages
    4 582
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : France, Côte d'Or (Bourgogne)

    Informations professionnelles :
    Activité : Architecte Web / Android
    Secteur : Industrie

    Informations forums :
    Inscription : août 2003
    Messages : 4 582
    Points : 11 730
    Points
    11 730

    Par défaut

    Il y'a trois choses différentes :

    min sdk version : La version minimal qu'un appareil devra avoir pour faire tourner ton application. Celà veux dire que tu ne pourra pas utiliser (sans test préalable, ou alternative) des API qui n'existe pas dans cette version
    target sdk version : La version pour laquelle ton application à été concu; C'est en quelque sorte la cible idéal.
    compile sdk version : La version avec la quelle l'application est compilé. En général elle est égale à target sdk version.

    Donc si tu cible le SDK 24 et que tu compile avec le 24 c'est le seul que tu as besoin d'avoir installer pour commencer à travailler. Il faudra néamoins tester toute les version majeure jusqu'à la 16 avant de diffuser ton application pour être certains qu'elle fonctionne correctement.
    Pry Framework php5 | N'oubliez pas de consulter les FAQ Java et les cours et tutoriels Java

  3. #3
    Nouveau membre du Club
    Homme Profil pro
    Lycéen
    Inscrit en
    février 2013
    Messages
    48
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Lycéen
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : février 2013
    Messages : 48
    Points : 28
    Points
    28

    Par défaut re

    si mon aplpication marche pour sdk 24 ,ça va marcher automatiquement pour sdk 16 , justement quand je compile j ai pas d'erreur ,et visiblement je peux dev pour min sdk 16 , alors que je n'ai pas télécharger
    sdk 16

  4. #4
    Nouveau membre du Club
    Homme Profil pro
    Lycéen
    Inscrit en
    février 2013
    Messages
    48
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Lycéen
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : février 2013
    Messages : 48
    Points : 28
    Points
    28

    Par défaut re

    ok , j 'ai compris donc même si j ai pas de bug a la compilation , je dois tester carrément pour chaque version de 16 a 24 , comment je fais pour tester pour toutes les versions ?

  5. #5
    Modérateur
    Avatar de grunk
    Homme Profil pro
    Architecte Web / Android
    Inscrit en
    août 2003
    Messages
    4 582
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : France, Côte d'Or (Bourgogne)

    Informations professionnelles :
    Activité : Architecte Web / Android
    Secteur : Industrie

    Informations forums :
    Inscription : août 2003
    Messages : 4 582
    Points : 11 730
    Points
    11 730

    Par défaut

    Il suffit de lancer des émulateur avec la version d'android que tu veux tester et d'executer ton application dessus.
    Pry Framework php5 | N'oubliez pas de consulter les FAQ Java et les cours et tutoriels Java

  6. #6
    Nouveau membre du Club
    Homme Profil pro
    Lycéen
    Inscrit en
    février 2013
    Messages
    48
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Lycéen
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : février 2013
    Messages : 48
    Points : 28
    Points
    28

    Par défaut re

    merci !

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Quel version choisir Visual Studio
    Par Mickybytes dans le forum Autres langages
    Réponses: 0
    Dernier message: 30/05/2016, 03h43
  2. Quel version d'Oracle choisir?
    Par cnguyen dans le forum Oracle
    Réponses: 8
    Dernier message: 18/05/2006, 20h48
  3. [Info]Quel base de données choisir
    Par bartmarley dans le forum JDBC
    Réponses: 6
    Dernier message: 19/01/2005, 12h42
  4. Quel type de projet choisir pour incorporer directX9...
    Par Coderm@n dans le forum DirectX
    Réponses: 6
    Dernier message: 02/08/2004, 13h24
  5. [Install] Quelle version d'Eclipse choisir
    Par yassine_23 dans le forum Eclipse Java
    Réponses: 6
    Dernier message: 13/05/2004, 15h57

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo