1. #1
    Expert éminent sénior Avatar de Menhir
    Homme Profil pro
    Ingénieur
    Inscrit en
    juin 2007
    Messages
    7 327
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Finistère (Bretagne)

    Informations professionnelles :
    Activité : Ingénieur

    Informations forums :
    Inscription : juin 2007
    Messages : 7 327
    Points : 13 366
    Points
    13 366

    Par défaut Problème d'installation : Base de données ne trouve pas JRE

    Bonjour,

    Je suis sous Win7 64b.
    Après de nombreuses années d'utilisation de MS Office, j'ai voulu m'essayer pour la première fois à (Apache) Open Office, surtout pour le module Base de données.

    J'ai donc installé la version 4.1.3.
    Tout s'est bien passé : Texte, Classeur, Dessin fonctionnent sans problème.

    Mais quand j'ai voulu utiliser Base de données, j'ai eu successivement les deux messages suivants :
    Nom : AOO_JRE.png
Affichages : 24
Taille : 27,6 Ko
    Pourtant, un fichier ODB est bien créé mais ces deux messages apparaissent dès que j'essaye d'accéder à n'importe quel élément (table, formulaire) de la base.

    Je suis donc allé sur le site Oracle pour installer Java 8.0.1440.1 - 64b.
    J'ai redémarré le PC.
    Mêmes messages.

    J'ai lu dans un document de la FAQ de Développez.com que pour faire fonctionner Base de données, il fallait que Java soit installé avant.
    J'ai donc désinstallé AOO, réinstallé, redémarré le PC : même messages.

    J'ai essayé de fouiller les premières pages du forum et de lancer une recherche, sans trouver de discussions correspondant à ce problème.

    Ne voyant pas quoi faire d'autre pour arranger la situation, je me retourne vers vous dans l'espoir que quelqu'un ait connaissance de ce problème et de sa solution.

    Merci d'avance à ceux qui s'y intéresseront.
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

  2. #2
    Membre expert
    Avatar de jurassic pork
    Homme Profil pro
    Bidouilleur
    Inscrit en
    décembre 2008
    Messages
    1 480
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Bidouilleur
    Secteur : Industrie

    Informations forums :
    Inscription : décembre 2008
    Messages : 1 480
    Points : 3 508
    Points
    3 508

    Par défaut

    hello,
    je pense que ton problème vient du fait que tu as installé la version 64 bits du jre. Comme OpenOffice est en 32 bits il faut que tu installes une version 32 bits du jre. Mais tu peux laisser aussi la version 64 bits du jre installée.

    Nom : Options - OpenOffice - Java.png
Affichages : 16
Taille : 34,1 Ko


    Petite question en passant : Pourquoi as-tu choisi OpenOffice plutôt que LibreOffice ?

    Ami calmant, J.P
    Jurassic computer : Sinclair ZX81 - Zilog Z80A à 3,25 MHz - RAM 1 Ko - ROM 8 Ko

  3. #3
    Expert éminent sénior Avatar de Menhir
    Homme Profil pro
    Ingénieur
    Inscrit en
    juin 2007
    Messages
    7 327
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Finistère (Bretagne)

    Informations professionnelles :
    Activité : Ingénieur

    Informations forums :
    Inscription : juin 2007
    Messages : 7 327
    Points : 13 366
    Points
    13 366

    Par défaut

    Citation Envoyé par jurassic pork Voir le message
    je pense que ton problème vient du fait que tu as installé la version 64 bits du jre. Comme OpenOffice est en 32 bits il faut que tu installes une version 32 bits du jre.
    Je te remercie pour cette information.
    En effet, je n'ai pas essayé la version 32 bits.

    J'avais essayé l'option que tu montres en image, mais quel que soit le répertoire de JRE choisi (racine, bin, lib, etc.), AOO me répondait qu'il ne contenait pas d'éditeur Java.
    Je vais voir si avec la version 32b ça fonctionne mieux.
    Je ferais un retour dans ce sujet.

    Petite question en passant : Pourquoi as-tu choisi OpenOffice plutôt que LibreOffice ?
    Je m'intéresse à OO surtout pour la base de données (pour tableur et traitement de texte, je resterai sans doute avec MSO).
    J'ai lu dans un sujet de ce forum qu'il y avait une grande différence pour cette partie entre OO et LO, que OO est plus simple, plus intuitif et plus proche de MSAccess.
    J'ai aussi trouvé plus de documentations (en français) concernant OO que LO.

    Mais, comme je l'ai écrit, OO et LO sont une expérience nouvelle pour moi.
    Il est possible qu'après avoir testé OOBase, j'essaye aussi LOBase pour comparer.
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

  4. #4
    Expert éminent sénior Avatar de Menhir
    Homme Profil pro
    Ingénieur
    Inscrit en
    juin 2007
    Messages
    7 327
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Finistère (Bretagne)

    Informations professionnelles :
    Activité : Ingénieur

    Informations forums :
    Inscription : juin 2007
    Messages : 7 327
    Points : 13 366
    Points
    13 366

    Par défaut

    Citation Envoyé par jurassic pork Voir le message
    je pense que ton problème vient du fait que tu as installé la version 64 bits du jre. Comme OpenOffice est en 32 bits il faut que tu installes une version 32 bits du jre. Mais tu peux laisser aussi la version 64 bits du jre installée.
    Je viens de tester en installant Java 32 bits (sans désinstaller la précédente).
    CA MARCHE !!!

    Je te remercie. Je n'aurais jamais pensé à faire comme ça.
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Problème Installation Base de donnée Oracle 11g XE
    Par Pimousse22 dans le forum Installation
    Réponses: 0
    Dernier message: 31/01/2015, 14h36
  2. Problème pour attacher base de données
    Par bpoulain dans le forum MS SQL-Server
    Réponses: 8
    Dernier message: 27/03/2006, 12h40
  3. problème avec ma base de donnée
    Par polace dans le forum PostgreSQL
    Réponses: 7
    Dernier message: 22/10/2005, 22h26
  4. problème avec ma base de données
    Par pmboutteau dans le forum ASP
    Réponses: 6
    Dernier message: 25/02/2005, 12h59
  5. Problême d'ouverture base de données
    Par comment_ca dans le forum Oracle
    Réponses: 20
    Dernier message: 14/12/2004, 12h39

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo