1. #1
    Membre à l'essai
    Profil pro
    Inscrit en
    février 2013
    Messages
    44
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2013
    Messages : 44
    Points : 20
    Points
    20

    Par défaut htaccess authentification dossier ET sous domaine

    Bonjour,

    Je développe des applications web, j'ai donc mis en place un environnement de "préproduction" où les utilisateurs peuvent voir l'évolution du projet et ainsi valider des évolutions ou correction de bug.

    Concrètement, le dossier contenant la préproduction est dans mon public_html sur le serveur avec une adresse de type : www.example.fr/~user/projet-preview sur lequel je fais pointer un sous domaine de type : http://preprod-projet.adresse.fr

    Pour sécuriser l'accès, différent des accès à l'environnement de développement, j'ai mis en place un Htaccess avec un Htpasswd.
    Si j'accède au lien avec l'utilisateur (premier lien), le serveur me demande bien mes identifiants. Cependant, par l'accès avec le sous domaine, il ne me demande pas de m'identifier.

    Le Htaccess :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
     
    AuthName "Projet PREPROD"
    AuthType Basic
    AuthUserFile "/pl/.htpasswd"ath
    Require valid-user
    Le fichier de configuration du sous domaine :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    <VirtualHost *:80>
            DocumentRoot /home/user/public_html/projet-preview
            ServerName preprod-projet.adresse.fr
            ServerAlias preprod-projet.adresse.fr
            ServerSignature Off
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /home/jeremie/public_html/base-preview>
                    Options -Indexes +FollowSymLinks
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    </VirtualHost>
    La plateforme est une Debian 8.8 avec un Apache 2.4.10. Je précise que l'environnement de développement et de préproduction sont sur le même serveur.

    J'ai cherché sur Google mais rien trouvé de probant.

    Merci de votre aide

  2. #2
    Membre à l'essai
    Homme Profil pro
    Analyste programmeur
    Inscrit en
    juillet 2017
    Messages
    9
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 27
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Analyste programmeur

    Informations forums :
    Inscription : juillet 2017
    Messages : 9
    Points : 12
    Points
    12

    Par défaut

    Bonjour,

    Je pense que le soucis provient de la déclaration du Virtualhost.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
     
    <VirtualHost *:80>
            DocumentRoot /home/user/public_html/projet-preview
            ServerName preprod-projet.adresse.fr
            ServerAlias preprod-projet.adresse.fr
            ServerSignature Off
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /home/jeremie/public_html/base-preview>
                    Options -Indexes +FollowSymLinks
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    </VirtualHost>
    Dans la section <Directory />, tu as une directive "AllowOverride None".
    Cette dernière indique à Apache de ne pas prendre en compte les fichiers .htaccess.
    Comme aucune autre règle ne vient contredire cette dernière, les fichiers .htaccess du site ne seront pas pris en compte.

    Pour résoudre ton problème, tu peux ajouter une nouvelle règle sur le dossier de ton projet pour autoriser le htaccess.
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
     
    <VirtualHost *:80>
            DocumentRoot /home/user/public_html/projet-preview
            ServerName preprod-projet.adresse.fr
            ServerAlias preprod-projet.adresse.fr
            ServerSignature Off
            <Directory />
                    Options FollowSymLinks
                    AllowOverride None
            </Directory>
            <Directory /home/jeremie/public_html/base-preview>
                    Options -Indexes +FollowSymLinks
                    AllowOverride None
                    Order allow,deny
                    allow from all
            </Directory>
    	<Directory /home/user/public_html/projet-preview>
    		AllowOverride All
    	</Directory>
    </VirtualHost>

  3. #3
    Membre à l'essai
    Profil pro
    Inscrit en
    février 2013
    Messages
    44
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2013
    Messages : 44
    Points : 20
    Points
    20

    Par défaut

    Salut,

    Merci pour ta réponse
    Il va s'en dire que la valeur de DocumentRoot et celle du bloc <Directory /home/jeremie/public_html/base-preview> sont identique
    Du coup, j'ai modifié la valeur de AllowOverride dans le bloc.

    Problème résolu
    Merci encore

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. .htaccess et rewrite de sous-domaine
    Par hargandalis dans le forum Apache
    Réponses: 2
    Dernier message: 08/02/2015, 21h15
  2. .htaccess pour gérer des sous-domaines
    Par Décibel dans le forum Apache
    Réponses: 4
    Dernier message: 15/05/2013, 10h07
  3. [.htaccess] Comment faire un sous-domaine
    Par pierrot10 dans le forum Apache
    Réponses: 1
    Dernier message: 24/06/2011, 08h19
  4. Un .htaccess pour supprimer les sous-domaines
    Par zarohn dans le forum Apache
    Réponses: 8
    Dernier message: 10/05/2011, 03h23

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo