1. #1
    Membre actif
    Profil pro
    Inscrit en
    février 2007
    Messages
    236
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2007
    Messages : 236
    Points : 258
    Points
    258

    Par défaut ORA-01017 sur linux lors de la connexion / as sysdba

    Bonjour,

    Sur mon serveur BDD SUSE 12 je me connecte oracle qui est membre du group dba
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
    grep oracle /etc/passwd
    oracle::491:490:Oracle user:/home/oracle:/bin/sh
     
    grep dba /etc/group
    dba::490:oracle
    mon $ORACLE_HOME et ORACLE_SID sont bien positionnés et exportés dans l'environnement courant.

    Je me connecte sans problème avec un compte (ex system)
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
     
    /home/oracle> sqlplus system
    SQL*Plus: Release 12.1.0.2.0 Production on Mon Jul 31 12:39:54 2017
    Copyright (c) 1982, 2014, Oracle.  All rights reserved.
     
    Enter password:
    Last Successful login time: Mon Jul 31 2017 12:34:15 +02:00
     
    Connected to:
    Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production
    With the Partitioning, OLAP, Advanced Analytics and Real Application Testing options
     
    SQL>
    Je ne me connecte pas avec / as sysdba
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
     
    SQL> connect / as sysdba
    ERROR:
    ORA-01017: invalid username/password; logon denied
     
    Warning: You are no longer connected to ORACLE.
    SQL>
    Qu'ai-je loupé ? Si quelqu'un a une idée...

    Pozzo.PtiteTete

  2. #2
    Membre averti
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    mai 2012
    Messages
    121
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : mai 2012
    Messages : 121
    Points : 321
    Points
    321

    Par défaut

    Bonjour,

    Jetez un coup d’œil dans le fichier sqlnet.ora, plus particulièrement au niveau du paramètre SQLNET.AUTHENTICATION_SERVICES. Si sa valeur est NONE, alors ce mode de connexion est désactivé. Vous pouvez le réactiver en supprimant ce paramètre ou en le valorisant à ALL

  3. #3
    Membre actif
    Homme Profil pro
    xxxxxxxxx
    Inscrit en
    avril 2015
    Messages
    179
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 49
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : xxxxxxxxx

    Informations forums :
    Inscription : avril 2015
    Messages : 179
    Points : 289
    Points
    289

    Par défaut ORA-01017 sur linux lors de la connexion as sysdba

    bonjour,


    refaire la même opération en utilisant la résolution du nom du service
    de la base via tnsnames.ora
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    connect  /@nom_de_la_base as sysdba
    et aussi vérifie ceci :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    select sys_context('userenv','authentication_method') from dual;

  4. #4
    Membre actif
    Profil pro
    Inscrit en
    février 2007
    Messages
    236
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : février 2007
    Messages : 236
    Points : 258
    Points
    258

    Par défaut

    Citation Envoyé par Baldrick Voir le message
    Bonjour,

    Jetez un coup d’œil dans le fichier sqlnet.ora, plus particulièrement au niveau du paramètre SQLNET.AUTHENTICATION_SERVICES. Si sa valeur est NONE, alors ce mode de connexion est désactivé. Vous pouvez le réactiver en supprimant ce paramètre ou en le valorisant à ALL
    J'avais laissé SQLNET.AUTHENTICATION_SERVICES sur NTS qui est "for Windows NT native authentication" d'après la documentation.
    Doc Oracle:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
     Authentication Methods Available with Oracle Net Services: 
        none for no authentication methods, including Windows native operating system authentication (to use Windows native operating system authentication, set this parameter to nts). When SQLNET.AUTHENTICATION_SERVICES is set to none, a valid user name and password can be used to access the database.
        all for all authentication methods
        nts for Windows native operating system authentication
     
    Authentication Methods Available with Oracle Advanced Security:  
        kerberos5 for Kerberos authentication
        radius for RADIUS authentication
        dcegssapi for DCE GSSAPI authentication
    Sur ALL cela fonctionne.

    Merci Baldrick.

    Pozzo
    PS: Merci à dell68 pour son intervention ^^

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. erreur 80072ee7 lors de la connexion sur internet
    Par devAd dans le forum Internet
    Réponses: 5
    Dernier message: 13/10/2007, 14h10
  2. Erreur ORA-04031 sur connexion sqlplus
    Par bigorj dans le forum Connexions aux bases de données
    Réponses: 9
    Dernier message: 28/08/2007, 13h18
  3. Erreur lors de l'Installation Oracle 10G sur linux X86
    Par yarold dans le forum Installation
    Réponses: 1
    Dernier message: 01/08/2007, 12h57
  4. Pb JDBC connexion avec FB 2 SS sur Linux
    Par ppelous dans le forum Connexion aux bases de données
    Réponses: 1
    Dernier message: 13/02/2007, 00h29
  5. [9i] ORA-01017 : 1er connexion
    Par OVAJHC dans le forum Oracle
    Réponses: 2
    Dernier message: 16/11/2005, 11h09

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo