IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Editeurs / Outils Discussion :

TexMaker et le processus d'encodage UTF-8


Sujet :

Editeurs / Outils

  1. #1
    Membre habitué
    Profil pro
    Inscrit en
    août 2009
    Messages
    542
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2009
    Messages : 542
    Points : 187
    Points
    187
    Par défaut TexMaker et le processus d'encodage UTF-8
    Bonjour,

    Quand j'ouvre un fichier .tex déjà réalisé, j'obtiens le message :

    Nom : message UTF-8.PNG
Affichages : 572
Taille : 7,4 Ko

    Pourtant, le code Latex comporte bien la ligne suivante :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    \usepackage[utf8]{inputenc}
    1) Est-ce qu'il faut aussi définir le processus d'encodage que l'on souhaite au niveau des options de l'éditeur TexMaker ?

    2) Si c'est le cas, où est-ce que celà se situe dans TexMaker ? Je n'ai pas encore trouvé.

    MErci d'avance pour votre aide.

  2. #2
    Expert éminent sénior

    Avatar de -Nikopol-
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2013
    Messages
    2 174
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Haute Marne (Champagne Ardenne)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Enseignement

    Informations forums :
    Inscription : mai 2013
    Messages : 2 174
    Points : 11 284
    Points
    11 284
    Billets dans le blog
    5
    Par défaut
    Par défaut, TEXMAKER encode en UTF-8. Si tu fais un copié-collé d'un document ayant un autre encodage (Latin-1 par exemple) TEXMAKER te signale qu'il risque d'y avoir des erreurs, dans le document copié. Tu peux changer l'encodage par défaut de TEXMAKER, mais si ce n'est que pour du ponctuel, je te conseille de rester en UTF-8 et de relire le .tex

  3. #3
    Membre habitué
    Profil pro
    Inscrit en
    août 2009
    Messages
    542
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2009
    Messages : 542
    Points : 187
    Points
    187
    Par défaut
    Merci pour ton retour.
    C'est donc bizarre que je reçoive ce message sachant que le fichier .tex a été encodé en UTF-8.

    Nom : code source.PNG
Affichages : 527
Taille : 16,5 Ko
    Nom : message erreur package label.PNG
Affichages : 585
Taille : 51,5 Ko

    1) Comment est-ce que je peux faire pour ne plus recevoir ce message à l'ouverture du fichier .tex?
    2) Comment supprimer l'erreur de compilation liée à la ligne 1 (cf copie d'écran) qui doit être en lien avec l'encodage ?

    Merci d'avance pour tes conseils.

  4. #4
    Expert éminent sénior

    Avatar de -Nikopol-
    Homme Profil pro
    Développeur Web
    Inscrit en
    mai 2013
    Messages
    2 174
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Haute Marne (Champagne Ardenne)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Enseignement

    Informations forums :
    Inscription : mai 2013
    Messages : 2 174
    Points : 11 284
    Points
    11 284
    Billets dans le blog
    5
    Par défaut
    1) Comment est-ce que je peux faire pour ne plus recevoir ce message à l'ouverture du fichier .tex?
    essaye un copié collé dans un éditeur plus neutre,genre le bloc note de windows, enregistre le fichier et recopie le dans TEXMAKER. Il me semble avoir déjà lu que cette méthode fonctionnait.
    2) Comment supprimer l'erreur de compilation liée à la ligne 1 (cf copie d'écran) qui doit être en lien avec l'encodage ?
    _Karnaj_, t'as déjà répondu dans la discussion à ce sujet.

  5. #5
    Membre habitué
    Profil pro
    Inscrit en
    août 2009
    Messages
    542
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : août 2009
    Messages : 542
    Points : 187
    Points
    187
    Par défaut
    En fait, j'ai vérifié dans les options et l'encodage n'était plus sur UTF-8.
    Je l'ai remis sur UTF-8 et celà devrait donc aller.
    Merci pour ton aide.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [DOM] Encodage UTF-8 dans fichier XML et PHP
    Par norkius dans le forum Bibliothèques et frameworks
    Réponses: 7
    Dernier message: 03/01/2007, 15h44
  2. Problème d'affichage avec encodage utf-8
    Par t-die dans le forum Zend
    Réponses: 3
    Dernier message: 04/12/2006, 14h55
  3. [C# 2.0] Comment réaliser un encodage UTF-8 ?
    Par StormimOn dans le forum C#
    Réponses: 2
    Dernier message: 18/10/2006, 10h35
  4. Pb Encodage UTF-8 pour Ooo
    Par Sylvain James dans le forum XMLRAD
    Réponses: 10
    Dernier message: 08/03/2006, 22h28
  5. [WebForms] Encodage, UTF-8 et accents
    Par alexischmit dans le forum Général Dotnet
    Réponses: 4
    Dernier message: 28/04/2004, 12h21

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo