1. #1
    Candidat au Club
    Homme Profil pro
    Consultant fonctionnel
    Inscrit en
    juillet 2017
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Consultant fonctionnel

    Informations forums :
    Inscription : juillet 2017
    Messages : 4
    Points : 3
    Points
    3

    Par défaut ora 12505 avec sql developer mais fonctionne bien dans sqlplus

    Bonsoir
    j'ai un soucis avec sql developer, qui marché tres bien et il a planté
    et du coup je ne pêux plus me connecter à ma base de donnée
    j'ai un message ora-12505 j'ai recherché tous les messages portant sur ce soucis et apres avoir regarder les differentes solutions, je peux me connecter a partir de sql plus, mais pas avec sql developer qui me donne l'erreur :
    ora-12505 TNS listener doesn't currently know of SID given in connect descriptor.
    et en lancant le lsnrctl status, je me rends compte que sur la derniere ligne il me dit
    L'instance "CLRExtProc", statut UNKNOWN, comporte 3 gestionnaire(s) pour ce service...
    est ce normal qu'il y a 3 gestionnaires ? alors que sur les videos que j'ai regardé pour ce probleme il n'en y avait qu'1
    quelqu'un a une solution pour moi ? merci de votre aide

  2. #2
    Expert Oracle confirmé

    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    mars 2003
    Messages
    361
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Administrateur de base de données
    Secteur : Conseil

    Informations forums :
    Inscription : mars 2003
    Messages : 361
    Points : 731
    Points
    731

    Par défaut

    Bonjour,

    Ne vous focalisez pas sur CLRExtProc qui est le SID configuré par défaut dans le Listerner.ora, et qui sert lorsque l'on utilise Microsoft .Net (CLR = Common Language Runtime).

    Puisque votre connexion SQL*Plus fonctionne, c'est juste votre connexion sous SqlDeveloper qui semble mal paramétrée.

    Pour vous connectez sous SQL*Plus, vous lancez normalement quelque chose comme cela :

    sqlplus compte/password@base
    Et bien au niveau des paramètres de votre connexion SqlDeveloper, il suffit de :

    1) choisir TNS dans la liste déroulante "Type de connexion"

    2) puis dans la liste déroulante "Alias de réseau" qui apparaît, vous devriez retrouver la valeur base.

    Si cette liste est vide, c'est qu'il faut gérer auparavant la variable TNS_ADMIN soit dans votre base de registre, soit comme variable d'environnement.



    Une autre manière de se connecter sous SqlDevelopper est de connaître les 3 valeurs essentielles (qui figurent dans le TNSNAMES.ORA) :
    - HOST
    - PORT
    - SID ou SERVICE_NAME

    Une fois que vous avez les valeurs de ces paramètres, sous SqlDevelepor vous choisissez cette fois-ci De base dans la liste déroulante "Type de connexion", puis vous renseignez ces 3 valeurs.

    HOST va dans Nom d'hôte
    PORT va dans Port
    Si vous avez un SID, cela va dans SID. Et si vous avec un SERVICE_NAME et non pas un SID, cela va dans Nom de service

  3. #3
    Candidat au Club
    Homme Profil pro
    Consultant fonctionnel
    Inscrit en
    juillet 2017
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Consultant fonctionnel

    Informations forums :
    Inscription : juillet 2017
    Messages : 4
    Points : 3
    Points
    3

    Par défaut

    Bonjour Merci pour la réponse.
    Malheureusement je ne pourrais pas tester votre solution pour savoir si cela aurait fonctionné dans mon cas, en effet, pour résoudre mon
    probleme j'ai tout désinstallé et réinstallé.
    Et maintenant ça fonctionne correctement.
    Merci.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Client oracle avec Toad mais pas avec SQL Developer
    Par Ikebukuro dans le forum Débuter
    Réponses: 1
    Dernier message: 14/01/2016, 11h30
  2. Réponses: 3
    Dernier message: 05/08/2009, 12h41
  3. Erreur de connexion avec SQL Developer
    Par 4rocky4 dans le forum Connexions aux bases de données
    Réponses: 1
    Dernier message: 25/05/2009, 14h41
  4. fichier shell qui ne fonctionne pas avec le cron mais fonctionne dans le shell
    Par diabli73 dans le forum Shell et commandes GNU
    Réponses: 4
    Dernier message: 20/10/2008, 20h12
  5. ORA-00904 avec SQL dynamique
    Par pascal_T dans le forum PL/SQL
    Réponses: 10
    Dernier message: 10/10/2008, 15h46

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo