1. #1
    Candidat au Club
    Homme Profil pro
    Conseil - Consultant en systèmes d'information
    Inscrit en
    juin 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Conseil - Consultant en systèmes d'information

    Informations forums :
    Inscription : juin 2017
    Messages : 3
    Points : 2
    Points
    2

    Par défaut Prise en charge des caractères accentués des valeurs de paramètres d'un build

    Bonjour,

    J'utilise actuellement Jenkins en version 2.32.2 sur un serveur Windows sous Tomcat 7.0.73, et je me retrouve avec un soucis dans la gestion des caractères accentués.
    * Tout d'abord, l'affichage des caractères accentués n'est pas toujours propre. En effet, sur les builds qui lancent des scripts .sh sur un serveur Linux, via une connexion SSH, les caractères accentués sont mal interprétés alors que tout est OK pour les builds qui lancent des scripts .bat lancés directement sur le serveur Jenkins (en Windows donc). Comme il s'agit d'affichage de log, ce n'est pas très grave mais pas propre; si vous avez une idée d'où celà peut venir, je suis preneur.

    * Le point le plus embêtant se trouve au niveau de builds lancé sur le serveur Jenkins (Windows) et ayant des valeurs de paramètres de lancements avec caractères accentués.
    Exemple: j'ai un build TOTO ayant comme paramètres de lancement une chaîne de caractères qui peut contenir des caractères accentués. Ce build fait appel à un .bat qui est exécuté sur le serveur Windows Tomcat et qui fait tourner Jenkins.
    Je me rends compte que lors de l'appel au .bat, Jenkins transforme les caractères accentués et donc mes builds tombent systématiquement en erreur. Le mot "Conformité" par exemple est transformé en "Conformit," (avec une virgule à la place du é).

    En faisant quelques recherches sur les possibilités d'encodage, j'ai modifié la configuration Tomcat pour y ajouter l'option Java "-Dfile.encoding=UTF8" dans l'IHM du programme "Configure Tomcat", onglet "Java".

    PI, dans mon fichier server.xml de Tomcat, j'ai:
    <Connector port="8080" protocol="HTTP/1.1"
    connectionTimeout="20000"
    redirectPort="8443"
    URIEncoding="UTF-8"
    />

    Auriez-vous des pistes ou des suggestions, sachant que mon Jenkins est en français; voici son systemInfo qui me semble d'ailleurs bizarre quand aux valeurs:
    file.encoding Cp1252
    file.encoding.pkg sun.io

    Peut-être le file.encoding qui pose problème ? Mais pas trouvé comment le modifier.

    Merci de votre aide.

  2. #2
    Candidat au Club
    Homme Profil pro
    Conseil - Consultant en systèmes d'information
    Inscrit en
    juin 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Conseil - Consultant en systèmes d'information

    Informations forums :
    Inscription : juin 2017
    Messages : 3
    Points : 2
    Points
    2

    Par défaut

    Bonjour,

    Petit up. Peut-être que ma description n'est pas claire ?

  3. #3
    Candidat au Club
    Homme Profil pro
    Conseil - Consultant en systèmes d'information
    Inscrit en
    juin 2017
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Conseil - Consultant en systèmes d'information

    Informations forums :
    Inscription : juin 2017
    Messages : 3
    Points : 2
    Points
    2

    Par défaut

    J'ai finalement trouvé la solution en faisant des recherches Google avec le mot clé "accents" plutôt que "unicode" ou "special characters" etc....
    J'ai rajouté une commande à mon build: chcp 1252

    Source: https://issues.jenkins-ci.org/browse/JENKINS-24132

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 8
    Dernier message: 19/07/2007, 17h18
  2. Problème d'affichage des caractères accentués
    Par ostaquet dans le forum JBuilder
    Réponses: 1
    Dernier message: 10/03/2005, 07h58
  3. [FLASH MX2004] Pb sur des caractères accentués.
    Par sandrineLL dans le forum Flash
    Réponses: 3
    Dernier message: 05/08/2004, 15h18
  4. Chaînes avec des caractères accentués dans Interbase
    Par François Marliac dans le forum Bases de données
    Réponses: 2
    Dernier message: 04/03/2004, 23h39
  5. insérer des caractères accentués INFORMIX/JDBC
    Par donde dans le forum Informix
    Réponses: 2
    Dernier message: 19/11/2002, 21h02

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo