Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Modules Perl Discussion :

[Mail::Sender] problème d'utilisation


Sujet :

Modules Perl

  1. #1
    Nouveau membre du Club
    Profil pro
    Inscrit en
    octobre 2004
    Messages
    29
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2004
    Messages : 29
    Points : 25
    Points
    25
    Par défaut [Mail::Sender] problème d'utilisation
    Bonjour à tous.

    J'ai un soucis avec l'utilisation du module Mail::Sender.
    Depuis peu, on me demande d'envoyer les mails à travers une passerelle SMTP Exchange. Ce modèle de passerelle me demande une authentification et là, je sèche, malgré tous mes tests.

    Actuellement, mon script ressemble à ça ( je n'ai pas mis tout la partie du script qui n'apporte rien aux explications ) :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
     
    my $sender = new Mail::Sender{smtp => $Passerelle_smtp};
    $sender->MailFile({to      => join (',', @touserTab),
                          from    => $fromuser[0],
                          cc      => join (',', @toccuser),
                          bcc     => join (',', @tobccuser),
                          subject => $subject[0],
                          msg     => $body,
                          file    => \@filetosend});
    Afin de mettre en place l'authentification, j'essaye de valoriser de la manière suivante :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
     
    my $sender = new Mail::Sender{smtp => $Passerelle_smtp};
    $fromuser[0]='xxx@yyy.com';
     
    open my $DEBUG, "> fichier_de_debug"  or die "Can't open the debug file: $!\n";
     
       $sender->MailFile({to      => join (',', @touserTab),
                          from    => $fromuser[0],
                          cc      => join (',', @toccuser),
                          bcc     => join (',', @tobccuser),
                          subject => $subject[0],
                          msg     => $body,
                          debug   => $DEBUG,
                          auth    => 'xxx@yyy.com',
                          authdomain => fr,
                          authid  => 'xxx@yyy.com',
                          authpwd => 'mot_de_passe',
                          file    => \@filetosend});
    En essayant plusieurs écriture dans les paramètres auth ou authid, j'ai soit le message d'erreur :
    Authentication protocol xxx@yyy.COM is not accepted by the server

    soit le message d'erreur :
    Server error: 530 5.7.1 Client was not authenticated

    Si vous avez une idée à me soumettre pour l'écriture des paramètres, je suis preneur

  2. #2
    Nouveau membre du Club
    Profil pro
    Inscrit en
    octobre 2004
    Messages
    29
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : octobre 2004
    Messages : 29
    Points : 25
    Points
    25
    Par défaut
    Bon, ben, je présente mes excuses.
    J'ai simplement mal lu la documentation

    Il suffit de mettre
    et sa passe. Je clôt le sujet

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 4
    Dernier message: 20/03/2008, 18h38
  2. Problème étrange avec Mail::Sender
    Par Arioch dans le forum Modules
    Réponses: 17
    Dernier message: 01/11/2007, 13h42
  3. [Mail] fonction mail : problème d'utilisation
    Par leclone dans le forum Langage
    Réponses: 4
    Dernier message: 13/02/2007, 17h02
  4. Problème d'utilisation de Mysql avec dev-c++
    Par Watchi dans le forum Dev-C++
    Réponses: 10
    Dernier message: 06/08/2004, 14h35
  5. problème d'utilisation avec turbo pascal 7.0
    Par le 27 dans le forum Turbo Pascal
    Réponses: 4
    Dernier message: 03/12/2003, 10h44

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo