1. #1
    Membre à l'essai
    Homme Profil pro
    Développeur Web
    Inscrit en
    septembre 2011
    Messages
    16
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : septembre 2011
    Messages : 16
    Points : 18
    Points
    18

    Par défaut [Erreur] segmentation fault avec Apache2

    bonjour

    J'ai Apache/2.4.25 (Ubuntu) avec php 7.0.18-0ubuntu0.17.04.1.

    Un site que j'avais créé en Symfony 2 crache sans arrêt, alors qu'il marchait parfaitement avec php 5.
    Il y a peut être un souci avec les requêtes de mysql, mais je n'arrive pas à mettre la main dessus, car Apache plante et ne donne aucune indication.

    Y a-t-il une solution ?

    Ca vient de l'incompatibilité de l'apache avec php7,on me dit, mais je trouve que c'est un bug de php mais aussi une merde chez apache. Un serveur d'internet doit être stable et ne pas planter avec n'importe quelle erreur.

    merci d'avance pour votre aide.

  2. #2
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    6 345
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 6 345
    Points : 10 212
    Points
    10 212

    Par défaut

    est ce que vous avez tout installé à partir des paquets ? vous n'avez rien téléchargé manuellement et compilé sur le serveur

  3. #3
    Membre à l'essai
    Homme Profil pro
    Développeur Web
    Inscrit en
    septembre 2011
    Messages
    16
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : septembre 2011
    Messages : 16
    Points : 18
    Points
    18

    Par défaut paquets

    y a des petits paquets utilitaires de php, que j'ai installé à la main car j'ai pas trouvé dans les sources de apt, Sinon apache, php et mysql viennent directement de l'apt. Vous croyez que ca vient de là?

  4. #4
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    6 345
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 6 345
    Points : 10 212
    Points
    10 212

    Par défaut

    l'avantage d'utiliser uniquement des paquets est que les dépendance de ces paquets sont gérées automatiquement pour que tout fonctionne
    quels sont les utilitaires de PHP que vous n'avez pas trouvé ?

    et de l'autre côté, vous pouvez suivre le déroulement d'une exécution avec des outils de débugage comme xdebug par exemple. cela vous permettra de trouver à quelle ligne Apache plante.

  5. #5
    Membre à l'essai
    Homme Profil pro
    Développeur Web
    Inscrit en
    septembre 2011
    Messages
    16
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : septembre 2011
    Messages : 16
    Points : 18
    Points
    18

    Par défaut

    Je ne sais plus il y en a tellement... Je vais installer xdebug mais vu qu'il marchait avec php5 c'est pas normal qu''il marche pas avec php7. En plus apache qui plante à cause d'une simple requête...

    Merci en tout cas je reviens vers vous.

  6. #6
    Membre à l'essai
    Homme Profil pro
    Développeur Web
    Inscrit en
    septembre 2011
    Messages
    16
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : septembre 2011
    Messages : 16
    Points : 18
    Points
    18

    Par défaut Xdebug

    Xdebug ne donne rien.

    je commence à croire que le problème ne viens même pas du php mais d'un des paquets du mysql . C'est une requête qui déconne.
    Comment peut-on savoir si un paquet est installé à la main ou par apt ? s'il te plait .

Discussions similaires

  1. Réponses: 2
    Dernier message: 08/04/2007, 17h23
  2. Probleme de segmentation fault avec sprintf
    Par MathG dans le forum C++
    Réponses: 5
    Dernier message: 14/12/2006, 01h12
  3. [erreur] Segmentation fault
    Par fveysseire dans le forum C
    Réponses: 11
    Dernier message: 15/06/2006, 14h44
  4. Segmentation fault avec glCompressedTexImage2DARB
    Par patbier dans le forum OpenGL
    Réponses: 5
    Dernier message: 12/12/2005, 10h32
  5. Pb segmentation fault avec glutinit()
    Par pipistrelle dans le forum GLUT
    Réponses: 2
    Dernier message: 17/11/2004, 23h17

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo