1. #1
    Membre régulier
    Homme Profil pro
    Retraité Ing Electronique
    Inscrit en
    mars 2004
    Messages
    316
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 70
    Localisation : France, Côtes d'Armor (Bretagne)

    Informations professionnelles :
    Activité : Retraité Ing Electronique
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mars 2004
    Messages : 316
    Points : 116
    Points
    116

    Par défaut Débutant en URL Rewriting

    Bonjour,

    Mon hébergeur mettant à disposition cette fonctionnalité, je tente d'utiliser l'URL rewriting sur mon site.

    J'ai ajouté un nouveau domaine qui pointe sur le site.

    Dans la racine du site, j'ai mis le fichier .htaccess suivant :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    Options +FollowSymlinks
    RewriteEngine On
    RewriteBase /
    RewriteRule ^www.nouveaudomaine.com/art-[0-9]+)$ www.monsite.com/article.php?art=$1 [L]
    la RewriteRule transforme bien (testé avec un preg_replace())
    le lien après transformation ouvre bien la page demandée

    et lorsque j'utilise le lien www.nouveaudomaine.com/art-100 le site me répond : "The requested URL /art-100 was not found on this server."

    Pouvez vous m'indiquer où est l'erreur ?

    Merci

  2. #2
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    6 345
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 6 345
    Points : 10 212
    Points
    10 212

    Par défaut

    déjà il manque une parenthèse ouvrante et ensuite essayez la ligne suivante :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    RewriteRule ^art-([0-9]+)$ www.monsite.com/article.php?art=$1 [L]

  3. #3
    Membre régulier
    Homme Profil pro
    Retraité Ing Electronique
    Inscrit en
    mars 2004
    Messages
    316
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 70
    Localisation : France, Côtes d'Armor (Bretagne)

    Informations professionnelles :
    Activité : Retraité Ing Electronique
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mars 2004
    Messages : 316
    Points : 116
    Points
    116

    Par défaut

    Merci Mathieu,

    Pour la parenthèse ouvrante, c'est une erreur de transcription dans le poste, désolé.

    Avec
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    RewriteRule ^art-([0-9]+)$ www.monsite.com/article.php?art=$1 [L]
    Si je mets dans le lien www.nouveaudomaine.com/art-100, J'ai l'erreur : "The requested URL /www.monsite.com/article.php was not found on this server", alors que lorsque je mets directement le lien www.monsite.com/article.php?article.php=100

  4. #4
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    6 345
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 6 345
    Points : 10 212
    Points
    10 212

    Par défaut

    peut-être avec "http:" devant
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    RewriteRule ^art-([0-9]+)$ http://www.monsite.com/article.php?art=$1 [L]

  5. #5
    Membre régulier
    Homme Profil pro
    Retraité Ing Electronique
    Inscrit en
    mars 2004
    Messages
    316
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 70
    Localisation : France, Côtes d'Armor (Bretagne)

    Informations professionnelles :
    Activité : Retraité Ing Electronique
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mars 2004
    Messages : 316
    Points : 116
    Points
    116

    Par défaut

    Merci super, ça marche.

    Mais avec cette solution, j'ai un problème, car plusieurs domaines différents peuvent accéder au site et il me faudrait une règle pas domaine d'appel !
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    RewriteRule ^www.nouveaudomaine.com/art-[0-9]+)$ http://www.monsite.com/article.php?art=$1 [L]
    ou
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    RewriteRule ^http://www.nouveaudomaine.com/art-[0-9]+)$ http://www.monsite.com/article.php?art=$1 [L]
    mais ni l'un ni l'autre ne marchent, alors je reste coincé !

    Si quelqu'un a une idée, je suis preneur !

    Merci

  6. #6
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    6 345
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 6 345
    Points : 10 212
    Points
    10 212

    Par défaut

    pour tester le nom de domaine, vous pouvez rajouter une ligne "RewriteCond"

    regardez ces exemples :
    http://httpd.apache.org/docs/2.4/rew...#canonicalhost
    http://httpd.apache.org/docs/2.4/rew...ml#rewritecond

    et la documentation est là :
    http://httpd.apache.org/docs/2.4/mod...ml#rewritecond

  7. #7
    Membre régulier
    Homme Profil pro
    Retraité Ing Electronique
    Inscrit en
    mars 2004
    Messages
    316
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 70
    Localisation : France, Côtes d'Armor (Bretagne)

    Informations professionnelles :
    Activité : Retraité Ing Electronique
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mars 2004
    Messages : 316
    Points : 116
    Points
    116

    Par défaut

    Suite à votre proposition, J'ai tenté toutes les écritures ci-dessous
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    RewriteCond %{HTPP_HOST} www.nouveaudomaine.com
    RewriteCond %{HTPP_HOST} "www.nouveaudomaine.com"
    RewriteCond %{HTPP_HOST} ^www.nouveaudomaine.com$
    RewriteCond %{HTPP_HOST} "^www.nouveaudomaine.com$"
    RewriteCond "%{HTPP_HOST}" www.nouveaudomaine.com
    RewriteCond "%{HTPP_HOST}" "www.nouveaudomaine.com"
    RewriteCond "%{HTPP_HOST}" ^www.nouveaudomaine.com$
    RewriteCond "%{HTPP_HOST}" "^www.nouveaudomaine.com$"
    avec, à suivre, un
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    RewriteRule ^art-([0-9]+)$ http://www.monsite.com/article.php?art=$1 [L]
    Mais j'ai toujours le message d'erreur.
    Au cas où j'aurais fait une erreur dans la RewriteRule, j'ai tout de même vérifié qu'en retirant la condition ça marchait toujours : ça marche toujours !

  8. #8
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    6 345
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 6 345
    Points : 10 212
    Points
    10 212

    Par défaut

    Citation Envoyé par zakuli Voir le message
    Mais j'ai toujours le message d'erreur.
    quel message ?

  9. #9
    Membre régulier
    Homme Profil pro
    Retraité Ing Electronique
    Inscrit en
    mars 2004
    Messages
    316
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 70
    Localisation : France, Côtes d'Armor (Bretagne)

    Informations professionnelles :
    Activité : Retraité Ing Electronique
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mars 2004
    Messages : 316
    Points : 116
    Points
    116

    Par défaut

    Celle du début : "The requested URL /art-100 was not found on this server."

  10. #10
    Expert éminent sénior
    Avatar de mathieu
    Profil pro
    Inscrit en
    juin 2003
    Messages
    6 345
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2003
    Messages : 6 345
    Points : 10 212
    Points
    10 212

    Par défaut

    dans le message là vous disiez que vous n'avez plus cette erreur
    https://www.developpez.net/forums/d1...g/#post9353319

    il faudrait que vous repartiez du code de test qui fonctionne et ajouter les conditions une par une pour trouver laquelle crée cette erreur

Discussions similaires

  1. souci de débutant en url rewriting
    Par freshman dans le forum Apache
    Réponses: 2
    Dernier message: 14/04/2011, 10h04
  2. Réponses: 14
    Dernier message: 18/01/2009, 18h57
  3. [Débutant]infos ds session sans cookie ? url rewriting ?
    Par Satanas_et_diabolo dans le forum ASP
    Réponses: 8
    Dernier message: 10/10/2006, 17h13
  4. Débutant: URL rewriting
    Par pod1978 dans le forum Apache
    Réponses: 1
    Dernier message: 12/09/2006, 16h09
  5. [apache] débutant Url Rewriting :(
    Par camyo dans le forum Apache
    Réponses: 7
    Dernier message: 27/06/2006, 19h16

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo