1. #1
    Futur Membre du Club
    Profil pro
    Inscrit en
    mai 2008
    Messages
    7
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2008
    Messages : 7
    Points : 6
    Points
    6

    Par défaut <gtk/gtk.h> inconnu à la compilation

    salut, pas moyen qu'un simple prog en GTK fonctionne:
    la ligne " #include <gtk/gtk.h> " ne passe pas à la compil: erreur <gtk/gtk.h> non trouvé
    je suis sous linux/debian et GTK, la GLIb et tout ce qu'il faut sont pourtant installés et je retrouve bien gtk/gtk.h sous /usr/include/gtk-2.0 !
    (si je fais un simple prog. incluant stdio.h, il n'y a aucun problème)
    une idée du pourquoi du comment ?

    merci

  2. #2
    Futur Membre du Club
    Profil pro
    Inscrit en
    mai 2008
    Messages
    7
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2008
    Messages : 7
    Points : 6
    Points
    6

    Par défaut résolu

    en lisant les incidents similaires, je m'aperçois que moi non plus je n'ai pas mis les bons quotes autour de pkg-config etc.
    en corrigeant, çà fonctionne!
    merci à ceux qui ont solutionné le problème

  3. #3
    Membre chevronné
    Homme Profil pro
    Développeur informatique
    Inscrit en
    juin 2009
    Messages
    1 242
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : juin 2009
    Messages : 1 242
    Points : 1 837
    Points
    1 837

    Par défaut

    Petite info: GTK 2, c'est (très) vieux, passe au moins à GTK 3, qui existe depuis déjà 6 ans !

  4. #4
    Membre régulier Avatar de Persistant
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    septembre 2016
    Messages
    50
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : septembre 2016
    Messages : 50
    Points : 73
    Points
    73

    Par défaut Mon grain de selle...

    Bonjour à tous,

    liberforce, c'est carrément martial comme commentaire.

    Si ca se trouve perlin (l'anchanteur) a besoin d'une API stable et ne souhaite pas gaspiller sont temps a faire des GTK_CHECK_VERSION a chaque nouvelle release au lieu d’investir son temps à faire évoluer son logiciel.

    Il suffit de lire quelques postes de luke-spywoker pour comprendre les problèmes que l'utilisation des dernière technologie version entraîne.

    Gnome a fait le choix de rester a la pointe en utilisant les dernière version de Gtk mais eut ils ont une armée de développeur...

    Perlin, pour info, je crois qu'on appel ` un accent grave:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    echo `pkg-config --cflags glib-2.0`
    Et, tu peux le remplacer par des parenthèses
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    echo $(pkg-config --cflags glib-2.0)

    Crlt

  5. #5
    Membre chevronné
    Homme Profil pro
    Développeur informatique
    Inscrit en
    juin 2009
    Messages
    1 242
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : juin 2009
    Messages : 1 242
    Points : 1 837
    Points
    1 837

    Par défaut

    Citation Envoyé par Persistant Voir le message
    Si ca se trouve perlin (l'anchanteur) a besoin d'une API stable et ne souhaite pas gaspiller sont temps a faire des GTK_CHECK_VERSION a chaque nouvelle release au lieu d’investir son temps à faire évoluer son logiciel.
    Euh... Si tu penses que le gars qui n'arrive pas à faire un #include de gtk.h est un mainteneur de logiciel avec une forte dépendance à la version de GTK, je pense que tu as un problème d'évaluation de ton interlocuteur.

    Citation Envoyé par Persistant Voir le message
    Il suffit de lire quelques postes de luke-spywoker pour comprendre les problèmes que l'utilisation des dernière technologie version entraîne.
    Ce que tu appelles "dernière technologie/version" est sorti il y a 6 ans. Certes, ça n'avait pas le même degré de maturité à l'époque, mais ça fait plusieurs années que c'est la version stable officielle. Même Debian Wheezy (oldstable, donc la version antérieure à la stable actuelle) embarque GTK 3.4. Alors, faut peut être pas pousser sur la nouveauté. Mon commentaire vient surtout du fait que beaucoup de tutos, y compris ici, n'ont jamais été mis à jour, et sont restés "gelés" sur GTK 2. Les débutants suivent les tutos sans regarder s'ils sont encore à jour ou valables.

    Je fais aussi ce rappel parce que GTK 4 pointe le bout de son nez, et que le rythme de parution des versions de GTK va s'accélérer. Il n'y a aucune justification à utiliser GTK 2 dans un nouveau projet.

    Citation Envoyé par Persistant Voir le message
    Gnome a fait le choix de rester a la pointe en utilisant les dernière version de Gtk mais eut ils ont une armée de développeur...
    GNOME n'a pas "une armée de développeurs", c'est une fondation aux USA, une association au niveau francophone, des bénévoles (beaucoup) et des employés de sociétés (qui souvent contribuent aussi sur leur temps libre).
    De fait, les développeurs principaux de GTK sont aussi majoritairement contributeurs de GNOME, cela semble donc logique que GNOME suivent de près les évolutions de GTK, mais là on parle d'évolutions incrémentales (passage de GTK 3.22 à 3.24 par exemple).

    Mais restons sérieux, passer de GTK 2 à GTK 3, ou débuter en GTK 3 sans passer par GTK 2, ce n'est pas "suivre de près" GTK, c'est juste du bon sens.

    Non, utiliser une techno stable depuis de nombreuses années, ce n'est pas être à la pointe, c'est juste du bon sens.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. QFormLayout inconnu à la compilation
    Par alias2015_29 dans le forum Débuter
    Réponses: 6
    Dernier message: 13/05/2015, 19h31
  2. Réponses: 3
    Dernier message: 22/09/2013, 09h00
  3. Réponses: 3
    Dernier message: 20/06/2011, 11h09
  4. lien treeview/explorer en gtk# (gtk+ accepté =)
    Par mensoif dans le forum Bibliothèques
    Réponses: 0
    Dernier message: 09/03/2009, 21h16
  5. Problemme inconnu à la compilation
    Par C3po23 dans le forum Visual C++
    Réponses: 6
    Dernier message: 17/03/2007, 22h22

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo