1. #1
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Conseil

    Informations forums :
    Inscription : mai 2017
    Messages : 8
    Points : 6
    Points
    6

    Par défaut Problème de liaison entre le formulaire principal et le sous-formulaire.

    Bonjour,

    Je suis étudiant en en DUT gestion de base de données et statistiques décisionnelles. Actuellement en stage de fin de DUT je bloque sur un élément qui m'empêche d'avancer sur ma mission malgré mes compétences de base en Access. C'est un élément dont je me suis rendu compte tardivement après même avoir avancé sur la partie design et utilisation de mon formulaire.



    Alors voilà,

    je possède ces différentes tables: PRODUIT, DESIGNER, CATEGORY et MASSES. Un prooduit possède un designer, une categorie, et peut avoir plusieurs masses différentes ( la table masse possède toutes les masses de tous les éléments composants le produit ).

    Dans mon premier formulaire "PRODUIT" j'ai intégré tous les champs de la table PRODUIT, une liste déroulante avec tous les designers, une liste déroulante avec toutes les categories. Mes liaisons établies lorsque je rentre un produit, que je choisis son designer, sa categorie, l'identifiant de ces éléments choisi s'inscrit bien dans le champ clé étrangère associé de ma table PRODUIT.

    Ensuite j'ai créé la relation avec ma table MASSES --> table/requête: MASSES et PRODUCT
    champs: id_masses (de ma table MASSES) et id_masses (de ma table PRODUCT)
    J'ai activé l'integrité réferentielle, la MAJ en cascade et la suppression en cascade.

    J'ai ensuite créé un sous formulaire "MASSES" contenant les différents chanps de la tables.
    Après avoir glissé mon formulaire "MASSES" en mode création dans mon formulaire principal "PRODUCT" j'ai définis en champ père de mon sous formulaire id_masses de ma table PRODUCT et id_mass de ma table MASSES.

    Le problème qui se pose et le suivant: Une fois mon produit créé en remplissant les champs de mon formulaire principal et qu je remplis les champs du sous formulaire "MASSES" associés au produit que je vient de créé, l'enregistrement qui s'inscrit dans ma table MASSES ne se lie pas avec le produit que je viens de créer. Autrement dit, l'identifiant de l'enregistrement de ma masse crée ne s'inscrit pas dans le champ clé étrangère id_masses de ma table PRODUIT.
    Or cela fonctionne lorsque je dépose directment les champs de MASSES dans mon formulaire de base.

    Je ne comprends pas, HELP PLEASE !!

  2. #2
    Membre éclairé
    Inscrit en
    août 2008
    Messages
    509
    Détails du profil
    Informations forums :
    Inscription : août 2008
    Messages : 509
    Points : 725
    Points
    725

    Par défaut

    Bonjour,

    peux tu verifier le parametrage du sous-formulaire : les champs parent et enfant ?

  3. #3
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Conseil

    Informations forums :
    Inscription : mai 2017
    Messages : 8
    Points : 6
    Points
    6

    Par défaut

    Voici les paramètres du sous formulaires quand j'ouvre la feuille de propriété en cliquant dessus dans le formulaire principal:

    - En Objet source: Formulaire MASSES
    - Champs père: id_masses de la table PRODUCT
    - Champs enfants: id_masses de la table MASSES

  4. #4
    Membre éclairé
    Inscrit en
    août 2008
    Messages
    509
    Détails du profil
    Informations forums :
    Inscription : août 2008
    Messages : 509
    Points : 725
    Points
    725

    Par défaut

    Bonjour,

    ca semble correct
    zip et poste ta base pour jeter un coup d'oeil

  5. #5
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Conseil

    Informations forums :
    Inscription : mai 2017
    Messages : 8
    Points : 6
    Points
    6

    Par défaut

    Je ne peux pas déposer de fichiers depuis l'ordinateur de mon lieu de travail, je vous le transmet depuis mon ordinateur perso au plus vite !

  6. #6
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2017
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Manche (Basse Normandie)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Conseil

    Informations forums :
    Inscription : mai 2017
    Messages : 8
    Points : 6
    Points
    6

    Par défaut

    J'ai finalement trouvé la solution, c'est tout bêtement un problème de clé étrangère. Merci quand même

Discussions similaires

  1. Réponses: 7
    Dernier message: 01/02/2013, 21h10
  2. Réponses: 2
    Dernier message: 23/07/2009, 15h18
  3. Réponses: 6
    Dernier message: 23/02/2007, 11h56
  4. Réponses: 4
    Dernier message: 08/02/2007, 16h00
  5. Réponses: 5
    Dernier message: 01/10/2006, 14h48

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo