1. #1
    Membre du Club
    Profil pro
    Inscrit en
    mars 2006
    Messages
    329
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2006
    Messages : 329
    Points : 61
    Points
    61

    Par défaut compter le nombre d'occurrence en fonction d'un tri sur colonne

    Bonjour à tous,

    J'ai un petit problème. Imaginons que j'ai un fichier Excel de 1000 lignes avec deux colonnes. Avec en colonne A les identifiants clients (avec doublons possibles) et en colonne B les Pays correspondants.

    Comment compter automatiquement le nombre de d'identifiants clients différents de ma colonne A en fonction du tri effectué sur la colonne B.... Par exemple, je selectionne "France" dans le tri de ma colonne B et il me sort 10 clients, puis je sélectionne "Belgique" et il me sort 5 clients (nombre de clients donné de façon purement arbitraire).

    C'est faisable facilement? (sans faire de tableau croisé dynamique)

    Merci

  2. #2
    Rédacteur/Modérateur

    Avatar de Jean-Philippe André
    Homme Profil pro
    Developpeur VBA migrant tranquillement vers C# et VB.Net =]
    Inscrit en
    juillet 2007
    Messages
    12 367
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Canada

    Informations professionnelles :
    Activité : Developpeur VBA migrant tranquillement vers C# et VB.Net =]
    Secteur : Finance

    Informations forums :
    Inscription : juillet 2007
    Messages : 12 367
    Points : 27 284
    Points
    27 284

    Par défaut

    Salut,

    regarde la formule
    =NB.SI()
    Pas de question technique par MP, je ne réponds pas

    Apprendre à programmer avec Access 2016

    Pensez à consulter la FAQ Excel et la FAQ Access

    Derniers tutos
    Excel et les paramètres régionaux
    Les fichiers Excel binaires : xlsb,

    Autres tutos

  3. #3
    Membre du Club
    Profil pro
    Inscrit en
    mars 2006
    Messages
    329
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2006
    Messages : 329
    Points : 61
    Points
    61

    Par défaut

    Bonjour,

    Oui j'ai testé la formule suivante:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    =SOMMEPROD(1/NB.SI(A2:A1000;B2:B1000=B1))
    Ou B1 correspond à l'entête "country" de mon tableau. En effet la ligne 1 contient les entête "code client" et "country" respectivement pour les colonnes A et B.

    Du coup j'ai une erreur #DIV qui est logique car il compare les valeurs des pays ("France", "Belgique" ect... avec la valeur de la cellule B1 qui est "country" et non pas au choix de tri effectué sur B1 (par exemple "France").

    Comment faire dans ce cas?

  4. #4
    Rédacteur/Modérateur

    Avatar de Jean-Philippe André
    Homme Profil pro
    Developpeur VBA migrant tranquillement vers C# et VB.Net =]
    Inscrit en
    juillet 2007
    Messages
    12 367
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Canada

    Informations professionnelles :
    Activité : Developpeur VBA migrant tranquillement vers C# et VB.Net =]
    Secteur : Finance

    Informations forums :
    Inscription : juillet 2007
    Messages : 12 367
    Points : 27 284
    Points
    27 284

    Par défaut

    Tu es parti trop loin
    (je pars du principe que tes donnees sont en colonne A et que dans la cellule B1 tu as la valeur a chercher)
    un simple
    =NB.SI(A:A;B1)

    devrait faire l'affaire
    Pas de question technique par MP, je ne réponds pas

    Apprendre à programmer avec Access 2016

    Pensez à consulter la FAQ Excel et la FAQ Access

    Derniers tutos
    Excel et les paramètres régionaux
    Les fichiers Excel binaires : xlsb,

    Autres tutos

  5. #5
    Membre expert
    Homme Profil pro
    Retraité
    Inscrit en
    juin 2012
    Messages
    1 374
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Retraité
    Secteur : Enseignement

    Informations forums :
    Inscription : juin 2012
    Messages : 1 374
    Points : 3 062
    Points
    3 062

    Par défaut

    Bonjour,
    Il me semble comprendre que l'on veut le nombre de clients distincts par pays choisi.
    Le choix du pays étant dans une cellule notée CelluleChoixPays, essayer la formule matricielle :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SOMME(SI(B2:B1000=CelluleChoixPays;1/NB.SI.ENS(B2:B10000;CelluleChoixPays;A2:A1000;A2:A1000)))
    à valider bien sûr par Ctrl + Maj + Entrée.
    Si l'on est sûr qu'il ne peut pas y avoir un même identifiant client dans deux pays différents, la formule peut se simplifier en la formule matricielle:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =SOMME(SI(B2:B1000=CelluleChoixPays;1/NB.SI(A2:A1000;A2:A1000)))
    Cordialement
    Claude

Discussions similaires

  1. Compter le nombre d'occurrences
    Par RKU01 dans le forum Fonctions
    Réponses: 1
    Dernier message: 22/03/2008, 18h22
  2. Réponses: 5
    Dernier message: 17/02/2008, 13h32
  3. Réponses: 2
    Dernier message: 07/05/2007, 00h43
  4. [débutant] Compter le nombre d'occurrence d'un texte
    Par PoichOU dans le forum Débuter
    Réponses: 2
    Dernier message: 14/10/2006, 01h00
  5. Réponses: 4
    Dernier message: 03/09/2006, 20h12

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo