1. #1
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut Comment paramétrer le SDK pour utiliser le champ Carte dans une application ?

    Bonjour,

    Je cherche à développer une application WD20 mobile comportant un champ Carte.
    J'ai vu que le champ carte impliquait une version 4 du SDK d'Android. J'ai donc téléchargé et j'obtiens en PJ

    Par contre je ne vois plus la ligne Extra Support Library et, bien sûr, quand je veux compiler mon projet j'ai un message indiquant que le SDK n'est pas trouvé.

    Si je télécharge Android Support Library quelle version dois-je sélectionner ?

    Merci d'avance
    Images attachées Images attachées  

  2. #2
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut

    J'ajoute une précision :

    J'ai été sur ce lien : http://forum.pcsoft.fr/fr-FR/pcsoft....26211/read.awp

    Les deux répertoires indiqués sont bien présents chez moi

  3. #3
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut

    Voilà un sujet traitant du même problème.

    https://wind.developpez.com/actu/833...onctionnement/

    Je voudrais savoir si quelqu'un a utilisé le champ Carte avec la version 20 et comment il a paramétré son environnement pour que cela fonctionne.

    Merci d'avance

  4. #4
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut

    J'ai tenté de poursuivre et j'ai téléchargé à partir du lien proposé par WD

    Voici le message d'erreur que j'obtiens maintenant :
    Nom : Err.png
Affichages : 144
Taille : 129,2 Ko

    Voici ce que j'ai téléchargé :
    Nom : Err2.png
Affichages : 142
Taille : 21,5 Ko

    Que peut-il manquer ?
    J'avoue que quand je lis qu'avec WinDev on développe 10 fois plus vite j'ai un peu de mal...

  5. #5
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut

    J'avoue ne plus savoir comment faire.

    J'ai posé des questions sur un sujet identique pour essayer la même solution mais c'est resté sans réponse.
    Là je multiplie les essais mais cela n'avance pas depuis une semaine.
    Il y a quelques mois sur un autre PC j'avais même essayé de proposer de payer une prestation pour installer cet environnement et je n'avais eu aucune offre.

    Si quelqu'un pouvait me donner un avis je pense que je devrais pouvoir avancer.

  6. #6
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut

    Je finirai peut-être par trouver quelqu'un qui pourra m'aider ?

    Toujours le même message d'erreur.
    Nom : im2.png
Affichages : 127
Taille : 13,6 Ko

    J'ai suivi un autre poste pour réinstaller un SDK Manager reconnu compatible avec la version 20.
    Voilà maintenant ce que je vois au niveau SDK Manager
    Nom : im1.png
Affichages : 129
Taille : 36,9 Ko

    Si quelqu'un utilisant le champ Carte en version 20 de WD pouvait me donner la liste des éléments nécessaires cela me permettrait d'avancer.
    Cela fait 2 semaines que je tourne en rond...

    Merci d'avance

  7. #7
    Membre expert
    Avatar de jurassic pork
    Homme Profil pro
    Bidouilleur
    Inscrit en
    décembre 2008
    Messages
    1 508
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Bidouilleur
    Secteur : Industrie

    Informations forums :
    Inscription : décembre 2008
    Messages : 1 508
    Points : 3 599
    Points
    3 599

    Par défaut

    hello,
    dans ton message #3 le lien n'est pas bon. Est-ce que c'était ce lien ?


    Ami calmant, J.P
    Jurassic computer : Sinclair ZX81 - Zilog Z80A à 3,25 MHz - RAM 1 Ko - ROM 8 Ko

  8. #8
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut

    Si quelqu'un au moins a lu mon souci cela me rassure.

    Effectivement c'était bien ce lien.

  9. #9
    Membre expert
    Avatar de jurassic pork
    Homme Profil pro
    Bidouilleur
    Inscrit en
    décembre 2008
    Messages
    1 508
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Bidouilleur
    Secteur : Industrie

    Informations forums :
    Inscription : décembre 2008
    Messages : 1 508
    Points : 3 599
    Points
    3 599

    Par défaut

    hello,
    as-tu essayé ce qui est écrit dans ce lien ?
    la version google_play_services_8298000_r28 est ici

    Ami calmant, J.P
    Jurassic computer : Sinclair ZX81 - Zilog Z80A à 3,25 MHz - RAM 1 Ko - ROM 8 Ko

  10. #10
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut

    Au terme du post en question le problème ne semblait pas vraiment résolu.

    Je vais essayer de télécharger ldl-ssl.google.com/an...298000_r28.zip
    Cela me repousse à Mardi soir mais je ferai un retour.

    En android avec la version 20 on ne peut pas vraiment utiliser autre chose que le champ Carte.
    Les fonctions ggl ne sont reconnues qu'avec la version 22

  11. #11
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut

    J'ai récupéré mon PC avant le WE en espérant arriver à compiler

    j'ai téléchargé le google_play_services_8298000_r28.zip
    J'ai copié son contenu dans le répertoire C:\Android\sdk\extras\google\m2repository\com\google\android\gms

    Ce qui donne Nom : CheminGoogleplay.png
Affichages : 123
Taille : 30,8 Ko

    avec à l'intérieur
    Nom : CheminGoogleplay2.png
Affichages : 122
Taille : 37,2 Ko

    et toujours le même message...

  12. #12
    Membre expert
    Avatar de jurassic pork
    Homme Profil pro
    Bidouilleur
    Inscrit en
    décembre 2008
    Messages
    1 508
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Bidouilleur
    Secteur : Industrie

    Informations forums :
    Inscription : décembre 2008
    Messages : 1 508
    Points : 3 599
    Points
    3 599

    Par défaut

    hello,
    es-tu sûr de l'endroit où tu as mis le google play service ?
    Parce que c'est plutôt ici :
    Nom : google_play_service.png
Affichages : 121
Taille : 23,2 Ko

    Ami calmant, J.P
    Jurassic computer : Sinclair ZX81 - Zilog Z80A à 3,25 MHz - RAM 1 Ko - ROM 8 Ko

  13. #13
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut

    J'ai fait un couper-coller du répertoire.
    J'ai donc maintenant la même arborescence. Idem

  14. #14
    Membre expert
    Avatar de jurassic pork
    Homme Profil pro
    Bidouilleur
    Inscrit en
    décembre 2008
    Messages
    1 508
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Bidouilleur
    Secteur : Industrie

    Informations forums :
    Inscription : décembre 2008
    Messages : 1 508
    Points : 3 599
    Points
    3 599

    Par défaut

    hello,
    vois-tu alors dans le Android SDK manager la version 28 de Google Play Services installée comme ceci :

    Nom : Android-GooglePlayServices-28.png
Affichages : 107
Taille : 45,0 Ko

    Ami calmant, J.P
    Jurassic computer : Sinclair ZX81 - Zilog Z80A à 3,25 MHz - RAM 1 Ko - ROM 8 Ko

  15. #15
    Membre à l'essai
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2016
    Messages
    32
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Bénin

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : août 2016
    Messages : 32
    Points : 23
    Points
    23

    Par défaut

    Salut à tous! Moi même j'ai eu à longtemps galérer sur ce problème en Windev Mobile 20 et ma seule solution a été de récupérer un sdk chez un ami qui arrivait à compiler d'abord les simples applications (n'utilisant pas de services play google). Quelques caractéristiques sont:
    - Android SDK Tool rev 24.0.2;
    - Android SDK Platform-tool rev 20;
    - Android SDK Build-tools rev 25.0.1;
    - Google Play Services rev 29.
    Ensuite, comme c'est le Google Play Service qui posait de problème (surement parce que sa révision n'est pas pas gérable par Windev Mobile 20), j'ai cherché un peu sur google puis j'ai pu obtenir un dossier google_play_services_8298000_r28 (compressé au format zip lors du téléchargement). J'ai récupéré le contenu de ce dossier que j'ai placé dans le dossier équivalent de mon sdk (AndroidSDK\extras\google\google_play_services). Et comme par magie, j'ai réussi à générer une application avec champ carte qui fonctionne très bien!
    Si cela peut vous aider, bon dev à vous!

  16. #16
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut

    Pièce jointe 279398
    j'ai cherché un peu sur google puis j'ai pu obtenir un dossier google_play_services_8298000_r28 (compressé au format zip lors du téléchargement).
    C'est ce que disait jurassic pork

    J'ai téléchargé le ZIP et je l'ai décompressé dans
    ce qui donne l'arborescence suivante :
    Nom : Arb.png
Affichages : 90
Taille : 20,7 Ko

    Par contre au niveau du SDK je vois toujours
    Nom : and.png
Affichages : 91
Taille : 15,9 Ko

    J'ai perdu le projet mais j'aimerais quand même comprendre.

  17. #17
    Membre à l'essai
    Homme Profil pro
    Développeur informatique
    Inscrit en
    août 2016
    Messages
    32
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Bénin

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : août 2016
    Messages : 32
    Points : 23
    Points
    23

    Par défaut

    Nom : Erreur.PNG
Affichages : 86
Taille : 11,1 Ko

    Si tu as toujours l'erreur ci dessus, c'est que probablement, ton sdk est toujours plus récent que ceux qui marchent avec WM20.
    A ta place, je chercherais un sdk plus ancien. J'aimerais bien compresser le mien et te l'envoyer mais avec sa taille, je crains que ma connexion m'en emêcherait!

  18. #18
    Membre confirmé

    Profil pro
    Inscrit en
    mars 2002
    Messages
    1 097
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2002
    Messages : 1 097
    Points : 564
    Points
    564

    Par défaut

    J'aimerais bien compresser le mien et te l'envoyer
    C'est vraiment gentil mais j'avas déjà chargé un SDK plus ancien sur les conseils de jurassic pork
    Finalement j'ai laissé tomber.
    Pour l'instant j'utilise WinDev et WinDev mobile pour des petites applications. Je crois que les versions 21 et 22 ont un peu amélioré les dépendances mais je ne sais pas si je poursuivrai.

    En tout cas merci de m'avoir aidé.

Discussions similaires

  1. Comment faire pour utiliser plusieurs fonctions logiques dans une condition ?
    Par arnaudperfect dans le forum Shell et commandes GNU
    Réponses: 2
    Dernier message: 04/11/2010, 12h37
  2. Réponses: 0
    Dernier message: 17/06/2010, 15h22
  3. Utiliser un champ photo dans une base access
    Par mapoupou dans le forum VB 6 et antérieur
    Réponses: 12
    Dernier message: 02/01/2009, 23h04
  4. Réponses: 3
    Dernier message: 18/09/2007, 15h54
  5. Pour utiliser MFC et directX9 dans une fenetre dialogue
    Par Mathieu008_67 dans le forum DirectX
    Réponses: 2
    Dernier message: 17/11/2005, 20h09

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo