IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

SQL Firebird Discussion :

[Firebird 1.5] probleme avec le type VARCHAR et les quote '


Sujet :

SQL Firebird

  1. #1
    Nouveau membre du Club
    Inscrit en
    juillet 2004
    Messages
    35
    Détails du profil
    Informations forums :
    Inscription : juillet 2004
    Messages : 35
    Points : 30
    Points
    30
    Par défaut [Firebird 1.5] probleme avec le type VARCHAR et les quote '
    bonjour.
    je suis en train de réaliser une appli web reposant sur une base de données firebird. Je dispose donc de questionnaires pour mettre ma base a jour. Et là lorsqu'un utilisateur utilise une ' dans un champ texte du formulaire, la mise à jour de la base pose un réel problème.

    Ma requête d'insertion
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
    insert into MODIFICATION (REF_APPLI, REF_ANAPROG, "DATE", DESCRIPTION) values(7, 'toto', '8/31/2004', 'modif de l'essai')
    comme vous pouvez le voir, l'apostrophe avant essai crée une exception.

    Existe t-il un moyen de ne pas prendre en compte les caractères spéciaux? J'imagine que ce problème peut également se poser avec d'autres caractères que les quote.

    d'avance merci[/quote]

  2. #2
    Membre actif Avatar de TMuet
    Homme Profil pro
    Responsable de service informatique
    Inscrit en
    septembre 2003
    Messages
    225
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Responsable de service informatique
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : septembre 2003
    Messages : 225
    Points : 288
    Points
    288
    Par défaut
    Il faut remplacer ' par '' (2 ' de suite) avant insertion

  3. #3
    Nouveau membre du Club
    Inscrit en
    juillet 2004
    Messages
    35
    Détails du profil
    Informations forums :
    Inscription : juillet 2004
    Messages : 35
    Points : 30
    Points
    30
    Par défaut
    effectivement.
    merci

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [XPath]probleme avec xsi:type
    Par fisherman dans le forum XSL/XSLT/XPATH
    Réponses: 5
    Dernier message: 01/11/2006, 00h46
  2. probleme avec le type LONG ROW
    Par amigauss dans le forum SQL
    Réponses: 10
    Dernier message: 21/09/2006, 11h29
  3. Petit probleme avec <input type="text" .
    Par cyberdevelopment dans le forum Balisage (X)HTML et validation W3C
    Réponses: 4
    Dernier message: 18/08/2006, 21h17
  4. [VB6.0]Probleme avec le type Form
    Par Tankian dans le forum VB 6 et antérieur
    Réponses: 5
    Dernier message: 17/11/2005, 14h26
  5. [DLL] Probleme avec le Type TRichEdit !
    Par TOTO32 dans le forum Langage
    Réponses: 2
    Dernier message: 03/08/2005, 21h50

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo