Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

 Oracle Discussion :

Erreur database après virtualisation


Sujet :

Oracle

  1. #1
    Membre à l'essai
    Erreur database après virtualisation
    Bonjour,

    Pour des tests j'ai fait un PTV (W2008R2 ORACLE 11G SAGEX3V6) et en relançant les services Oracle celà ne fonctionne pas.
    j'ai ça dans les logs :

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    alter database mount exclusive
    Successful mount of redo thread 1, with mount id 2558069062
    Database mounted in exclusive mode
    Lost write protection disabled
    Completed : alter database mount exclusive
    alter database open
    Errors in file :e\sage\x3prod_ora_4904.trc
    Ora-10873: file 1 needs to be either taken out of backup mode or media recovered
    Ora-01110: fichier de donnees 1 : "E:\....\SYS1X3PROD.BDF'
    $Ora-10873 signalled during : alter database open...


    Je n'arrive pas non plus à me logger avec SQLPLUS

    Par avance merci de votre aide !

  2. #2
    Expert éminent
    Bonjour,
    La base était en backup mode lors du P2V?
    alors:
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    alter database end backup

    puis recover + startup
    Cordialement,
    Franck.
    Franck Pachot - dbi services - Oracle ACE Director - OCM 12c - Oak Table member - twitter: @FranckPachot - blog: blog.pachot.net

  3. #3
    Membre à l'essai
    Bonjour Franck,

    A priori oui, mon presta m'avait assuré que c'était ok, je suis un peu naïf parfois

    Je n'arrive pas à faire le end back up ; il me retourne un SP2-0640: Non connecté.
    Alors j'essaye de me connecter et la ORA-01033: ORACLE init or shutdown in progress (ID de processus: 0,ID de session:0,Numéro de série:0)

    Encore Merci

    Maxime

  4. #4
    Membre à l'essai
    Bonjour,

    Je bloque toujours sur mon problème :
    si je fais un SQLPLUS et que j'essaie de me connecter j'ai un ORA-12560 TNS (j'ai relancé le service listener plusieurs fois)
    si je fais un connect user/pswd@BDD j'ai un ORACLE initialization or shutdown in progress

    Vous voyez quelque chose à faire?


    Par avance merci & bonne journée !

  5. #5
    Rédacteur/Modérateur

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    shutdown abort
    pour tuer définitivement l'instance
    puis un startup mount
    et la commande de Frank
    Sr DBA Oracle / MS-SQL / MySQL / Postgresql / SAP-Sybase / Informix / DB2

    N'oublie pas de consulter mes articles, mon blog, les cours et les FAQ SGBD

    Attention : pas de réponse technique par MP : pensez aux autres, passez par les forums !

  6. #6
    Membre à l'essai
    Bonjour Merci de votre retour,

    C'était un problème de variable d'environnement et de compte.
    J'ai résolu la suite de mon soucis avec un
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    aletr database backup end;


    Bonne journée

###raw>template_hook.ano_emploi###