IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Excel Discussion :

Recherche textuelle multiple


Sujet :

Excel

  1. #1
    Modérateur

    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    avril 2007
    Messages
    1 996
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 1 996
    Points : 3 105
    Points
    3 105
    Par défaut Recherche textuelle multiple
    Bonjour à tous,

    je cherche un moyen de faire une recherche textuelle multiple dans un tableau sous Excel.
    Je m'explique :
    A1 = football
    A2 = baseball
    A3 = cyclisme
    A4 = athlétisme
    A5 = triathlon

    B1 = ball
    B2 = isme

    je cherche à récupérer en C une valeur m'indiquant que B1 ou B2 a été trouvé dans A.

    J'ai essayé de le faire avec des SI(TROUVE()) imbriqués mais ce sera in-maintenable et je suis à la recherche d'une solution un peu plus propre.

    Si vous avez des idées, je suis preneur.

    Merci d'avance

  2. #2
    Membre expert

    Homme Profil pro
    Retraité
    Inscrit en
    juin 2012
    Messages
    1 557
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Alpes Maritimes (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Retraité
    Secteur : Enseignement

    Informations forums :
    Inscription : juin 2012
    Messages : 1 557
    Points : 3 536
    Points
    3 536
    Billets dans le blog
    1
    Par défaut
    Bonjour,
    La formule
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =NB.SI(A1:A5;"*"&B1)+NB.SI(A1:A5;"*"&B2)
    renvoie le total du nombre d'occurrence dans la plage A1:A5 du contenu de B1 ou du contenu de B2.
    Cordialement
    Claude

  3. #3
    Expert éminent sénior Avatar de Menhir
    Homme Profil pro
    Ingénieur
    Inscrit en
    juin 2007
    Messages
    16 034
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Finistère (Bretagne)

    Informations professionnelles :
    Activité : Ingénieur
    Secteur : Industrie

    Informations forums :
    Inscription : juin 2007
    Messages : 16 034
    Points : 32 855
    Points
    32 855
    Par défaut
    Mettre en C1 la formule :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    =OU((B1=DROITE(A$1:A$5;NBCAR(B1)));(B2=DROITE(A$1:A$5;NBCAR(B2))))
    A valider comme une formule matricielle avec Ctrl+Shift+Entrée
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

  4. #4
    Modérateur

    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    avril 2007
    Messages
    1 996
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Service public

    Informations forums :
    Inscription : avril 2007
    Messages : 1 996
    Points : 3 105
    Points
    3 105
    Par défaut
    Merci pour vos conseils.

    J'ai continué à chercher et fini par trouver une formule qui fonctionne également :
    =SOMMEPROD(--ESTNUM(CHERCHE(B1:B2;A1)))>0

    Mais j'avoue ne pas comprendre comment elle fonctionne.
    CHERCHE --> OK, renvoie la position à laquelle la chaîne recherchée dans la matrice est trouvée dans la cellule A1
    ESTNUM --> checke que la valeur renvoyée est un nombre
    -- --> ?
    SOMMEPROD --> OK pour le SOMMEPROD quand il s'agit de faire un calcul multi-colonnes, mais en l'état je ne comprends pas comment cela peut fonctionner.

  5. #5
    Expert éminent sénior Avatar de Menhir
    Homme Profil pro
    Ingénieur
    Inscrit en
    juin 2007
    Messages
    16 034
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Finistère (Bretagne)

    Informations professionnelles :
    Activité : Ingénieur
    Secteur : Industrie

    Informations forums :
    Inscription : juin 2007
    Messages : 16 034
    Points : 32 855
    Points
    32 855
    Par défaut
    Citation Envoyé par calagan99 Voir le message
    ESTNUM --> checke que la valeur renvoyée est un nombre -- --> ?
    C'est sans doute pour différencier les cas où CHERCHE() trouve un résultat et ceux où elle renvoie une erreur.
    Un peu comme un contraire de ESTERR().
    Merci de cliquer sur pour chaque message ayant aidé puis sur pour clore cette discussion.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Recherche textuelle sur fichiers
    Par tchauviere dans le forum VB.NET
    Réponses: 4
    Dernier message: 16/12/2007, 21h53
  2. recherche à sélection multiple
    Par Kalite dans le forum Algorithmes et structures de données
    Réponses: 1
    Dernier message: 06/11/2007, 11h54
  3. recherche à choix multiple
    Par meddeb2001 dans le forum Access
    Réponses: 3
    Dernier message: 30/08/2006, 11h22
  4. [SQL] Recherche à résultats multiples SQL - PHP
    Par Paradise01 dans le forum PHP & Base de données
    Réponses: 4
    Dernier message: 15/08/2006, 15h52
  5. Réponses: 9
    Dernier message: 07/11/2005, 20h57

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo