Discussion: Envois de Mail - 4D

  1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    4D
    Inscrit en
    avril 2017
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Somme (Picardie)

    Informations professionnelles :
    Activité : 4D
    Secteur : Transports

    Informations forums :
    Inscription : avril 2017
    Messages : 2
    Points : 1
    Points
    1

    Par défaut Envois de Mail - 4D

    Bonjour à tous

    Avant de poster mon sujet, je précise que j'ai mené pas mal de recherches sur différents forums, mais je n'ai pas trouvé de solutions...

    Mon problème est simple : j'aimerais envoyer un E-Mail via 4D. Tout d'abord avec du texte en dur, je modifierai tout ca après.
    J'ai déjà testé pas mal de choses, notamment en regardant dans la doc 4D mais rien ne marche. Je dois surement oublier des choses...

    Voici ce que j'ai fais :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
     
        C_TEXT($nomServeur;$message;$msgA;$msgDe;$objet;$user;$mdp)
        C_LONGINT($erreur)
        $nomServeur:="smtp.gmail.com"
        $msgDe:="adresse1@gmail.com"
        $msgA:="adresse2@gmail.com"
        $user:="adresse1@gmail.com"
        $mdp:="mdpAdresse1"
        $message:="Enfin réussi !"
        $objet:="envois de Mail grace a 4D"
     
        $param:=5  //HTML avec SSL
        $port:=465  //Port SSL de gmail
     
        $erreur:=SMTP_QuickSend($nomServeur;$msgDe;$msgA;$objet;$message;$param;$port;$user;$mdp)
     
        If ($erreur#0)
             ALERT("erreur : "+String($erreur))
        Else 
             ALERT("mail envoyé")
        End if
    Avez-vous des idées, des éclaircissement ou même un imple bout de code pour que j'envois un mail vide SVP ?
    D'avance merci à tous

  2. #2
    Nouveau Candidat au Club
    Homme Profil pro
    4D
    Inscrit en
    avril 2017
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Somme (Picardie)

    Informations professionnelles :
    Activité : 4D
    Secteur : Transports

    Informations forums :
    Inscription : avril 2017
    Messages : 2
    Points : 1
    Points
    1

    Par défaut Envois de mail ok

    Après de longues heures de recherche, j'ai enfin réussi à envoyer mes mails. Maintenant, nouveau soucis : ils arrivent en SPAM. Avez-vous une idée pour qu'il arrive dans la boite mail principale ?

Discussions similaires

  1. Envoi de mail au format html
    Par Mephyston dans le forum C++Builder
    Réponses: 2
    Dernier message: 22/01/2004, 13h29
  2. Envoi de mail au format Rich-Text
    Par LineLe dans le forum ASP
    Réponses: 4
    Dernier message: 29/10/2003, 17h27
  3. envoi de mail avec attachement de fichier
    Par GMI3 dans le forum Modules
    Réponses: 2
    Dernier message: 24/09/2003, 12h22
  4. Outlook ne se ferme pas après un envoi de mail
    Par Joke dans le forum VBA Access
    Réponses: 2
    Dernier message: 07/06/2003, 18h32
  5. envoi de mail, protocol SMTP langage C
    Par Heimdall dans le forum Développement
    Réponses: 2
    Dernier message: 23/05/2003, 12h22

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo