1. #1
    Membre du Club Avatar de Markos22
    Homme Profil pro
    Développeur Java
    Inscrit en
    juillet 2016
    Messages
    111
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Développeur Java

    Informations forums :
    Inscription : juillet 2016
    Messages : 111
    Points : 63
    Points
    63

    Par défaut éléments static sous ArgoUML

    Bonjour à tous,

    J'utilise ArgoUML pour créer un diagramme de classes à partir d'un projet PHP. Or, j'ai des attributs static dans certains de mes objets. Savez-vous comment spécifier le caractère static des attributs sous ArgoUML ? Cette précision me paraît importante à noter sur le diagramme, or, si j'écris "static" dans mes attributs, ce mot est systématiquement effacé. Que faire ?

    Merci de votre aide.

  2. #2
    Modérateur
    Avatar de bruno_pages
    Homme Profil pro
    Développeur informatique
    Inscrit en
    juin 2005
    Messages
    3 361
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 57
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : juin 2005
    Messages : 3 361
    Points : 5 539
    Points
    5 539

    Par défaut

    bonjour,

    le fait qu'un attribut soit de classe (ie static) et non d'instance devrait apparaître au niveau des propriétés de l'attribut, comme sa visibilité etc
    Bruno Pagès, auteur de Bouml (freeware), mes tutoriels sur DVP (vieux, non à jour )

    N'oubliez pas de consulter les FAQ UML et les cours et tutoriels UML

  3. #3
    Membre du Club Avatar de Markos22
    Homme Profil pro
    Développeur Java
    Inscrit en
    juillet 2016
    Messages
    111
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Développeur Java

    Informations forums :
    Inscription : juillet 2016
    Messages : 111
    Points : 63
    Points
    63

    Par défaut

    Bonjour, bruno_pages,

    Merci pour ta réponse, mais je ne vois pas apparaître cette caractéristique dans l'onglet "Propriétés" :

    Nom : Propriétés attribut UML.jpg
Affichages : 34
Taille : 34,8 Ko
    Alors ? Comment faire ? Ce serait dommage d'utiliser un autre logiciel. En effet, après en avoir testé plusieurs, c'est ArgoUML qui me convient le mieux. Il doit bien y avoir un moyen.

  4. #4
    Modérateur
    Avatar de bruno_pages
    Homme Profil pro
    Développeur informatique
    Inscrit en
    juin 2005
    Messages
    3 361
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 57
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : juin 2005
    Messages : 3 361
    Points : 5 539
    Points
    5 539

    Par défaut

    effectivement la façon de le faire ne saute pas aux yeux, avez-vous essayé en le stéréotypant static même s'il serait regrettable que ce soit la solution ?
    Bruno Pagès, auteur de Bouml (freeware), mes tutoriels sur DVP (vieux, non à jour )

    N'oubliez pas de consulter les FAQ UML et les cours et tutoriels UML

  5. #5
    Membre du Club Avatar de Markos22
    Homme Profil pro
    Développeur Java
    Inscrit en
    juillet 2016
    Messages
    111
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Développeur Java

    Informations forums :
    Inscription : juillet 2016
    Messages : 111
    Points : 63
    Points
    63

    Par défaut

    ??? Et comment fait-on ?
    Si je clique sur l'onglet Stéréotype, j'ai deux zones vides, Available sterreotypes et Applied Stereotypes, avec deux boutons ">>" et "<<" pour faire passer l'un vers l'autre. Mais comment alimenter la zone "Available Stereotypes" ?

  6. #6
    Modérateur
    Avatar de bruno_pages
    Homme Profil pro
    Développeur informatique
    Inscrit en
    juin 2005
    Messages
    3 361
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 57
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : juin 2005
    Messages : 3 361
    Points : 5 539
    Points
    5 539

    Par défaut

    je n'ai pas dit que c'est la solution, c'était juste une idée sachant que je n'utilise (évidemment) pas argouml

    bref, je n'ai pas de solution pour vous ... si ce n'est de changer de modeleur

    il n'a pas de doc/forum/hotline c'est outil ?
    Bruno Pagès, auteur de Bouml (freeware), mes tutoriels sur DVP (vieux, non à jour )

    N'oubliez pas de consulter les FAQ UML et les cours et tutoriels UML

  7. #7
    Membre du Club Avatar de Markos22
    Homme Profil pro
    Développeur Java
    Inscrit en
    juillet 2016
    Messages
    111
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 52
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Développeur Java

    Informations forums :
    Inscription : juillet 2016
    Messages : 111
    Points : 63
    Points
    63

    Par défaut

    Merci d'avoir essayé.

    Il y a bien un site (en anglais ! ), ici, mais le lien vers le forum est mort.

    Tant pis ! On va faire sans !

    A+

Discussions similaires

  1. [CSS 2] Disposition d'éléments : problème sous IE7
    Par yann18 dans le forum Mise en page CSS
    Réponses: 3
    Dernier message: 26/03/2009, 17h24
  2. Qt en static sous Mac OS/XCode
    Par Rolf Le Saint dans le forum Qt
    Réponses: 21
    Dernier message: 25/02/2009, 10h41
  3. Réponses: 10
    Dernier message: 19/10/2006, 09h39
  4. Réponses: 7
    Dernier message: 20/11/2005, 19h26

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo