1. #1
    Nouveau membre du Club
    Profil pro
    Inscrit en
    novembre 2010
    Messages
    175
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : novembre 2010
    Messages : 175
    Points : 38
    Points
    38

    Par défaut [Symfony 3] Probleme avec un service

    Bonjour,

    J'ai besoin de faire des fonctions et donc j'ai un service qui contiendra une classe et les differentes methodes que j'ai besoins.

    voila mon service qui est dans "src/EPI/MathBundle/Outil/EPIoutil.php"
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
     
    namespace EPI\MathBundle\Outil;
     
    class EPIOutil
    {
       /**
       * Vérifie si le texte est un spam ou non
       *
       * @param string $text
       * @return bool
       */
      public function isSpam($text)
      {
        return strlen($text) < 50;
      }
    }

    j'ai rajouté dans le fichier "src/EPI/MathBundle/Resources/config/services.yml" ces deux lignes
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
     
        epi_math.outil:
            class: EPI\MathBundle\Outil\EPIOutil

    et quand j'utilise mon service dans un controleur j'ai une erreurs

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
     public function argAction($value)
     {
         $outil = $this->container->get('epi_math.outil');
         $busy = 0;
         $n = 3500;
         $p = $value / (8 * 3600);
         $k = 0;
         $array = array($busy, $n, $p);
         return new JsonResponse($array);
     }
    voila l'erreur :




    Pouvez vous m'aidez ? merci d'avance

  2. #2
    Membre chevronné
    Avatar de dukoid
    Homme Profil pro
    Développeur informatique
    Inscrit en
    novembre 2012
    Messages
    1 491
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : novembre 2012
    Messages : 1 491
    Points : 2 043
    Points
    2 043

    Par défaut

    peut être qu'il manque le _construct ?

  3. #3
    Membre éclairé
    Homme Profil pro
    Développeur Web
    Inscrit en
    novembre 2013
    Messages
    602
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : novembre 2013
    Messages : 602
    Points : 808
    Points
    808

    Par défaut

    bonsoir,
    tu veux récupérer quoi exactement avec ça ?
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
     $this->container->get('epi_math.outil');
    inutile de faire appel au container dans un controlleur.
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
     
     $this->get('epi_math.outil');
    et plus logique comme ça :


    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
     
    $text = "text";
     $textLength=$this->get('epi_math.outil')->isSpam($text);

    pour integrer antispam et akismet , cet article peux servir http://www.mrbinr.com/2015/04/12/ant...-sous-symfony2

Discussions similaires

  1. Probleme avec Win32::Service::GetStatus
    Par laurent33500 dans le forum Langage
    Réponses: 0
    Dernier message: 06/08/2009, 11h46
  2. problem avec un service windows
    Par Halloula dans le forum VB.NET
    Réponses: 6
    Dernier message: 27/02/2009, 15h24
  3. [windows serveur 2003] probleme avec le service DNS
    Par djilos dans le forum Windows Serveur
    Réponses: 17
    Dernier message: 02/01/2009, 15h38
  4. Probleme avec Web Service et TomCat
    Par lordpixel dans le forum NetBeans
    Réponses: 1
    Dernier message: 14/03/2008, 09h10
  5. probleme avec Analysis Services de sql server 2000
    Par thefaycal dans le forum MS SQL-Server
    Réponses: 1
    Dernier message: 13/02/2006, 16h41

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo