1. #1
    Membre à l'essai
    Homme Profil pro
    Inscrit en
    juillet 2013
    Messages
    15
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2013
    Messages : 15
    Points : 16
    Points
    16

    Par défaut parcourir tous les enregistrements

    bonjour la famille dites moi comment parcourir tous les enregistrement d'une fichier hyperfile pour en faire un update
    ex:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    SI HTrouve(Conges) ALORS
    			SI  Conges.Flag_Conge = 1 
    				UTILISATEURS.FLAG_ACTIF = 0			
    				SI PAS HModifie(UTILISATEURS) ALORS
    				Erreur("il y a erreur")
    				RETOUR 	
    				FIN
    			FIN	
    	FIN
    je veux parcourir fichier conge et mettre tous les flag à 0 si cest flag_conge = 1
    merci

  2. #2
    Membre émérite
    Homme Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 078
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 078
    Points : 2 447
    Points
    2 447

    Par défaut

    Bonjour,

    D'une manière générale, voyez Parcours ou Parcourir dans l'index de l'aide. Lecture très intéressante.

    Plus spécifiquement, pour le parcours d'un fichier HFSQL, voyez Instruction POUR TOUT / POUR TOUS (parcours de fichiers).

    J'espère que cela vous aidera. C'est a priori exactement ce dont vous avez besoin.

    Hemgé

Discussions similaires

  1. [VBA]Boucle pour parcourir tous les enregistrements
    Par Paul Gasser dans le forum VBA Access
    Réponses: 44
    Dernier message: 28/03/2007, 11h22
  2. Afficher tous les enregistrements d'une table
    Par bertrand_declerck dans le forum QuickReport
    Réponses: 2
    Dernier message: 08/07/2005, 09h35
  3. faire somme de tous les enregistrements identiques
    Par Keraccess dans le forum Langage SQL
    Réponses: 2
    Dernier message: 04/07/2005, 12h03
  4. [C#] Parcourir tous les TextBox d'un Panel
    Par Oberown dans le forum ASP.NET
    Réponses: 7
    Dernier message: 18/01/2005, 15h04
  5. jointure renvois pas tous les enregistrements
    Par rayonx dans le forum Langage SQL
    Réponses: 7
    Dernier message: 29/08/2002, 13h51

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo