1. #1
    Membre à l'essai
    Homme Profil pro
    Inscrit en
    juillet 2013
    Messages
    15
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2013
    Messages : 15
    Points : 16
    Points
    16

    Par défaut utilisation d'une requête parametrée

    bonjour la famille, j'ai ma requete sql :
    SELECT
    Agents.Date_Depart AS Date_Depart
    FROM
    Agents
    WHERE
    Agents.Date_Depart IS NOT NULL
    AND Agents.NUM_MATRICULE LIKE {param1}

    et je veux l'executer ici en sachant que y a un parametre:

    SI HExécuteRequête() ALORS
    SI Conges.Flag_Conge = 1 ALORS
    UTILISATEURS.FLAG_ACTIF = 0
    FIN

    que faire?

  2. #2
    Candidat au Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    juin 2016
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : juin 2016
    Messages : 2
    Points : 3
    Points
    3

    Par défaut

    Bonjour,

    Je pense que ca devrait fonctionner comme ca.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
     
    NOM_REQUETE.Param1 = VALEUR
     
    SI PAS HExécuteRequête(NOM_REQUETE) ALORS
         Erreur("Erreur HFSQL : " + HErreur())
    SINON
           HLITPREMIER(NOMREQUETE)
            TANTQUE PAS HENDHORS()
     
              //TRAITEMENT
             HLITSUIVANT(NOMREQUETE)
             FIN 
    FIN
    NOM_REQUETE Correspond au nom que tu as donné a la requete
    VALEUR Correspond a la valeur de Param1

    en espérant t'avoir aidé

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Pb avec utilisation d'une requête dynamique
    Par bentoile dans le forum SQL
    Réponses: 12
    Dernier message: 30/08/2007, 17h45
  2. Réponses: 6
    Dernier message: 10/08/2007, 11h27
  3. Réponses: 3
    Dernier message: 31/08/2006, 12h27
  4. Réponses: 4
    Dernier message: 21/07/2006, 14h48
  5. [FREETEXT][Sql2000] Utilisation dans une requête ?
    Par SoaB dans le forum MS SQL-Server
    Réponses: 2
    Dernier message: 18/10/2005, 14h49

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo