1. #1
    Futur Membre du Club
    Homme Profil pro
    Analyse système
    Inscrit en
    janvier 2017
    Messages
    7
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Analyse système
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : janvier 2017
    Messages : 7
    Points : 5
    Points
    5

    Par défaut Configuration des vhosts

    Bonjour,

    J'ai un probleme de configuration des Vhosts.

    Lorsque j'effectue un nouveau paramétrage j'ai l'impression qu'il n'est pas pris en compte.
    Je tourne sur Debian 8 apache 2.4, Webmin.

    j'ai 3 sites HTTPS qui fonctionnent correctement. au total 5 fichiers de configuration dont voici le détail :

    000-default.conf
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    # vim: syntax=apache ts=4 sw=4 sts=4 sr noet
    default-ssl.conf
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    <IfModule mod_ssl.c>
    	<VirtualHost _default_:443>
    		ServerAdmin webmaster@localhost
     
    		DocumentRoot /var/www/html
    		#LogLevel info ssl:warn
     
    		ErrorLog ${APACHE_LOG_DIR}/error.log
    		CustomLog ${APACHE_LOG_DIR}/access.log combined
     
    		SSLEngine on
     
    		SSLCertificateFile	/etc/ssl/certs/ssl-cert-snakeoil.pem
    		SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
     
    		<FilesMatch "\.(cgi|shtml|phtml|php)$">
    				SSLOptions +StdEnvVars
    		</FilesMatch>
    		<Directory /usr/lib/cgi-bin>
    				SSLOptions +StdEnvVars
    		</Directory>
     
    		BrowserMatch "MSIE [2-6]" \
    				nokeepalive ssl-unclean-shutdown \
    				downgrade-1.0 force-response-1.0
    		BrowserMatch "MSIE [17-9]" ssl-unclean-shutdown
     
    	</VirtualHost>
    </IfModule>
    webmin.1480458023-le-ssl.conf
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    <IfModule mod_ssl.c>
    <VirtualHost dev.site.com:443>
    DocumentRoot /home/dev
    <Directory "/home/dev">
    allow from all
    Options None
    Require all granted
    </Directory>
    ServerName https://dev.site.com
    SSLCertificateFile /etc/letsencrypt/live/phpmyadmin.site.com/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/phpmyadmin.site.com/privkey.pem
    Include /etc/letsencrypt/options-ssl-apache.conf
    ServerAlias dev.site.com
    </VirtualHost>
    </IfModule>
    webmin.1480596758-le-ssl.conf
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    <IfModule mod_ssl.c>
    <VirtualHost phpmyadmin.site.com:443>
    DocumentRoot /home/phpmyadmin
    <Directory "/home/phpmyadmin">
    allow from all
    Options None
    Require all granted
    </Directory>
    SSLCertificateFile /etc/letsencrypt/live/phpmyadmin.site.com/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/phpmyadmin.site.com/privkey.pem
    Include /etc/letsencrypt/options-ssl-apache.conf
    ServerName phpmyadmin.site.com
    </VirtualHost>
    </IfModule>
    <VirtualHost phpmyadmin.site.com:80>
       ServerName phpmyadmin.site.com
       DocumentRoot /home/phpmyadmin/
       Redirect permanent / <a href="https://phpmyadmin.site.com" target="_blank">https://phpmyadmin.site.com</a>
    </VirtualHost>
    webmin.1482937484-le-ssl.conf
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    <IfModule mod_ssl.c>
    <VirtualHost lms.site.com:443>
    DocumentRoot /home/prod/
    <Directory "/home/prod/">
    allow from all
    Options None
    Require all granted
    </Directory>
    ServerName https://lms.site.com
    SSLCertificateFile /etc/letsencrypt/live/phpmyadmin.site.com/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/phpmyadmin.site.com/privkey.pem
    Include /etc/letsencrypt/options-ssl-apache.conf
    ServerAlias lms.site.com
    </VirtualHost>
    <VirtualHost lms.site.com:80>
       ServerName lms.site.com
       DocumentRoot /home/prod/
       Redirect permanent / https://lms.site.com
    </VirtualHost>
    </IfModule>
    Lorsque j'essaye de créer un vhost qui répond a toutes les autres requêtes je suis systématiquement renvoyé vers le site https://dev.site.com

    je n'arrive pas a trouver la coquille ! vous avez des pistes ?

    Merci

  2. #2
    Membre actif Avatar de dancom5
    Homme Profil pro
    Inscrit en
    janvier 2010
    Messages
    750
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48

    Informations forums :
    Inscription : janvier 2010
    Messages : 750
    Points : 248
    Points
    248

    Par défaut

    Bonjour elpablodelcasata.

    Je doute fort que ça puisse marcher le VirtualHost par défaut sur le port 443. Sur le port 80, oui ça marche bien.
    J'ai passé la journée d'hier et la nuit à tenter de faire un par défaut sur 443 et rien à faire.

    Ce que vous chercher à faire, c'est d'avoir un répertoire par défaut quand on ne tape pas le bon domaine situé
    dans l'un de vos Virtualhost. Selon mes essaies, ça marche sur 80 mais pas sur 443.

    Je me permet d'intervenir puisque je comprends le problème pour l'avoir aussi.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    <VirtualHost *:80>
      DocumentRoot "/cheminpardéfaut"
    # le premier est par défaut si les autres ne correspond pas
    </VirtualHost>
     
    <VirtualHost *:80>
     DocumentRoot "/chemin1"
     ServerName tondomain.ltd
    </VirtualHost>
    Si tu tape autre chose que tondomain.ltd, ça ira au premier.
    Mais, si tu avais *:443 à la place, non, ça ne marchera pas.

    Moi, dans mon cas, j'ai un virtualhost sur le port 80, un sur le port 443, et pour faire deux par défaut dont un sur 80 et l'autre 443,
    Il faudrait faire _default_:* mais, à cause du port 443, ça ne marche pas.
    Mais, sur le port 80 oui.
    On oublie souvent la simplicité ou la base dans la vie: Maslow

  3. #3
    Membre actif Avatar de dancom5
    Homme Profil pro
    Inscrit en
    janvier 2010
    Messages
    750
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48

    Informations forums :
    Inscription : janvier 2010
    Messages : 750
    Points : 248
    Points
    248

    Par défaut Mieux que _default_ pour 443 et autre

    Après plusieurs essaies avec _default_ sur le port 443 quand on veux aussi le faire sur le 80.
    J'ai trouvé cette astuce pour Apache 2.3+ et ça marche super bien tel que j'ai supprimé
    le Host virutel par défaut.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    <VirtualHost *:80>
    DocumentRoot "/..."
    ServerName tondomain.ltd
    <If "%{HTTP_HOST} != 'tondomain.ltd'">
        Redirect permanent "/" "http://tondomain.ltd/"
    </If> 
    ...
    </VirtualHost>
    Si quelqu'un tentait de scanner votre serveur ou simplement de taper un sous-domaine dans
    le host virutel, il sera redirigé vers le bon url que vous accordé qui devrait être le même
    host que votre servername. OU encore, le rediriger vers un host hole qui sert à rien 0.0.0.0
    de manière à décourager les scannes de port.

    Ça fonctionne bien sous 2.4 de Apache sur Windows 7 sur le port 80 et 443. Mais, il faut
    mettre cela dans tous vos virtuel host.

    Pour dire que _default_ sur 443, ça ne marche pas et selon mes recherches, je ne suis pas le seul
    à qui ça ne marche pas.

    Souhaitant que ça peut aider quelqu'un.
    On oublie souvent la simplicité ou la base dans la vie: Maslow

Discussions similaires

  1. [Bind9] problème de configuration des DNS
    Par stc074 dans le forum Debian
    Réponses: 10
    Dernier message: 10/03/2013, 22h45
  2. Problème Vista : Configuration des mises à jour
    Par GG971 dans le forum Windows Vista
    Réponses: 0
    Dernier message: 21/09/2011, 13h30
  3. Réponses: 0
    Dernier message: 19/11/2009, 14h54
  4. Configuration des vhosts
    Par Gecko dans le forum Apache
    Réponses: 3
    Dernier message: 23/08/2009, 16h02
  5. Réponses: 5
    Dernier message: 09/03/2007, 17h53

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo