1. #1
    Membre du Club
    Homme Profil pro
    Formateur en informatique
    Inscrit en
    août 2009
    Messages
    68
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Formateur en informatique

    Informations forums :
    Inscription : août 2009
    Messages : 68
    Points : 58
    Points
    58

    Par défaut Images invisibles lors d'interpolation

    [Flash CS6]

    Bonjour !

    Mes images deviennent invisibles lors d'interpolation classique. Je m'explique :

    1. Je crée un nouveau projet ActionScript 3
    2. Je dessine un rectangle dans la première image de mon unique calque 1
    3. Je clique avec le bouton droit de ma souris sur l'image 10 de ce même calque et je choisis "Insérer une image clé"
    Mon rectangle est visible sur toutes les images de 1 à 10 (Normal)
    4. Je déplace un peu mon rectangle de l'image 10 sur sa droite
    5. Je clique sur une image intermédiaire (par exemple la 5) avec le bouton droit de ma souris, et je choisis "Créer une interpolation classique"
    Une flèche horizontale me montre que ça s'est bien passé.

    MAIS ... Je ne vois plus mon rectangle QUE sur l'image 10. Il a disparu de toutes les autres images, y compris la 1 ! Même phénomène si j'insère un symbole.

    Et ce qui est vraiment bizarre, c'est que quand je teste avec Contrôle/Lire : j'ai un écran blanc, et BOUM le rectangle apparaît, conformément à ce que je vois dans la timelime
    MAIS
    Contrôle/Tester la séquence me montre correctement l'animation : Le rectangle se déplace bien de gauche à droite.

    Des idées ?

    Et pourtantNom : Flas.jpg
Affichages : 36
Taille : 123,6 Ko

  2. #2
    Membre régulier
    Femme Profil pro
    Autre
    Inscrit en
    janvier 2017
    Messages
    73
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Autre

    Informations forums :
    Inscription : janvier 2017
    Messages : 73
    Points : 114
    Points
    114

    Par défaut

    Bonjour,
    J'ai fait quelques tests et réfléchi à une fausse manipulation, mais non je n'ai pas d'explication.
    Ce que j'ai déjà eu, ce sont des éléments qui ne s'affichaient plus, avec du vectoriel complexe et Flash ouvert depuis longtemps. Il suffisait de relancer Flash.
    Au niveau des interpolations, il me semble avoir déjà vu des images intermédiaires ne donnant pas le bon rendu, mais juste dans Flash pas au niveau du swf.

    En cliquant sur l'image 1, puis en sélectionnant tout avec "Ctrl+A", qu'est-ce que cela donne au niveau des propriétés ?
    Le plus simple serait peut-être de fournir le fichier.

  3. #3
    Membre du Club
    Homme Profil pro
    Formateur en informatique
    Inscrit en
    août 2009
    Messages
    68
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Suisse

    Informations professionnelles :
    Activité : Formateur en informatique

    Informations forums :
    Inscription : août 2009
    Messages : 68
    Points : 58
    Points
    58

    Par défaut

    Incroyable !

    EN lisant ton message, je me suis dit qu'effectivement, c'était un peu bête de ma part de ne pas avoir joint le fichier.

    Comme je ne l'avais pas sauvegardé, je l'ai recréé, mais c'était très facile puisque ça faisait une dizaine de fois que je recommençais pour essayer de comprendre

    Et là, par l'opération du saint-esprit, BOUM ! ça marche !!!

    Et la cerise sur le gâteau, le véritable fichier (bien plus complexe mais qui présentait les mêmes symptômes) re-fonctionne !

    Le problème semble survenir de manière aléatoire...

    En tout cas merci !

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Image scintillante lors d'un redimensionnement
    Par QAYS dans le forum Delphi
    Réponses: 3
    Dernier message: 22/02/2007, 11h34
  2. Réponses: 1
    Dernier message: 13/12/2006, 00h40
  3. Chargement d'Images invisibles
    Par Toinou0123 dans le forum JavaScript
    Réponses: 3
    Dernier message: 01/10/2006, 16h41
  4. [Image] scintillement lors déplacement sur autre composant
    Par lilou77 dans le forum Interfaces Graphiques en Java
    Réponses: 21
    Dernier message: 07/12/2005, 09h27
  5. Les images clignotes lors du Mouse over
    Par The Bat ! dans le forum C++Builder
    Réponses: 4
    Dernier message: 30/05/2005, 10h37

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo