1. #1
    Membre du Club
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    mars 2004
    Messages
    67
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : mars 2004
    Messages : 67
    Points : 45
    Points
    45

    Par défaut Message d'erreur: Target runtime jdk1.8.0_121 not defined

    Bonjour à tous.

    Je travaille sous Windows 10 64bits et Eclipse Indigo. Ma version de java est la 1.8.0_121. Dans mon espace de travail j'ai 5 projets (4 applications et projet web). Lorsque j'essaie de compiler ces quatre applications, j'obtiens, pour chacune d'entre elles, le message suivant: Target runtime jdk1.8.0.121 is not defined.

    Pour chacun des 4 projets, il y a un fichier xml org.eclipse.wst.common.project.facet.core.xml dont le contenu est le suivant:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    <?xml version="1.0" encoding="UTF-8"?>
    <faceted-project>
      <runtime name="jdk1.8.0_121"/>
      <installed facet="java" version="1.8"/>
    </faceted-project>
    Dans le menu Windows->Preferences->Installed JREs, mon JRE, nommé jdk1.8.0_121, est sélectionné.
    Dans le menu Windows->Preferences->Build path, le champ "As jre library use" est positionné sur "JRE container"

    Je n'arrive pas à solutionner le problème.

    Toute aide sera la bienvenue.
    Merci par avance.

  2. #2
    Modérateur
    Avatar de joel.drigo
    Homme Profil pro
    Ingénieur R&D - Développeur Java/Eclipse RCP
    Inscrit en
    septembre 2009
    Messages
    10 211
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Ingénieur R&D - Développeur Java/Eclipse RCP
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2009
    Messages : 10 211
    Points : 24 479
    Points
    24 479
    Billets dans le blog
    2

    Par défaut

    Salut,

    Premièrement, ce serait bien de passer à une version récente de Eclipse, genre Neon.2 (Version 4.6), plutôt que Indigo (version 3.7 !) qui date de 2011 !

    Ensuite, ce n'est pas normal d'avoir runtime="java xxx" : runtime c'est pour le serveur, tu devrais avoir par exemple : runtime="Apache Tomcat V8.0"...
    Ce qui n'est pas clair dans ce que tu dis, c'est que tu as 5 projet, 4 applications et 1 projet web. Par projet Web, tu parles de Dynamic Web Project je suppose. Mais "applications" ? C'est quoi ?
    Le fichier de configuration de facets, tu ne devrais l'avoir que pour un projet "WTP", avec facets donc. Pour les projets Java par exemple, c'est le .classpath qui a une entrée de type con, sur le container associé à la JRE.
    M'enfin, en théorie, tu n'as pas besoin d'aller dans les fichiers : les interfaces de configuration évitent d'avoir à aller se farcir les fichiers, et à se tromper.

    Par ailleurs, tu parles de Installed JREs, mais tu as bien configuré l'association entre environnement d'exécution et JRE, dans la préférence Execution Environments ?
    La plupart des réponses à vos questions sont déjà dans les FAQs ou les Tutoriels, ou peut-être dans une autre discussion : utilisez la recherche interne.
    Des questions sur Java : consultez le Forum Java. Des questions sur l'EDI Eclipse ou la plateforme Eclipse RCP : consultez le Forum Eclipse.
    Une question correctement posée et rédigée et vous aurez plus de chances de réponses adaptées et rapides.
    N'oubliez pas de mettre vos extraits de code entre balises CODE (Voir Mode d'emploi de l'éditeur de messages).
    Nouveau sur le forum ? Consultez Les Règles du Club.

  3. #3
    Membre chevronné
    Avatar de Mickael_Istria
    Homme Profil pro
    Développeur Expert Eclipse RCP
    Inscrit en
    juillet 2008
    Messages
    1 029
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Expert Eclipse RCP
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2008
    Messages : 1 029
    Points : 2 136
    Points
    2 136

    Par défaut

    Citation Envoyé par joel.drigo Voir le message
    Premièrement, ce serait bien de passer à une version récente de Eclipse, genre Neon.2 (Version 4.6), plutôt que Indigo (version 3.7 !) qui date de 2011 !
    Je pense meme que c'est necessaire. Le support de Java 8 dans Eclipse IDE a ete developpe en 2013 et livre en 2014. Avec un Indigo de 2011, il n'y a pas grand chose a esperer.
    Tu fais du JEE/Web/Mobile dans Eclipse? Essaye JBoss Tools !
    Read my blog about Eclipse | Follow me on twitter

Discussions similaires

  1. Messages d'erreurs avec access 2007 runtime SP1
    Par praspail dans le forum Runtime
    Réponses: 4
    Dernier message: 10/09/2008, 15h09
  2. Messages d'erreur sur install Runtime
    Par curt dans le forum Runtime
    Réponses: 6
    Dernier message: 30/11/2007, 23h41
  3. Config Serveur? Message d'erreur "Runtime Error"
    Par Poussy-Puce dans le forum ASP.NET
    Réponses: 6
    Dernier message: 29/08/2007, 23h16
  4. Réponses: 10
    Dernier message: 19/02/2007, 16h44
  5. Message d'erreur Runtime
    Par chleuh dans le forum Langage
    Réponses: 4
    Dernier message: 25/07/2005, 14h20

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo