Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Discussion :

Solr Highlighting ne retourne aucune donnée


Sujet :

Plateformes (Java EE, Jakarta EE, Spring) et Serveurs

  1. #1
    Membre actif
    Homme Profil pro
    développeur
    Inscrit en
    octobre 2004
    Messages
    436
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : développeur
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : octobre 2004
    Messages : 436
    Points : 249
    Points
    249
    Par défaut Solr Highlighting ne retourne aucune donnée
    Bonjour,

    J'ai installé Solr 6.4.1, lancé une indexation d'un répertoire contenant différents fichiers (dont pdf).
    Quand je fais une recherche sur le mot "modifier", j'ai bien des résultats dans "response", mais dans "highlighting", je n'ai que les id des documents.
    Je ne sais plus comment faire.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    {
      "responseHeader":{
        "status":0,
        "QTime":0,
        "params":{
          "q":"modifier",
          "hl":"on",
          "indent":"on",
          "fl":"id, date, title, score",
          "rows":"1",
          "wt":"json",
          "_":"1486915015796"}},
      "response":{"numFound":119,"start":0,"maxScore":6.1039233,"docs":[
          {
            "id":"id_du_document_xxxxxx.pdf",
            "date":["2013-11-25T14:56:04Z"],
            "title":["Titre du document"],
            "score":6.1039233}]
      },
      "highlighting":{
        "id_du_document_xxxxxx.pdf":{}}}

  2. #2
    Membre actif
    Homme Profil pro
    développeur
    Inscrit en
    octobre 2004
    Messages
    436
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : développeur
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : octobre 2004
    Messages : 436
    Points : 249
    Points
    249
    Par défaut Trouvé !
    J'ai compris ce qu'il faut faire.

    1. Modifier le fichier solr/server/solr/votre_instance/conf/solrconfig.xml
      mettre en commentaire les lignes
      Code : Sélectionner tout - Visualiser dans une fenêtre à part
      1
      2
      <str name="fmap.meta">ignored_</str>
      <str name="fmap.content">_text_</str>
      Si on ne fait pas cela, lorsqu'on lance une requête dans l'interface d'administration de Solr (query), avec fl = content et/ou hl = content, rien n'est renvoyé (une interrogation sur _text_ ne donne rien non plus).
    2. Arrêter/relancer solr
    3. Lancer une première indexation
    4. Modifier le fichier solr/server/solr/votre_instance/conf/managed-schema
      Lorsque vous créez votre_instance, ce fichier est créé et initialisé avec un contenu par défaut.
      Il est ensuite complété/modifié lors de la première indexation.
      il faut alors remplacer (ou ajouter) la ligne
      Code : Sélectionner tout - Visualiser dans une fenêtre à part
      <field name="content" type="strings"/>
      par
      Code : Sélectionner tout - Visualiser dans une fenêtre à part
      <field name="content" type="text_general" indexed="false" stored="true" multiValued="true"/>
    5. Arrêter/relancer solr
    6. Lancer une nouvelle indexation

    ...et voilà, des données apparaissent bien dans le highlighting.content

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. WMS Geoportail Vecteur: Aucune donnée retournée
    Par agodfrin dans le forum IGN API Géoportail
    Réponses: 3
    Dernier message: 07/08/2014, 13h08
  2. Erreur : La requête ne retourne aucune donnée
    Par guigui81 dans le forum Débuter
    Réponses: 6
    Dernier message: 08/07/2011, 14h26
  3. [Vxi3] reqeête ne retourne aucune donnée
    Par ahmed_amine dans le forum Deski
    Réponses: 0
    Dernier message: 11/05/2011, 12h49
  4. Réponses: 1
    Dernier message: 16/07/2008, 01h46
  5. Réponses: 2
    Dernier message: 29/01/2008, 20h20

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo