Discussion: Masse bruit pile AA

  1. #1
    Membre actif
    Homme Profil pro
    Technicien Layout
    Inscrit en
    août 2015
    Messages
    251
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Technicien Layout

    Informations forums :
    Inscription : août 2015
    Messages : 251
    Points : 256
    Points
    256

    Par défaut Masse bruit pile AA

    Bonjour,

    je rencontre un petit pb d'alimentation sur une nucleo-L476RG. je souhaiterais l'alimenter avec 3 piles AA. En l'alimentant de cette manière j'ai un comportement erratique de ma board.

    J'entends par erratique certaine fonction marche comme allumer une Led, j'ai bien 3.3V post regulateur par contre je suis un peu light sur le 5V j'ai 4.4V (mais je n'utilise pas de 5V dans mon appli).

    La ou ca ce complique c'est lorsque j'ajoute un capteur de distance qui fonctionne en I2C (alim 3.3V/GND).

    Si j'alimente ma carte depuis une breadboard (alimentée par mon PC) ou USB l'appli fonctionne par contre juste avec les 3 piles cela ne fonctionne que si j'ajoute la masse de la breadboard (c.à.d. du pc c.à.d de la maison).

    Je me suis dit qu'il y avait un problème sur la masse de mon circuit avec un effet antenne et que je recuperais du bruit sur gnd de ma carte.

    J'ai essayé de faire des mesures avec mon Oscilloscope usb (smartscope labnation) et mon multimètre pour voir si j'avais du bruit sur gnd mais je ne suis pas sur de faire la bonne manip.

    Si je mesure la ddp entre gnd de ma carte et gnd (-) de ma breadboard je recupère 400mV peak to peak ( Cette différence est déja présente quand je mesure ente le moins des 3 piles AA et gnd de ma breadbord) du coup j'ai l'impression que cette valeur ne veux rien dire. J'ai également mesuré la ddp avec mon mutlimètre et j'ai 400mV en postion alternatif et rien position continu.

    Partant du constat que si j'applique une masse sur mon circuit cela fonctionne je suis resté sur l'idée du bruit sur gnd de ma carte et on m'a conseiller de regardé si il n'y avait pas une pin en l'air sur ma board ( une pin configurée en input est connecté a rien ).

    C'était le cas après correction de mes GPIO ( les GPIO déclarées dans mon prg sont toutes utilisées a présent ) mais le problème reste identique.

    Dernier point si je mesure avec mon multimètre aux bornes de mes 3 piles AA j'ai 4.5V donc on peut dire vu les mesures que j'ai indiqué plus haut 3.3v 5v que le 0 (gnd/masse/-) n'est pas trop décalé...

    Si quelqu'un a une idée merci d'avance.

  2. #2
    Modérateur
    Avatar de Vincent PETIT
    Homme Profil pro
    Ancien développeur matériel électronique (Hard/Soft)
    Inscrit en
    avril 2002
    Messages
    1 696
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Ancien développeur matériel électronique (Hard/Soft)
    Secteur : Service public

    Informations forums :
    Inscription : avril 2002
    Messages : 1 696
    Points : 5 373
    Points
    5 373

    Par défaut

    Salut Julien,
    Est ce que tu peux faire un schéma de câblage dans le cas où ça marche et dans le cas où ça ne marche pas.

    Je m'y perds un peu avec cette histoire de breadboard.

    Tu as le schéma électronique de ta nucleo-L476RG ? Je voudrai voir la réf du régulateur 3.3V pour voir son drop out.

    A+
    La science ne nous apprend rien : c'est l'expérience qui nous apprend quelque chose.
    Richard Feynman

  3. #3
    Modérateur
    Avatar de sevyc64
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    8 994
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 44
    Localisation : France, Pyrénées Atlantiques (Aquitaine)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : janvier 2007
    Messages : 8 994
    Points : 23 821
    Points
    23 821

    Par défaut

    3 piles 1,5V c'est trop faible pour un montage qui doit être alimenté en 5V. Tes 3 piles te donneront au mieux 4,5V, à pleine charge et sous faible puissance. Dès que tu vas tirer un peu plus de puissance, la tension peut chuter de façon importante, jusqu'à 1.2V* par pile, ce qui te fait plus que 3.6V pour l'ensemble.

    Si tu veux vraiment alimenter ton montage avec ces 3 piles, il faudrait peut-être prévoir une alim avec un convertisseur DC/DC capable de remonter la tension à 5V (au prix forcément, à puissance égale, d'une durée de vie plus faible des piles).



    * Les montages fonctionnant avec des jeux de piles à 1,5V doivent être prévus pour fonctionner avec une tension qui descend jusqu'à 1,2V par pile. 1,2V c'est la tension nominale des accumulateurs (piles rechargeables) de même format, qui peuvent être utilisés à la place des piles. En dessous de cette tension, le fonctionnement n'est pas garantie.
    --- Sevyc64 ---

    Parce que le partage est notre force, la connaissance sera notre victoire

  4. #4
    Membre actif
    Homme Profil pro
    Technicien Layout
    Inscrit en
    août 2015
    Messages
    251
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Technicien Layout

    Informations forums :
    Inscription : août 2015
    Messages : 251
    Points : 256
    Points
    256

    Par défaut

    Citation Envoyé par Vincent PETIT Voir le message
    Salut Julien,
    Est ce que tu peux faire un schéma de câblage dans le cas où ça marche et dans le cas où ça ne marche pas.

    Je m'y perds un peu avec cette histoire de breadboard.

    Tu as le schéma électronique de ta nucleo-L476RG ? Je voudrai voir la réf du régulateur 3.3V pour voir son drop out.

    A+
    Bonsoir Vincent, merci pour ton aide ci-joint un schéma de câblage dans le cas ou c'est HS

    Appli HS:

    Nom : nucleo_board_HS.png
Affichages : 67
Taille : 607,4 Ko

    Pour résumer quand le capteur détecte quelque chose la pin A0 passe a l'état bas et la led doit s'allumer.
    Pour info GPIO0 est la pin de reset (hardware) du capteur et GPIO1 et la pin d'interruption (software) du capteur.

    Appli OK:

    Nom : nucleo_board_OK.png
Affichages : 68
Taille : 640,7 Ko

    Il y a juste un câble en plus qui part de gnd de ma breadboard vers gnd de la nucleo.

    Du coup en faisant le schéma de cablage je me rends compte que je suis a coté de la plaque... en faite mon appli fonctionne c'est juste que ma led ne s'allume pas parce que quand A0 passe a l'état bas je ne suis pas sur la mm masse... du coup pour confirmer je vais mesurer A0 avec mon multimètre et voir si qd le capteur detecte quelque chose A0 doit passer de 3.3V a 0V

    Pour terminer voici le schéma des régulateurs:

    Nom : regulateur_VIN_E5V.png
Affichages : 68
Taille : 35,6 Ko

  5. #5
    Membre actif
    Homme Profil pro
    Technicien Layout
    Inscrit en
    août 2015
    Messages
    251
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Technicien Layout

    Informations forums :
    Inscription : août 2015
    Messages : 251
    Points : 256
    Points
    256

    Par défaut

    Citation Envoyé par sevyc64 Voir le message
    3 piles 1,5V c'est trop faible pour un montage qui doit être alimenté en 5V. Tes 3 piles te donneront au mieux 4,5V, à pleine charge et sous faible puissance. Dès que tu vas tirer un peu plus de puissance, la tension peut chuter de façon importante, jusqu'à 1.2V* par pile, ce qui te fait plus que 3.6V pour l'ensemble.

    Si tu veux vraiment alimenter ton montage avec ces 3 piles, il faudrait peut-être prévoir une alim avec un convertisseur DC/DC capable de remonter la tension à 5V (au prix forcément, à puissance égale, d'une durée de vie plus faible des piles).



    * Les montages fonctionnant avec des jeux de piles à 1,5V doivent être prévus pour fonctionner avec une tension qui descend jusqu'à 1,2V par pile. 1,2V c'est la tension nominale des accumulateurs (piles rechargeables) de même format, qui peuvent être utilisés à la place des piles. En dessous de cette tension, le fonctionnement n'est pas garantie.
    Merci pour le retour, mais dans mon appli il n' y a pas de composant qui fonctionne a 5V tout est en 3.3V j'ai controlé la tension, elle est ok. Pour l'instant je consomme entre 70 et 80 mA (car non optimisé).

  6. #6
    Modérateur
    Avatar de Vincent PETIT
    Homme Profil pro
    Ancien développeur matériel électronique (Hard/Soft)
    Inscrit en
    avril 2002
    Messages
    1 696
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Ancien développeur matériel électronique (Hard/Soft)
    Secteur : Service public

    Informations forums :
    Inscription : avril 2002
    Messages : 1 696
    Points : 5 373
    Points
    5 373

    Par défaut

    Citation Envoyé par julien terrier Voir le message
    je ne suis pas sur la mm masse...
    oui c'est juste ça le problème

    J'ai réussi à trouver la datasheet de la carte, j'y retrouve les même schéma que celui que tu as posté.
    Le +E5V issu des 3 piles alimentent deux régulateurs, le premier est celui que je vois sur le schéma et l'autre est plus bas dans la datasheet. Ces deux régulateurs acceptent des tensions assez basses pour générer 3,3V et la tension des 3 piles est suffisante.

    Par contre la datasheet préconise quand même d'être entre 4,75V et 5,25V pour +E5V (c'est un sécurité car il y a des diodes anti-retours qui font perdre un peu de tension)

    Nom : Capture du 2017-01-14 23-38-14.png
Affichages : 68
Taille : 24,3 Ko
    La science ne nous apprend rien : c'est l'expérience qui nous apprend quelque chose.
    Richard Feynman

  7. #7
    Membre actif
    Homme Profil pro
    Technicien Layout
    Inscrit en
    août 2015
    Messages
    251
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Technicien Layout

    Informations forums :
    Inscription : août 2015
    Messages : 251
    Points : 256
    Points
    256

    Par défaut

    Citation Envoyé par Vincent PETIT Voir le message
    oui c'est juste ça le problème

    J'ai réussi à trouver la datasheet de la carte, j'y retrouve les même schéma que celui que tu as posté.

    Le +E5V issu des 3 piles alimentent deux régulateurs, le premier est celui que je vois sur le schéma et l'autre est plus bas dans la datasheet. Ces deux régulateurs acceptent des tensions assez basses pour générer 3,3V et la tension des piles est suffisante.

    Par contre la datasheet préconise quand même d'être entre 4,75V et 5,25V (c'est du à la présence de diodes anti-retour qui font perdre un peu de tension)
    J'ai lu les mm préconisation que toi mais bon ca fonctionne avec 3 piles AA, sinon il faudrait ajouter un DC boost comme l'a indiqué sevyc64. Selon toi quelle sont les risques de rester dans cette config juste avec les 3 piles AA? les piles seront efficace moins longtemps car quand elle vont se decharger et perdre en tension cela risque d’être insuffisante a l'entrée des régulateurs ?

  8. #8
    Modérateur
    Avatar de Vincent PETIT
    Homme Profil pro
    Ancien développeur matériel électronique (Hard/Soft)
    Inscrit en
    avril 2002
    Messages
    1 696
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Ancien développeur matériel électronique (Hard/Soft)
    Secteur : Service public

    Informations forums :
    Inscription : avril 2002
    Messages : 1 696
    Points : 5 373
    Points
    5 373

    Par défaut

    Citation Envoyé par julien terrier
    Selon toi quelle sont les risques de rester dans cette config juste avec les 3 piles AA?
    Je ne vois pas de risque lorsque je regarde l'électronique si ce n'est comme le dit sevyc64 "que les piles ne vont pas rester à 1.5V et qu'il faut tenir compte de cette décharge".
    On peut tout calculer en fonction de la capacité des piles, souvent exprimé en mAh et le courant que tu consommes en mA. Il y a des datasheet sur des piles et on te donne la courbe de décharge qui est souvent linéaire.

    Concernant le régulateur de compéte LD39050 (celui de ton schéma) il a un dropout de 50mV (typique) si tu tirent 100mA dessus. Ce qui veut dire que tant que la tension en entrée du régulateur est de (3.3V+0.05V = 3.35V) alors il sortira 3.3V
    Voir le graphique page 11 de la datasheet http://www.st.com/content/ccc/resour...CD00227527.pdf

    Concernant le régulateur LD3985 (celui sur mon schéma) c'est quasiment du même tonneau, dropout de 45mV (typique) si on tirent dessus 100mA par contre il faut tenir compte de la chute de tension dans la diode BAT60 qui est de 0.2V (typique) si on fait passer 100mA. Donc ici, tant qu'en entrée du régulateur on a (3.3V+0.045V+0.2V = 3.54V) alors c'est bon pour la sortie.
    Voir le tableau du régulateur page 7 (pas de graphique) de la datasheet http://www.st.com/content/ccc/resour...CD00003395.pdf
    Voir le tableau de la diode page 2 de la datasheet http://www.infineon.com/dgdl/Infineo...13def70c9304a9

    Ça fait que grosso modo et avec les valeurs typiques ci dessus, une fois les 3 piles arrivées à 1.18V chacune, ça ne fonctionne plus car le LD3985 et la diode anti-retour dans le passage a au moins besoin de 3.54V. Le temps que mettrons les piles a aller de 1.5V à 1.18V est fonction du courant que tu consommes et de la capacité en mAh des piles. PS ; Ton micro a plusieurs modes de veilles (périphérique en veille ou périphérique + CPU en veille ou veille complète avec RAM rétention c'est presque la mort clinique là et encore d'autre mode)




    Si tu es puriste, c'est plus prudent :
    • Ne jamais prendre les valeurs typiques d'une datasheet. On prend toujours la valeur la plus défavorable.
    • Toujours vérifier dans les graphiques le comportement en température car même une valeur MAX ou MIN suivant le cas le plus défavorable, est donné pour une température fixe. Les dropout des régulateurs ou même la tension VF de la diode citée plus haut évoluent en fonction de la température.
    • Toujours connaitre les courants mis en jeu car les valeurs de la datasheet sont fonctions des courants et températures
    La science ne nous apprend rien : c'est l'expérience qui nous apprend quelque chose.
    Richard Feynman

  9. #9
    Membre actif
    Homme Profil pro
    Technicien Layout
    Inscrit en
    août 2015
    Messages
    251
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Technicien Layout

    Informations forums :
    Inscription : août 2015
    Messages : 251
    Points : 256
    Points
    256

    Par défaut

    Citation Envoyé par Vincent PETIT Voir le message
    Je ne vois pas de risque lorsque je regarde l'électronique si ce n'est comme le dit sevyc64 "que les piles ne vont pas rester à 1.5V et qu'il faut tenir compte de cette décharge".
    On peut tout calculer en fonction de la capacité des piles, souvent exprimé en mAh et le courant que tu consommes en mA. Il y a des datasheet sur des piles et on te donne la courbe de décharge qui est souvent linéaire.

    Concernant le régulateur de compéte LD39050 (celui de ton schéma) il a un dropout de 50mV (typique) si tu tirent 100mA dessus. Ce qui veut dire que tant que la tension en entrée du régulateur est de (3.3V+0.05V = 3.35V) alors il sortira 3.3V
    Voir le graphique page 11 de la datasheet http://www.st.com/content/ccc/resour...CD00227527.pdf

    Concernant le régulateur LD3985 (celui sur mon schéma) c'est quasiment du même tonneau, dropout de 45mV (typique) si on tirent dessus 100mA par contre il faut tenir compte de la chute de tension dans la diode BAT60 qui est de 0.2V (typique) si on fait passer 100mA. Donc ici, tant qu'en entrée du régulateur on a (3.3V+0.045V+0.2V = 3.54V) alors c'est bon pour la sortie.
    Voir le tableau du régulateur page 7 (pas de graphique) de la datasheet http://www.st.com/content/ccc/resour...CD00003395.pdf
    Voir le tableau de la diode page 2 de la datasheet http://www.infineon.com/dgdl/Infineo...13def70c9304a9

    Ça fait que grosso modo et avec les valeurs typiques ci dessus, une fois les 3 piles arrivées à 1.18V chacune, ça ne fonctionne plus car le LD3985 et la diode anti-retour dans le passage a au moins besoin de 3.54V. Le temps que mettrons les piles a aller de 1.5V à 1.18V est fonction du courant que tu consommes et de la capacité en mAh des piles. PS ; Ton micro a plusieurs modes de veilles (périphérique en veille ou périphérique + CPU en veille ou veille complète avec RAM rétention c'est presque la mort clinique là et encore d'autre mode)




    Si tu es puriste, c'est plus prudent :
    • Ne jamais prendre les valeurs typiques d'une datasheet. On prend toujours la valeur la plus défavorable.
    • Toujours vérifier dans les graphiques le comportement en température car même une valeur MAX ou MIN suivant le cas le plus défavorable, est donné pour une température fixe. Les dropout des régulateurs ou même la tension VF de la diode citée plus haut évoluent en fonction de la température.
    • Toujours connaitre les courants mis en jeu car les valeurs de la datasheet sont fonctions des courants et températures
    Merci pour les explications très instructif comme toujours mais finalement la consommation a un instant T du circuit ne jouera que sur le dropout des régulateurs, comme tu l'indique il faut se rapprocher des datasheets des composants afin de voir la chute de tension en fonction de la t°.

    Donc si je résume mesurer la consommation de courant de l'appli lorsqu'elle en pleine effort en déduire le dropout du régulateur le plus critique inclure les variations de tension en fonction de la T°, prendre le cas le plus critique.

    Ceci nous donnera la tension min avant la mort de l'appli... exercice que tu as fait en prenant une conso de 100mA et ajouter la variation de tension en fonction de la T° (cette partie me semble un peu plus difficile car il faudrait également mesurer la conso dans ces conditions pour etre vraiment précis).

    Déterminer la capacité des 3 piles et estimer la durée de l'appli en fonction de la conso.

    Actuellement mon code n'est pas du tout optimisé je fonctionne en polling (conso max du micro) aucune gestion de mise en veille a l'issue je souhaite passer en interruption et effectuer une mise en veille du micro et du capteur il y a encore du taf, que du bon je ne comprends pas les personnes qui n'aiment pas l'electronique/informatique tant c'est passionnant

    A+

  10. #10
    Modérateur
    Avatar de Vincent PETIT
    Homme Profil pro
    Ancien développeur matériel électronique (Hard/Soft)
    Inscrit en
    avril 2002
    Messages
    1 696
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Ancien développeur matériel électronique (Hard/Soft)
    Secteur : Service public

    Informations forums :
    Inscription : avril 2002
    Messages : 1 696
    Points : 5 373
    Points
    5 373

    Par défaut

    Tu as très bien résumé !
    Dans mon ancien boulot nous avions des étuves (chambre à température) dans les quelles je mettais mes appareils et je reglais l'étuve à -5 puis à +35 degrés pour voir le comportement.

    Dans un développement perso, on fait un postulat. Disons température de l'environnement ou ambiante = 35 degrés

    Puis en fonction des courants en jeu tu peux connaître l'élévation en température des composants (dans la doc des régulateurs c'est exprimé en degrés par Watt). Enfin tu peux trouver les variations de tensions.

    Citation Envoyé par julien terrier Voir le message
    Actuellement mon code n'est pas du tout optimisé je fonctionne en polling (conso max du micro) aucune gestion de mise en veille a l'issue je souhaite passer en interruption et effectuer une mise en veille du micro et du capteur il y a encore du taf, que du bon
    Bien vu ! Avec programme reposant le plus possible sur des interruptions, le programme principal ne fait finalement qu'attendre, du moins il passe du temps à attendre, et donc il peut être mis en veille adaptée (il y a des modes veilles avec reveilles sur interruption)

    Citation Envoyé par julien terrier Voir le message
    je ne comprends pas les personnes qui n'aiment pas l'electronique/informatique tant c'est passionnant
    On est d'accord mais il faut aimer aller dans les détails pour trouver ou se cache le diable ! Et ça, figure toi qu'il n'y a pas beaucoup de monde qui aiment en réalité.
    La science ne nous apprend rien : c'est l'expérience qui nous apprend quelque chose.
    Richard Feynman

  11. #11
    Expert éminent
    Avatar de Auteur
    Profil pro
    Inscrit en
    avril 2004
    Messages
    6 719
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 6 719
    Points : 9 132
    Points
    9 132

    Par défaut

    Citation Envoyé par Vincent PETIT Voir le message
    Dans un développement perso, on fait un postulat. Disons température de l'environnement ou ambiante = 35 degrés
    25°C plutôt ?

  12. #12
    Membre actif
    Homme Profil pro
    Technicien Layout
    Inscrit en
    août 2015
    Messages
    251
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Var (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Technicien Layout

    Informations forums :
    Inscription : août 2015
    Messages : 251
    Points : 256
    Points
    256

    Par défaut

    Citation Envoyé par Auteur Voir le message
    25°C plutôt ?
    Relatif a l'endroit ou tu te trouves sur le globe...

    Pour le nord-pas-de-calais je dirais mm 15c° si on fait une moyenne glissante sur l'année

  13. #13
    Modérateur
    Avatar de Vincent PETIT
    Homme Profil pro
    Ancien développeur matériel électronique (Hard/Soft)
    Inscrit en
    avril 2002
    Messages
    1 696
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Ancien développeur matériel électronique (Hard/Soft)
    Secteur : Service public

    Informations forums :
    Inscription : avril 2002
    Messages : 1 696
    Points : 5 373
    Points
    5 373

    Par défaut

    En effet, ou bien 25°C mais ça dépend de l'endroit où va être placé l'électronique.
    Dehors et en plein été c'est carrément 40°C même voir plus, qu'il faut prendre. On a souvent tendance, et moi le premier à mes débuts, a négliger ce paramètre dans les calculs de dissipation thermique des composants (tout ce qui est (Rthjonction/ambiante + Tambiante ) < Tjonction_maxi et compagnie)

    Le pire c'est quand on met ça dans un boitier fermé

    Je pense notamment a tout ce qui est Raspberry, dehors et dans un boitier, en pleine été... à mon avis
    La science ne nous apprend rien : c'est l'expérience qui nous apprend quelque chose.
    Richard Feynman

  14. #14
    Modérateur
    Avatar de Vincent PETIT
    Homme Profil pro
    Ancien développeur matériel électronique (Hard/Soft)
    Inscrit en
    avril 2002
    Messages
    1 696
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Pas de Calais (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Ancien développeur matériel électronique (Hard/Soft)
    Secteur : Service public

    Informations forums :
    Inscription : avril 2002
    Messages : 1 696
    Points : 5 373
    Points
    5 373

    Par défaut

    Citation Envoyé par julien terrier Voir le message
    Relatif a l'endroit ou tu te trouves sur le globe...

    Pour le nord-pas-de-calais je dirais mm 15c° si on fait une moyenne glissante sur l'année
    Ch'é vrai, y fait fro chez mi !
    La science ne nous apprend rien : c'est l'expérience qui nous apprend quelque chose.
    Richard Feynman

  15. #15
    Modérateur
    Avatar de sevyc64
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    8 994
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 44
    Localisation : France, Pyrénées Atlantiques (Aquitaine)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : janvier 2007
    Messages : 8 994
    Points : 23 821
    Points
    23 821

    Par défaut

    Citation Envoyé par Auteur Voir le message
    25°C plutôt ?
    25°C de t° ambiante ça peut faire 35 à 40°C au niveau du circuit lui-même, s'il chauffe et qu'il se retrouve dans un boitier fermé (ce qui est quand même, faut le reconnaitre un peu souvent le cas ) et ça peut aussi faire plus au niveau du cœur de la puce elle-même.

    Sauf condition de fonctionnement spécifique, ou indications contraires sur les datasheets, les valeur dites typiques des composants dans les datasheets sont généralement données pour une t° ambiante de 25°C, circuit hors boitier, donc 25°c de t° ambiante réelle du circuit.
    --- Sevyc64 ---

    Parce que le partage est notre force, la connaissance sera notre victoire

  16. #16
    Modérateur

    Homme Profil pro
    Ingénieur électricien
    Inscrit en
    septembre 2008
    Messages
    405
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Suisse

    Informations professionnelles :
    Activité : Ingénieur électricien

    Informations forums :
    Inscription : septembre 2008
    Messages : 405
    Points : 1 182
    Points
    1 182

    Par défaut

    Bonsoir à tous

    J'ai passé mon week-end entre -10° et -20°C, mon smartphone dans le sac à dos était-il dans sa plage de fonctionnement?

    Sur le schéma qui ne marche pas en 4ème message. C'est une bête appli des lois d'ohm et de Kirchhoff.
    La Led est alimentée par le module USB et tirée à la masse du nucleo. Donc si les masses sont flottantes entre elles cela ne marche pas.
    Il faut alimenter la Led par le nucleo, ça ira mieux.

    Les 400mV c'est lié au couplage capacitif du 50Hz domestique. Cela n'a auune influance sur le montage car c'est du mode commun (càd présent sur l'ensemble des tensions de la carte en alimentation flottante. 400mV c'est très faible: avec un multimètre numérique en touchant la pointe de mesure positive j'arrive facilement à plusieurs Volts. Mon record dans ce domaine: 80V en mesurant un fil de phase dans une prise alors que le fusible était retiré. C'est un cas ultra favorable car étant tiré dans une gaine commune, le couplage est fort.

    Bonne soirée

    Delias

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Voir la pile FPU
    Par Qwazerty dans le forum Assembleur
    Réponses: 5
    Dernier message: 11/05/2003, 15h09
  2. Créer des objets sur la pile ?
    Par Cornell dans le forum Langage
    Réponses: 8
    Dernier message: 03/03/2003, 11h47
  3. Etat de la pile sous Linux et Windows
    Par Bibouda dans le forum x86 32-bits / 64-bits
    Réponses: 7
    Dernier message: 16/02/2003, 01h28
  4. La mémoire en Pmode et en Rmode - la pile
    Par le mage tophinus dans le forum Assembleur
    Réponses: 15
    Dernier message: 16/02/2003, 01h00
  5. [TASM] Déclarer le segment de pile
    Par cipher dans le forum x86 16-bits
    Réponses: 2
    Dernier message: 01/10/2002, 03h58

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo