IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Autres IDE Pascal Discussion :

[FPC 3.0.0] Message d'erreur : obsolete switch


Sujet :

Autres IDE Pascal

  1. #1
    Membre du Club
    Homme Profil pro
    Gérant d'un site
    Inscrit en
    février 2014
    Messages
    55
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Saône et Loire (Bourgogne)

    Informations professionnelles :
    Activité : Gérant d'un site
    Secteur : Enseignement

    Informations forums :
    Inscription : février 2014
    Messages : 55
    Points : 43
    Points
    43
    Par défaut [FPC 3.0.0] Message d'erreur : obsolete switch
    Bonsoir

    En compilant, dans la fenêtre Messages du compilateur et du linker, ce message :"you are using the obsolete switch -OP<nr> please use -OP<name>".
    Comment changer cette option ?
    Par ailleurs, constamment dans la fenêtre "compilation completed" est signalée : Erreurs 3.
    A quoi est-ce dû ?

    Avec le même programme-source, FPC 2.6.4 n'affiche pas ces messages.

    Merci de votre aide.

  2. #2
    Rédacteur/Modérateur

    Avatar de Roland Chastain
    Homme Profil pro
    Enseignant
    Inscrit en
    décembre 2011
    Messages
    3 828
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Enseignant

    Informations forums :
    Inscription : décembre 2011
    Messages : 3 828
    Points : 13 685
    Points
    13 685
    Billets dans le blog
    8
    Par défaut
    Bonjour !

    Citation Envoyé par escargot72 Voir le message
    En compilant, dans la fenêtre Messages du compilater et du linker, ce message :"you are using the obsolete switch -OP<nr> please use -OP<name>".
    Comment changer cette option ?
    Si vous tapez fpc -i dans l'invite de commandes, vous obtenez la liste des valeurs pour cette option :

    Supported CPU instruction sets:
    80386,PENTIUM,PENTIUM2,PENTIUM3,PENTIUM4,PENTIUMM,COREI,COREAVX
    COREAVX2
    Il faut donc mettre, par exemple : -Op80386.

    Mais on peut aussi supprimer tout simplement cette option, qui n'est pas nécessaire.

    Citation Envoyé par escargot72 Voir le message
    Par ailleurs, constamment dans la fenêtre "compilaton completed" est signalée : Erreurs 3.
    A quoi est-ce dû ?

    Avec le même programme-source, FPC 2.6.4 n'affiche pas ces messages.
    À l'époque où j'utilisais Dev-Pascal j'avais rencontré un problème du même genre. En regardant dans le code source (de Dev-Pascal), je m'étais aperçu que la procédure qui analyse les messages du compilateur renvoyait de faux résultats parce que le format de ces messages avait changé. Mais cela n'empêchait pas Dev-Pascal de fonctionner.

    Si c'est un problème de ce genre, il n'y a rien d'autre à faire que modifier le code source de Dev-Pascal, ou ne pas tenir compte du message d'erreur.

  3. #3
    Rédacteur/Modérateur

    Avatar de Roland Chastain
    Homme Profil pro
    Enseignant
    Inscrit en
    décembre 2011
    Messages
    3 828
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Enseignant

    Informations forums :
    Inscription : décembre 2011
    Messages : 3 828
    Points : 13 685
    Points
    13 685
    Billets dans le blog
    8
    Par défaut
    Citation Envoyé par Roland Chastain Voir le message
    À l'époque où j'utilisais Dev-Pascal j'avais rencontré un problème du même genre.
    En fait, c'était le même problème.

    http://www.developpez.net/forums/d15...m-repertoires/

    La conclusion à laquelle j'étais arrivé était qu'il fallait modifier le code source de Dev-Pascal. J'avais même essayé, puis abandonné.

    Au fait, le code source de Dev-Pascal n'est plus disponible sur le site de l'auteur : le lien est mort. Quelqu'un en aurait-il conservé une copie ? Moi pas.

  4. #4
    Membre du Club
    Homme Profil pro
    Gérant d'un site
    Inscrit en
    février 2014
    Messages
    55
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Saône et Loire (Bourgogne)

    Informations professionnelles :
    Activité : Gérant d'un site
    Secteur : Enseignement

    Informations forums :
    Inscription : février 2014
    Messages : 55
    Points : 43
    Points
    43
    Par défaut [Free Pascal] version FPC 3.0.0 message d'erreur : obsolete switch
    Merci pour vos réponses.

    Mais, méfiance !
    C'était contrariant.
    Si ça n'a pas d'importance, je ne touche à rien.

    A de prochaines interrogations ...

Discussions similaires

  1. [TSocket] Message d'erreur
    Par rgz dans le forum Web & réseau
    Réponses: 6
    Dernier message: 04/07/2003, 09h16
  2. Surcharger le message d'erreur après un OnException
    Par Tirlibibi dans le forum XMLRAD
    Réponses: 2
    Dernier message: 24/04/2003, 11h42
  3. Réponses: 4
    Dernier message: 04/03/2003, 01h05
  4. [CR] Message d'erreur
    Par nono1 dans le forum SAP Crystal Reports
    Réponses: 2
    Dernier message: 11/09/2002, 14h54
  5. Réponses: 2
    Dernier message: 27/05/2002, 19h46

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo