IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Tomcat et TomEE Java Discussion :

Apache2, Tomcat et mod_jk


Sujet :

Tomcat et TomEE Java

  1. #1
    Nouveau membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    mai 2008
    Messages
    30
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2008
    Messages : 30
    Points : 31
    Points
    31
    Par défaut Apache2, Tomcat et mod_jk
    Bonjour,

    J'ai depuis peu un serveur dédié sur Debian qui va me servir pour afficher des pages web mais je voudrai aussi me mettre aux servlets (à des fins de web services de tests, mais bon, il faut déjà que ça fonctionne ).

    J'ai donc installer un serveur Apache 2 qui fonctionne bien, et j'ai installé aussi un Tomcat (la version 9).

    Pour qu'Apache redirige les requêtes vers Tomcat, j'ai lu qu'il fallait paramétrer mod_jk dans Apache, chose que j'ai faite, mais cela fait plusieurs jours que je tourne en rond, que je modifie mes fichiers de conf, que mes pages web s'affiche mais que je n'arrive à rien faire côté Tomcat et je dois dire que je suis complètement paumé...
    Dernière erreur en date : un p'tit 403 forbidden !!!

    Quelqu'un aurait-il déjà configuré un Tomcat avec mod_jk ?
    Qu'auriez-vous utilisé à ma place, à la place du couplage Apache2/Tomcat ?
    Est-ce mes versions d'Apache et de Tomcat qui sont incompatible ?
    Au pire : comment virer proprement Tomcat pour repartir de zéro ? (ça m'embêterai de formater le serveur mais au pire...)

    Merci d'avance pour toute aide.
    Manu

  2. #2
    Nouveau membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    mai 2008
    Messages
    30
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2008
    Messages : 30
    Points : 31
    Points
    31
    Par défaut
    De retour (pour vous jouer un mauvais tour... bon elle est nulle celle là !)

    J'ai, depuis hier, essayé un paramétrage à l'aide des directives "ProxyPass" et "ProxyPassReverse", que je découvre, dans mon virtual host.

    Il y a du changement, mais c'est pas folichon !

    Voici quelques un de mes paramétrages et le log d'erreur (j'ai un internal error maintenant) :

    /etc/apache2/workers.properties :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    ps=/
    worker.list=worker1
    worker.worker1.port=8009
    worker.worker1.host=127.0.0.1
    worker.worker1.type=ajp13
     
    # Declare the load balancer itself and all the worker nodes
    worker.loadbalancer.type=lb
    worker.loadbalancer.balance_workers=worker1
    worker.list=worker1,loadbalancer
    worker.loadbalancer.sticky_session=true
    /etc/apache2/sites-available/001-tomcat.conf :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    <VirtualHost *:8009>
            ServerName blablabla:)
            ProxyPass / ajp://localhost:8009/
            ProxyPassReverse / ajp://localhost:8009/
            ProxyRequests Off
    </VirtualHost>
    /var/log/apache2/error.log :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    ...AH01113: HTTP: declining URL ajp://localhost:8009/
    Je suis sûr que quelqu'un d'expérience sur le sujet va voir tout de suite la bourde que j'ai faite, mais moi je reste complètement aveugle et ignorant...

    Merci d'avance (ou pas).

  3. #3
    Rédacteur
    Avatar de lunatix
    Homme Profil pro
    Architecte technique
    Inscrit en
    novembre 2002
    Messages
    1 960
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Architecte technique

    Informations forums :
    Inscription : novembre 2002
    Messages : 1 960
    Points : 3 645
    Points
    3 645
    Par défaut
    a mon avis, dans le cas simple que tu essayes de monter : tu peux simplement te contenter du mod_proxy_http.
    je pense que si tu changes ta conf comme ca

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    <VirtualHost *:8009>
            ServerName blablabla:)
            ProxyPass / http://localhost:8009/
            ProxyPassReverse / http://localhost:8009/
    </VirtualHost>
    ca doit fonctionner tout seul

  4. #4
    Nouveau membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    mai 2008
    Messages
    30
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France, Essonne (Île de France)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : mai 2008
    Messages : 30
    Points : 31
    Points
    31
    Par défaut
    Bonjour Lunatix et merci pour ta réponse.

    J'ai transformé mes ajp en http comme tu me l'as conseillé (j'étais déjà passé par cette phase mais j'ai quand même essayé de nouveau , ON NE SAIT JAMAIS ), mais je pense que le ProxyPass renvoie vers le port 8009, et que le virtual host qui écoute le 8009 renvoie vers le proxy pass. J'arrive donc, dans les logs, à une petite boucle sans fin, qui possède en fait une fin :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting
    Mon but avec ce virtual host qui écoute le port 8009, c'est de rediriger certaines requêtes vers mon serveur d'application Tomcat, je possède 1 autre virtual host qui s'occupe, lui, des pages webs et celui-ci fonctionne bien.

    Mais Tomcat me fait des misères ; "y veut pô" !

  5. #5
    Membre habitué
    Profil pro
    Opération
    Inscrit en
    décembre 2012
    Messages
    91
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations professionnelles :
    Activité : Opération

    Informations forums :
    Inscription : décembre 2012
    Messages : 91
    Points : 187
    Points
    187
    Par défaut
    Il me semble qu'il il a confusion en les config Tomcat et Apache.
    Je suppose que ce que vous souhaitez est :
    Browser http(s) -> Apache Port 80 (ou 443 pour https) -> Tomcat Port 8009 pour AJP (ou 8080 pour http)
    Il faut donc vérifier que les connecteurs HTTP et/ou AJP Tomcat sont correctement configuré (Voir tomcat/conf/server.xml)
    Et dans la conf d'apache :
    configurer mod_jk :
    JkWorkersFile conf/workers.properties
    JkMount /<appContext>/* ajp
    Avec dans workers.properties :
    worker.list=ajp
    worker.ajp.port=8009
    worker.ajp.host=localhost

    Ou
    configurer mod_proxy*
    ProxyPass "/<appContext>" "ajp://localhost:8009/<appContext>"
    ou
    ProxyPass "/<appContext>" "http://localhost:8080/<appContext>"

Discussions similaires

  1. Coupling Apache-tomcat vhost mod_jk appli Flex
    Par zanteskuken dans le forum Tomcat et TomEE
    Réponses: 1
    Dernier message: 25/05/2012, 14h31
  2. mod_jk apache2 tomcat issue
    Par moutey dans le forum Apache
    Réponses: 3
    Dernier message: 13/10/2011, 15h44
  3. Réponses: 3
    Dernier message: 31/12/2010, 17h07
  4. Apache/Tomcat .htaccess mod_jk
    Par totoche dans le forum Tomcat et TomEE
    Réponses: 2
    Dernier message: 29/10/2010, 07h58
  5. Réponses: 2
    Dernier message: 31/08/2009, 16h20

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo