1. #1
    Membre averti
    Avatar de stc074
    Homme Profil pro
    Codeur du dimanche
    Inscrit en
    janvier 2009
    Messages
    935
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : France, Lozère (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Codeur du dimanche

    Informations forums :
    Inscription : janvier 2009
    Messages : 935
    Points : 385
    Points
    385
    Billets dans le blog
    1

    Par défaut Eclipse ne se lance pas sauf en root

    Bonjour, je suis sur ubuntu et j'ai installé eclipse neon l'installeur ne se lançait qu'en root normal mais je ne peux lancer eclipse qu'en root j'aimerais savoir sur quels dossiers je dois changer les permissions (en plus de /usr/local/eclipse ça c déjà fait) pour qu'il se lance via l'utilisateur 'normal'.
    Merci.

  2. #2
    Membre chevronné
    Avatar de Mickael_Istria
    Homme Profil pro
    Développeur Expert Eclipse RCP
    Inscrit en
    juillet 2008
    Messages
    1 050
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Expert Eclipse RCP
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2008
    Messages : 1 050
    Points : 2 175
    Points
    2 175

    Par défaut

    L'installeur devrait marcher en mode user aussi, pas la peine d'etre root.
    Si tu n'y arrives pas avec l'installeur, tu peux aussi telecharger directement les .tar.gz des "packages" (lien sur eclipse.org/downloads , just en dessous du lien pour l'installeur).
    Tu fais du JEE/Web/Mobile dans Eclipse? Essaye JBoss Tools !
    Read my blog about Eclipse | Follow me on twitter

  3. #3
    Membre averti
    Avatar de stc074
    Homme Profil pro
    Codeur du dimanche
    Inscrit en
    janvier 2009
    Messages
    935
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 42
    Localisation : France, Lozère (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Codeur du dimanche

    Informations forums :
    Inscription : janvier 2009
    Messages : 935
    Points : 385
    Points
    385
    Billets dans le blog
    1

    Par défaut

    Citation Envoyé par Mickael_Istria Voir le message
    L'installeur devrait marcher en mode user aussi, pas la peine d'etre root.
    Si tu n'y arrives pas avec l'installeur, tu peux aussi telecharger directement les .tar.gz des "packages" (lien sur eclipse.org/downloads , just en dessous du lien pour l'installeur).
    j'ai pensé aussi a relancer l'installeur en mode user mais sans succès.
    Si je lance eclipse en console en mode user j'ai ça :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    /usr/local/eclipse/java-neon/eclipse$ ./eclipse
    /root/.p2/pool/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.400.v20160518-1444: Ne peut ouvrir le fichier d'objet partagé: Permission non accordée
    Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
    bref c bien un probleme de permission je veux pas toucher au perms existantes sur ce dossier je vais essayer l'archive
    Merci.

  4. #4
    Membre chevronné
    Avatar de Mickael_Istria
    Homme Profil pro
    Développeur Expert Eclipse RCP
    Inscrit en
    juillet 2008
    Messages
    1 050
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur Expert Eclipse RCP
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juillet 2008
    Messages : 1 050
    Points : 2 175
    Points
    2 175

    Par défaut

    j'ai pensé aussi a relancer l'installeur en mode user mais sans succès.
    C'est le probleme que tu dois chercher a resoudre. Le probleme suivant avec root et les permissions est une consequence de celui-ci.
    Tu fais du JEE/Web/Mobile dans Eclipse? Essaye JBoss Tools !
    Read my blog about Eclipse | Follow me on twitter

Discussions similaires

  1. Réponses: 4
    Dernier message: 02/04/2015, 14h12
  2. [Ubuntu] Eclipse ne se lance pas depuis le lanceur
    Par abysr dans le forum Eclipse
    Réponses: 5
    Dernier message: 12/02/2015, 14h03
  3. Eclipse ne se lance pas
    Par feuilledotone dans le forum Eclipse
    Réponses: 1
    Dernier message: 25/09/2014, 20h05
  4. Eclipse ne se lance pas
    Par Mozard Yao dans le forum Eclipse Platform
    Réponses: 1
    Dernier message: 03/04/2014, 15h19
  5. Eclipse ne se lance pas
    Par Guillaume82 dans le forum Ordinateurs
    Réponses: 5
    Dernier message: 10/03/2009, 15h25

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo