IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Apache Discussion :

Accès au localHost avec un autre appareil sur le même réseau (WampServer permission)


Sujet :

Apache

  1. #1
    Membre régulier
    Homme Profil pro
    Développeur .NET
    Inscrit en
    octobre 2015
    Messages
    55
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 32
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : octobre 2015
    Messages : 55
    Points : 82
    Points
    82
    Par défaut Accès au localHost avec un autre appareil sur le même réseau (WampServer permission)
    Bonjour, j'utilise wampserver.

    J’aimerai pouvoir accéder à mon site Web "binder" sur localhost:8080 a partir d'un ordinateur sur le même réseau. Quand je saisi mon ip:8080 J'ai une erreur de permission : apache you don't have permission to access / on this server
    après quelque recherche j'ai modifié mon httpd.conf de la sorte :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
     
    <Directory />
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Order deny,allow
        Allow from all
    </Directory>
    J’ai aussi essayé avec cependant j'ai toujours le même message.
    Je suis à la recherche de solution.

    Tout aide est à la bienvenue

    Merci

  2. #2
    Membre régulier
    Homme Profil pro
    Développeur .NET
    Inscrit en
    octobre 2015
    Messages
    55
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 32
    Localisation : France, Nord (Nord Pas de Calais)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : octobre 2015
    Messages : 55
    Points : 82
    Points
    82
    Par défaut
    Bonjour,
    j'ai trouvé le probleme.
    Enfait en plus de modifier les droits dans le httpd.conf il faut les adapter aussi dans
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    \wamp\bin\apache\apache{version}\conf\extra\httpd-vhosts.conf
    .

    il faut modifier :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    #
    # Virtual Hosts
    #
     
    <VirtualHost *:80>
        ServerName localhost
        DocumentRoot c:/wamp/www
        <Directory  "c:/wamp/www/">
            Options +Indexes +FollowSymLinks +MultiViews
            AllowOverride All
            Require local
        </Directory>
    </VirtualHost>
    changer Require local en Require all granted. Dans mon cas c'est juste un test donc je ne specifie pas de Ip. Pour plus de securité il faut specifier.

    Merci

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 2
    Dernier message: 05/12/2015, 21h53
  2. Réponses: 3
    Dernier message: 30/12/2013, 16h31
  3. Réponses: 6
    Dernier message: 11/05/2012, 16h00
  4. [Plugin Firefox] Parlez avec ceux qui sont sur le même site que vous en direct
    Par ®om dans le forum La taverne du Club : Humour et divers
    Réponses: 25
    Dernier message: 15/08/2006, 12h02
  5. dl avec dt et dd sur la meme ligne...
    Par TabrisLeFol dans le forum Balisage (X)HTML et validation W3C
    Réponses: 6
    Dernier message: 08/04/2006, 00h27

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo