1. #1
    Membre régulier
    Profil pro
    Développeur informatique
    Inscrit en
    décembre 2006
    Messages
    294
    Détails du profil
    Informations personnelles :
    Âge : 31
    Localisation : Suisse

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : décembre 2006
    Messages : 294
    Points : 71
    Points
    71

    Par défaut DatePart - Résultats différents entre developpement et production

    Bonjour à tous,

    J'ai une énigme que je n'arrive pas à résoudre.

    J'utilise la fonction DatePart pour calcul le n° de la semaine.
    Cela fonctionne parfaitement sur mon serveur de développement, mais une fois sur le serveur de production il n'y a pas le même résultat.

    Pour exemple j'utilise ce code
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    For i = 0 To 20
    	Response.Write "Date : " & DateAdd("d", i, Cdate("25.12.2015")) & " - "
    	Response.Write "N° sem. : " & DatePart("ww", DateAdd("d", i, Cdate("25.12.2015")), vbMonday, vbFirstFourDays) & "<br />"
    Next
    C'est le même code sur le 2 serveurs et voici les résultats:
    Nom : Sans titre 4.jpg
Affichages : 33
Taille : 142,8 Ko

    Sur le serveur de production il me mets le 1, 2 et 3 janvier en semaine 1 alors que ça devrait être semaine 53, comme sur le serveur de dev.

    Les paramètres Windows "Régions" sont identiques sur les 2 machines.

    Des idées ?

    Merci d'avance

  2. #2
    Modérateur

    Avatar de NoSmoking
    Homme Profil pro
    Inscrit en
    janvier 2011
    Messages
    11 450
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Isère (Rhône Alpes)

    Informations forums :
    Inscription : janvier 2011
    Messages : 11 450
    Points : 24 224
    Points
    24 224

    Par défaut

    Bonjour,
    trouvées, sur ce site, deux réponses qui devraient te convenir
    et il y en a d'autres...

Discussions similaires

  1. Réponses: 7
    Dernier message: 21/09/2012, 21h32
  2. [XL-2007] Résultat différent entre filtrage et NB.SI()
    Par marc56 dans le forum Excel
    Réponses: 2
    Dernier message: 19/04/2011, 05h21
  3. [CR XI] résultat différent entre aperçu et viewer
    Par kikidrome dans le forum SAP Crystal Reports
    Réponses: 5
    Dernier message: 20/06/2008, 14h11
  4. Réponses: 1
    Dernier message: 20/07/2006, 15h21
  5. Résultats différent entre une requête SQL, et la même en VBA
    Par thetaps dans le forum Requêtes et SQL.
    Réponses: 3
    Dernier message: 23/09/2005, 12h05

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo