1. #1
    Nouveau Candidat au Club
    Homme Profil pro
    Développeur Web
    Inscrit en
    septembre 2016
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 19
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : septembre 2016
    Messages : 1
    Points : 1
    Points
    1

    Par défaut Zend Framework 2, premier projet

    Bonjour à tous,

    Je débute avec zend framework 2 et je n'arrive pas à lancer mon projet. Ci-dessous les erreurs produites par mon navigateur:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Fatal error: Uncaught exception 'Zend\ServiceManager\Exception\ServiceNotCreatedException' with message 'While attempting to create modulemanager(alias: ModuleManager) an invalid factory was registered for this instance type.' in C:\wamp64\www\CaptainVet\vendor\zendframework\zend-servicemanager\src\ServiceManager.php on line 1101
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Zend\ServiceManager\Exception\ServiceNotCreatedException: While attempting to create modulemanager(alias: ModuleManager) an invalid factory was registered for this instance type. in C:\wamp64\www\CaptainVet\vendor\zendframework\zend-servicemanager\src\ServiceManager.php on line 1101
    Quelqu'un pourrait-il m'expliquer d'où vient cette erreur et comment la corriger ?

    Merci d'avance

  2. #2
    Membre éprouvé Avatar de Théocrite
    Homme Profil pro
    Architecte technique
    Inscrit en
    février 2009
    Messages
    520
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Côte d'Or (Bourgogne)

    Informations professionnelles :
    Activité : Architecte technique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : février 2009
    Messages : 520
    Points : 991
    Points
    991

    Par défaut

    Bonjour,

    Le problème vient probablement de tes fichiers de configuration. Cherche la clé 'factories' et regarde si toutes les entrées sont des callables correct.

    Tu peux aussi nous montrer un max de ta config.

Discussions similaires

  1. Création d'un projet Zend Framework avec NetBeans 6.5
    Par MaitrePylos dans le forum NetBeans
    Réponses: 8
    Dernier message: 10/06/2011, 10h48
  2. Créer un projet Zend Framework 1.7
    Par Damien R dans le forum Zend Studio
    Réponses: 3
    Dernier message: 07/02/2009, 12h05
  3. Réponses: 1
    Dernier message: 10/02/2008, 14h56

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo