IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Interfaces Graphiques Perl Discussion :

[GTK] Problème affichage images script Perl


Sujet :

Interfaces Graphiques Perl

  1. #1
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 684
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 684
    Points : 34 020
    Points
    34 020
    Par défaut [GTK] Problème affichage images script Perl
    Bonjour,

    Je souhaites utiliser un script Perl sous Linux utilisant Gtk (il y a aussi un script Glade).

    Le script fonctionne sauf que les icônes liés aux boutons ne s'affichent pas.

    Je pense qu'il me manque des dépendances.

    Quelles sont à votre avis les dépendances nécessaires pour afficher ces images (image en .png) ?

    libgtk2-perl, libcairo-perl, libglib-perl présents.

    bibliothèques appelés par use :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
     
    use strict;
    use utf8;
    use Encode;
    use warnings;
    use Glib qw{ TRUE FALSE };
    use Gtk2 '-init';
    use XML::Simple;
    use Gtk2::SimpleList;
    use IO::Handle;
    use Data::Dumper;
    Merci d'avance.

    Je peux fournir le script si besoin mais pas sûr que ce soit nécessaire.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  2. #2
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 793
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 793
    Points : 499 017
    Points
    499 017
    Par défaut
    Bonjour,

    Je n'y connais rien en GTK, mais as-tu libpng, libjpeg... as-tu des messages d'erreur ou d'avertissement ?

  3. #3
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 684
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 684
    Points : 34 020
    Points
    34 020
    Par défaut
    Aucune erreur, je vais tester l'install de libpng/libjpeg.

    Pas d'erreurs, le script fonctionne très bien en dehors des images boutons non affichés. Il y a une image de fond dans la fenêtre qui elle s'affiche.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  4. #4
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 793
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 793
    Points : 499 017
    Points
    499 017
    Par défaut
    Dans le programme, tu as vérifié les chemins vers les images ?

  5. #5
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 684
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 684
    Points : 34 020
    Points
    34 020
    Par défaut
    Les chemins sont bons, tout est dans un seul dossier et l'image de titre s'affiche. Tout est en png, ce qui enlève l'hypothèse d'un manque de libpng.

    Je crois que je vais devoir tracer le code, pas simple sans faire de perl ...

    Je vais faire une pause, j'aurais peut-être plus d'inspiration plus tard.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  6. #6
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 793
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 793
    Points : 499 017
    Points
    499 017
    Par défaut
    Montre nous le code.

  7. #7
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 684
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 684
    Points : 34 020
    Points
    34 020
    Par défaut
    Voici le code.

    Je pense qu'il me manque une dépendance mais je touve pas.

    Merci pour votre aide.
    Fichiers attachés Fichiers attachés
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  8. #8
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 793
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 793
    Points : 499 017
    Points
    499 017
    Par défaut
    Dans le programme, je ne vois aucun appel aux images des boutons. Donc je ne vois pas comment il pourrait afficher les icones.
    Ensuite dans le fichier XML, je vois bien les noms des images (class="GtkImage"), il y en a trois. Par contre, vu comment c'est écrit, ils doivent être au même niveau que le XML.
    Bref, je vois rien de plus pour t'aider.

  9. #9
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 684
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 684
    Points : 34 020
    Points
    34 020
    Par défaut
    Merci quand-même d'avoir regardé.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  10. #10
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 793
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 793
    Points : 499 017
    Points
    499 017
    Par défaut
    As-tu gtk-pixbuf ?

  11. #11
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 684
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 684
    Points : 34 020
    Points
    34 020
    Par défaut
    oui,

    gdk-pixbuf est installé, et au moins une image s'affiche
    Je joints l'image normale et mon bug

    J'ai essayé en installant les paquets présents dans la distri originelle dans ma distri de test, sans résultat.
    Images attachées Images attachées   
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

  12. #12
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 793
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 793
    Points : 499 017
    Points
    499 017
    Par défaut
    Alors je sèche !

    Bon, d'un autre coté, est-ce grave si l’icône ne s'affiche pas ?

  13. #13
    Responsable Systèmes


    Homme Profil pro
    Technicien maintenance
    Inscrit en
    août 2011
    Messages
    14 684
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : High Tech - Matériel informatique

    Informations forums :
    Inscription : août 2011
    Messages : 14 684
    Points : 34 020
    Points
    34 020
    Par défaut
    Pour moi non, mais c'était pour créer un .deb avec le produit.
    Ma page sur developpez.com : http://chrtophe.developpez.com/ (avec mes articles)
    Mon article sur le P2V, mon article sur le cloud
    Consultez nos FAQ : Windows, Linux, Virtualisation

Discussions similaires

  1. Problème affichage Images
    Par jason69 dans le forum Mise en page CSS
    Réponses: 2
    Dernier message: 06/03/2007, 20h19
  2. [MySQL] problème affichage image avec sql
    Par igaurillac dans le forum PHP & Base de données
    Réponses: 2
    Dernier message: 14/02/2007, 18h04
  3. [VB]Problème affichage image dans IE6
    Par flogreg dans le forum VB 6 et antérieur
    Réponses: 1
    Dernier message: 20/02/2006, 18h41
  4. Problème affichage image dans IE6
    Par flogreg dans le forum IE
    Réponses: 6
    Dernier message: 13/02/2006, 14h29
  5. problème affichage image
    Par thealpacino dans le forum Balisage (X)HTML et validation W3C
    Réponses: 8
    Dernier message: 30/05/2005, 13h56

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo