IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Firebird Discussion :

Firebird 3.0 est maintenant disponible


Sujet :

Firebird

  1. #1
    Expert confirmé
    Avatar de Ph. B.
    Homme Profil pro
    Freelance
    Inscrit en
    avril 2002
    Messages
    1 784
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 56
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Freelance
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : avril 2002
    Messages : 1 784
    Points : 5 912
    Points
    5 912
    Par défaut Firebird 3.0 est maintenant disponible
    Firebird 3.0 est maintenant disponible
    et propose des améliorations majeures en terme de performance, de sécurité et de fonctionnalités SQL.


    Félicitations au projet Firebird qui a annoncé ce mardi 19 avril la disponibilité de la version 3.0 de Firebird, son système de gestion de base de données relationnel open source.
    Il s'agit de la sixième version majeure depuis la création du projet, il y a 14 ans.

    Les principaux objectifs pour Firebird 3.0 étaient d'unifier l'architecture serveur et d'améliorer la prise en compte du parallélisme (SMP) et des plates-formes matérielles multicœurs mais aussi et parallèlement d'améliorer le fonctionnement des processus du moteur et les options de partage entre processus et connexions des pages mises en cache.

    A côté de ces objectifs ont été mises en œuvre de nouvelles stratégies pour
    • l'amélioration des performances,
    • l'optimisation des requêtes,
    • le suivi et la montée en charge,
    • l'ajout de nouvelles options de sécurité (bases de données chiffrées, contrôle d'accès utilisateur par base).


    Le langage SQL présente de nouvelles fonctionnalités dont
    • le type de données BOOLEAN et les prédicats logiques associées,
    • le type de données IDENTITY (générateur interne de séquence),
    • les fonctions statistiques et fenêtrées,
    • les paquets (PACKAGE) SQL regroupant plusieurs procédures et/ou fonctions en une seule entité de gestion,
    • les curseurs bidirectionnels.

    Cette dernière version conserve toujours une empreinte de fonctionnement minime et maintient la compatibilité avec les précédentes bibliothèques clientes.

    Vous pouvez lire le communiqué de presse et les notes de versions.
    Vous pouvez également télécharger Firebird pour Windows et Linux (32 ou 64 bits).
    Les versions pour MacOS X et les autres plateformes seront bientôt disponibles.

    A l'heure où un nouveau sondage relatif aux moteurs de bases de données est en cours, qu'en pensez vous ?
    Philippe.

  2. #2
    Expert éminent

    Homme Profil pro
    Retraité
    Inscrit en
    septembre 2002
    Messages
    2 149
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 71
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : septembre 2002
    Messages : 2 149
    Points : 6 472
    Points
    6 472
    Billets dans le blog
    2
    Par défaut
    En cours de téléchargement, je l'attendais avec impatience
    Pierre GIRARD

  3. #3
    Membre actif

    Inscrit en
    mai 2010
    Messages
    385
    Détails du profil
    Informations forums :
    Inscription : mai 2010
    Messages : 385
    Points : 289
    Points
    289
    Par défaut
    Bon Courage a tous .

  4. #4
    Expert éminent sénior Avatar de Artemus24
    Homme Profil pro
    Agent secret au service du président Ulysses S. Grant !
    Inscrit en
    février 2011
    Messages
    5 526
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Agent secret au service du président Ulysses S. Grant !
    Secteur : Finance

    Informations forums :
    Inscription : février 2011
    Messages : 5 526
    Points : 16 521
    Points
    16 521
    Par défaut
    Salut à tous.

    Merci Ph. B. !

    Je vais de ce pas installer la nouvelle version 3.0.0.

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  5. #5
    Nouveau membre du Club
    Profil pro
    Retraité
    Inscrit en
    avril 2004
    Messages
    38
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : avril 2004
    Messages : 38
    Points : 34
    Points
    34
    Par défaut
    Bonjour,

    Je vais me lancer sur ce type de base.

    Avec Delphi7, faut-il la version 32 ou 64Bits de Firebird 3 ?

  6. #6
    Expert éminent sénior Avatar de Artemus24
    Homme Profil pro
    Agent secret au service du président Ulysses S. Grant !
    Inscrit en
    février 2011
    Messages
    5 526
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Agent secret au service du président Ulysses S. Grant !
    Secteur : Finance

    Informations forums :
    Inscription : février 2011
    Messages : 5 526
    Points : 16 521
    Points
    16 521
    Par défaut
    Salut JCD59.

    En premier, il faut regarder la version 32 ou 64 bits de ton système d'exploitation.
    Si c'est 32 bits alors vous devez mettre la version 32 bits de firebird 3.0.
    En fait, vous n'avez pas le choix avec le 32 bits.

    Si c'est du 64 bits alors il faut regarder pour Delphi 7, la version qui a été installé.
    Si Delphi 7 est en 32 bits et bien mettre FireBird 3.0 en 32 bits.
    Si Delphi 7 est en 64 bits et bien mettre FireBird 3.0 en 64 bits.

    Sinon, je ne sais pas trop s'il existe un lien entre Delphi 7 et FireBird.
    Sous WampServer, je peux mettre mysql en 64 bits et apache+php en 32 bits sans rencontrer de problèmes (et vice versa).
    Mais normalement, je préfère mettre tout en 32 bits ou tout en 64 bits, sans faire de panachage de version entre mes quatre composants.

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  7. #7
    Expert éminent

    Homme Profil pro
    Retraité
    Inscrit en
    septembre 2002
    Messages
    2 149
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 71
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : septembre 2002
    Messages : 2 149
    Points : 6 472
    Points
    6 472
    Billets dans le blog
    2
    Par défaut
    Je ne suis pas certain qu'il y ait un problème ? Firebird est un serveur de base de donnée, et il se situe soit sur la même machine, soit sur un serveur distant. Dans tous les cas, Delphi fait des requêtes SQL à une base de donnée. Ça peut être Firebird, Oracle, MySQL, etc... le fait que le serveur de base de donnée soit en 32 ou en 64 bits ne doit pas changer grand chose, les requêtes sont exactement les mêmes.

    Par contre, ça peut probablement avoir une influence sur la performance, il serait logique que Firebird en 64 bits soit plus performant
    Pierre GIRARD

  8. #8
    Expert éminent

    Homme Profil pro
    Retraité
    Inscrit en
    septembre 2002
    Messages
    2 149
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 71
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : septembre 2002
    Messages : 2 149
    Points : 6 472
    Points
    6 472
    Billets dans le blog
    2
    Par défaut
    D'ailleurs, en y réfléchissant, j'ai déjà fait le test :
    - Delphi 32 bits (ou applications créées avec Delphi) sur une MV VMware Windows XP 32 bits
    - Firebird en 64 bits sur Linux et je n'ai eu aucun problème d'accès aux bases de données créées

    Bon, maintenant, je suis passé de Delphi à Lazarus et tout se retrouve sur Linux (et donc en 64 bits)
    Pierre GIRARD

  9. #9
    Nouveau membre du Club
    Profil pro
    Retraité
    Inscrit en
    avril 2004
    Messages
    38
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : avril 2004
    Messages : 38
    Points : 34
    Points
    34
    Par défaut
    Bonsoir,

    Merci à tous les deux.

    Comme je suis en Win10 Pro Créator 64 bits, Delphi 7 ( fonctionne mais avec des réserves)et surtout le module de base de données ( ne s'ouvre plus de tout) qui causent soucis.

    Je vais tenter Firebird en 64 bits, voir à récupérer mes petites bases Paradox et mes applis "perso" développées en Delphi.

    Cela me permettra de maintenir mes méninges, plutôt de vérifier mes capacités vu mon age.

    Cordialement

  10. #10
    Rédacteur/Modérateur

    Avatar de SergioMaster
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    13 883
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 66
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 13 883
    Points : 37 493
    Points
    37 493
    Billets dans le blog
    58
    Par défaut
    Bonjour,

    Je rejoint Pierre, si vous avez un OS 64 bits, quelque soit la version de Delphi (RAD qui de toute façon est 32 bits), vous installerez de préférence la version 64 bits de Firebird.
    J'indique bien de préférence, vous pouvez très bien mettre une version 32 bits voire même faire cohabiter les deux versions (c'est possible pour peu d'utiliser 2 ports différents)

    Toutefois, quelques bémols :
    - Attention aux UDF(s) pour peu que vous en ayez développé ou que vous utilisiez des UDF tiers (je pense par exemple aux FreeAdHoc) choisissez de les mettre dans les répertoires UDF de votre/vos intallation(s) en fait bien attention à la version OS des DLL

    - Pour une installation embedded (terme qui n'existe plus vraiment avec FB3 puisqu'il s'agit d'une installation super serveur dans le répertoire particulier de l'application) quelque soit la version bits de l'OS, c'est la version bits du programme qui devra être utilisée. Donc dans le cas de D7 le problème ne se pose pas, puisque le compilateur ne produit que du 32 bits, la version Embedded sera la version 32 bits

    Win10 Pro Créator 64 bits,
    Déjà, je n'ai pas voulu installer la pré-version et j'attends le chargement et l'application de la mise à jour avec angoisse ! Quand je pense qu'il refaudra encore faire les manips pour pouvoir lire les fichiers d'aide de D7 ça me gave

    Citation Envoyé par Pierre Girard
    Par contre, ça peut probablement avoir une influence sur la performance, il serait logique que Firebird en 64 bits soit plus performant
    je ne vois pas en quoi cela changerait les performances sur une base locale.
    la seule chose qui me vient à l'esprit et qui est importante c'est que sur un système 64 bits les DLLs et programmes 32 bits passent par un "émulateur" 64 bits (d'où le nom utilisé par MS : SYSWOW64 qui contient des éléments 32 bits) donc : tout ce qui ôte des couches d'interprétation est bon à utiliser.


    Pour ce qui est de l'actualité, nous en sommes maintenant à la version 3.0.2, version qui semble t-il à un "léger problème" d'utilisation mémoire (discussion à partir du post #13)
    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) ,D11 (Alexandria)
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

  11. #11
    Expert éminent sénior Avatar de Artemus24
    Homme Profil pro
    Agent secret au service du président Ulysses S. Grant !
    Inscrit en
    février 2011
    Messages
    5 526
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Agent secret au service du président Ulysses S. Grant !
    Secteur : Finance

    Informations forums :
    Inscription : février 2011
    Messages : 5 526
    Points : 16 521
    Points
    16 521
    Par défaut
    Salut SergioMaster.

    Citation Envoyé par Sergiomaster
    Je rejoins Pierre, si vous avez un OS 64 bits, quelque soit la version de Delphi (RAD qui de toute façon est 32 bits), vous installerez de préférence la version 64 bits de Firebird.
    Je n'ai donné aucun conseil sur le choix final d'installer soit le 32 bits ou le 64 bits.
    Mais quand je peux installer la version 64 bits de n'importe quel utilitaire, c'est ce que je fais, sauf si je recontre des problèmes dans son utilisation.

    Citation Envoyé par Sergiomaster
    - Attention aux UDF(s) pour peu que vous en ayez développé ou que vous utilisiez des UDF tiers (je pense par exemple aux FreeAdHoc) choisissez de les mettre dans les répertoires UDF de votre/vos intallation(s) en fait bien attention à la version OS des DLL
    Il serait bon de nous donner un exemple de ce fonctionnement erratique afin de comprendre si c'est la version 64 bits qui pose problème où si cela vient d'autre chose.
    A moins que depuis FireBird 3.0, ce problème a été résolu !

    Citation Envoyé par Sergiomaster
    Déjà, je n'ai pas voulu installer la pré-version et j'attends le chargement et l'application de la mise à jour avec angoisse ! Quand je pense qu'il refaudra encore faire les manips pour pouvoir lire les fichiers d'aide de D7 ça me gave
    Je n'ai eu que des problèmes avec la version 1607 de Windows 10. J'ai pu enfin me stabiliser en mars 2017.
    Mais le pire, c'est que Windows nous force à passer dans la version supérieure. C'est ce qui m'est arrivé début mars alors que j'avais bloqué la version 1607.
    Je ne suis pas près de passer à la version suivante que est la version 1703 (la quatrième mise à jour de windows 10).

    Citation Envoyé par Sergiomaster
    Pour ce qui est de l'actualité, nous en sommes maintenant à la version 3.0.2, version qui semble t-il à un "léger problème" d'utilisation mémoire (discussion à partir du post #13)
    Comment se fait-il qu'il n'y a pas eu d'alerte sur Developpez pour indiquer la nouvelle release de FireBird 3.0 ?
    Je vais de ce pas installer la version 3.0.2 qui date de mars 2017.

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  12. #12
    Expert éminent

    Homme Profil pro
    Retraité
    Inscrit en
    septembre 2002
    Messages
    2 149
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 71
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : septembre 2002
    Messages : 2 149
    Points : 6 472
    Points
    6 472
    Billets dans le blog
    2
    Par défaut
    Personnellement, j'ai installé la dernière version de Firebird, mais je n'ai pas encore eu le temps de la tester ... c'est ça, les retraités, on a tellement de choses à faire ...?
    Pierre GIRARD

  13. #13
    Expert éminent sénior Avatar de Artemus24
    Homme Profil pro
    Agent secret au service du président Ulysses S. Grant !
    Inscrit en
    février 2011
    Messages
    5 526
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Agent secret au service du président Ulysses S. Grant !
    Secteur : Finance

    Informations forums :
    Inscription : février 2011
    Messages : 5 526
    Points : 16 521
    Points
    16 521
    Par défaut
    Salut Pierre Girard.

    A toi aussi tu es à la retraite. Moi aussi. Bienvenue dans le club !

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  14. #14
    Expert éminent

    Homme Profil pro
    Retraité
    Inscrit en
    septembre 2002
    Messages
    2 149
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 71
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : septembre 2002
    Messages : 2 149
    Points : 6 472
    Points
    6 472
    Billets dans le blog
    2
    Par défaut
    Citation Envoyé par Artemus24 Voir le message
    Salut Pierre Girard.

    A toi aussi tu es à la retraite. Moi aussi. Bienvenue dans le club !

    @+
    Oui, j'ai même eu un choc pas plus tard qu'aujourd'hui ... en remplissant ma déclaration d'impôts. Maintenant, je suis même classé parmi les vieux avec une ligne supplémentaire : "Abattement personnes âgées". Remarque, dans la mesure où ça fait baisser les impôts, je ne vais pas trop me plaindre
    Pierre GIRARD

  15. #15
    Nouveau membre du Club
    Profil pro
    Retraité
    Inscrit en
    avril 2004
    Messages
    38
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : avril 2004
    Messages : 38
    Points : 34
    Points
    34
    Par défaut
    Bonjour,

    ET oui, les retraités n'ont plus de temps cela fait plus de 12 ans que je le vis.

    Néanmoins j'ai quand même trouvé le temps de télécharger et de tester brièvement Firebird3 et Lazarus 1.6.4 64 bits suite à vos conseils.

    Bien sur ce n'est qu'un survol et mes premiers contacts avec Firebird n'ont pas été simple, est-ce de mauvais choix lors de l'install ou Win10 créator c'est toujours un soucis de droit. ( Bref ça tourne, mais je n'ai pas cerné le soucis, et ça m'énerve !)

    Lazarus par contre aucun soucis, peut faudra-t-il compléter la bibliothèque, mais premier contact encourageant.

    Une question, existerait-il l'équivalent du Module de Bases de données pour firebird ? Car pour la création des champs d'une base c'était pratique, sinon il faudra que je ressorte mes notes sur le SQL

    Cordialement

  16. #16
    Membre confirmé
    Profil pro
    Inscrit en
    avril 2010
    Messages
    227
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : avril 2010
    Messages : 227
    Points : 489
    Points
    489
    Par défaut
    Bienvenue au club

    Lors de l'installation de Firebird 3.x en version serveur 64b, j'espère que vous avez bien coché les cases demandant de générer les bibliothèques client (fbclient.dll) également pour les logiciels 32b. Pour Lazarus, sauf si vous développez des applications demandant beaucoup de mémoire, il est préférable d'installer la version 32b.
    Au cas où vous voulez utiliser Firebird avec d'anciennes applications Delphi 7, il faut aussi cocher les cases demandant de générer les bibliothèques pour les "anciennes applications" (gds32.dll). Je dois cependant préciser que si je n'ai eu aucun problème pour faire fonctionner des applications D7 avec FB jusqu'à la version 2.5, j'ai rencontré pas mal de problèmes de "perte de connexion" avec la version FB3. Ces problèmes n'ont été résolus que lorsque j'ai modifié les IBX de D7 pour qu'ils utilisent fbclient.dll à la place de gds32.dll, profitant au passage pour les mettre partiellement à jour afin de profiter de certaines évolutions de FB depuis ma version des IBX datant de 2002.
    Concernant Lazarus et les composants à utiliser pour vous connecter à une base FB3, les composants natifs restent relativement basiques, également un peu à la traine des évolutions de FB. J'utilise plus souvent les UIB (avec FBDataset comme dataset complet) qui me semblent les plus à jour mais utilisent une syntaxe différente des IBX de D7. Les composants ZEOS ont l'avantage d'être plus universels concernant les SGDB accessibles. Ils semblent bien évoluer mais j'ignore s'ils sont bien à jour avec les évolutions de FB; à l'époque où je les ai testés, ils l'étaient moins que les UIB, également moins rapides et je leur reprochaient de ne pas être aussi clairs que les UIB et les IBX dans la gestion des transactions. Lazarus travaillant en interne en UTF8, il est préférable de paramétrer la connexion dans ce jeu de caractères (la translitération est alors faite par Firebird), sinon il faudrait le programmer à chaque lecture et écriture, à moins qu'il n'y ait pas d'échanges avec l'utilisateur. Ce qui n'empêche pas d'utiliser le jeu WIN1252 (correspondant au jeu de votre Windows) pour les champs de données textuelles.
    Pour la création et la gestion des bases de données, il existe quelques bons outils dans le domaine libre (difficile d'"amortir" pour un retraité qui développe pour le plaisir). Il y a FlameRobin, une version allégée de IBExpert et d'autres...
    Bien que souvent conseillé, je regrette que FlameRobin ne soit pas mis à jour pour FB3 car il utilise encore des fonctions mettant à jour directement les tables système, ce qui est maintenant interdit par FB3. Une erreur fréquemment rencontrée est due au fait que le nombre d'enregistrements retourné depuis FB3 est maintenant un INT64 au lieu d'un Integer.

    Bon courage
    André

  17. #17
    Nouveau membre du Club
    Profil pro
    Retraité
    Inscrit en
    avril 2004
    Messages
    38
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : avril 2004
    Messages : 38
    Points : 34
    Points
    34
    Par défaut
    Bonjour,

    Je vais revoir mon installation, car je viens d'avoir l'explication de mon soucis avec IBexpert Perso.

    Pour la suite, je verrais bien jusqu'où je pourrais aller, vous avez raison développer pour le plaisir à ses limites ( financières), alors....

  18. #18
    Nouveau membre du Club
    Profil pro
    Retraité
    Inscrit en
    avril 2004
    Messages
    38
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : avril 2004
    Messages : 38
    Points : 34
    Points
    34
    Par défaut
    Rebonjour Alanglet

    Je voulu voir Flamerobin, j'ai téléchargé la version 0.9.3

    Cependant il ne se lance pas, il fait référence à une dll manquante le VRUNTIME140.

    On en trouve plusieurs sur Internet, laquelle choisir, et où l'installée ?

  19. #19
    Expert éminent sénior Avatar de Artemus24
    Homme Profil pro
    Agent secret au service du président Ulysses S. Grant !
    Inscrit en
    février 2011
    Messages
    5 526
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Agent secret au service du président Ulysses S. Grant !
    Secteur : Finance

    Informations forums :
    Inscription : février 2011
    Messages : 5 526
    Points : 16 521
    Points
    16 521
    Par défaut
    Salut JCD59.

    Le module "VRUNTIME140" signifie : Visual C++ Redistributable for Visual Studio 2015.
    Et vous le trouvez chez Microsoft : https://www.microsoft.com/en-us/down....aspx?id=48145

    Si vous êtes en version 32 bits, vous devez installer la version 32 bits.
    Si vous êtes en version 64 bits, vous devez installer la version 32 bits ainsi que la version 64 bits.

    @+
    Si vous êtes de mon aide, vous pouvez cliquer sur .
    Mon site : http://www.jcz.fr

  20. #20
    Rédacteur/Modérateur

    Avatar de SergioMaster
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    13 883
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 66
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Industrie

    Informations forums :
    Inscription : janvier 2007
    Messages : 13 883
    Points : 37 493
    Points
    37 493
    Billets dans le blog
    58
    Par défaut
    Bonjour,

    pour le runtime C++ c'était écrit en toute lettres et avec lien sur le site
    New Flamerobin snapshot 0.9.3.c75f861 for Windows is available (x86).

    25 November 2016 New Flamerobin snapshot 0.9.3.c75f861 for Windows is available (x86). It needs the Visual C++ Redistributable for Visual Studio 2015 (x86). See Git log for code changes.
    A noter qu'il existe aussi une version 32 bits et une version 64 bits de Flamerobin, le mieux est de piocher dans le répertoire SnapShots
    Delphi installés : D3,D7,D2010,XE4,XE7,D10 (Tokyo, Rio, Sidney) ,D11 (Alexandria)
    SGBD : Firebird 2.5, 3, SQLite
    générateurs Etats : FastReport, Rave, QuickReport
    OS : Window Vista, Windows 10, Ubuntu, Androïd

Discussions similaires

  1. Réponses: 0
    Dernier message: 26/09/2009, 12h36
  2. La phase de beta-test du SDK ATI Stream v2.0 d'AMD est maintenant disponible
    Par raptor70 dans le forum Développement 2D, 3D et Jeux
    Réponses: 0
    Dernier message: 24/09/2009, 23h34
  3. Réponses: 0
    Dernier message: 24/09/2009, 23h34
  4. Réponses: 5
    Dernier message: 07/09/2009, 22h40
  5. Réponses: 0
    Dernier message: 07/02/2009, 15h05

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo