IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Symfony PHP Discussion :

fosuserbundle erreure 404 apres déconnection de la page profile


Sujet :

Symfony PHP

  1. #1
    Membre averti
    Profil pro
    Inscrit en
    juillet 2006
    Messages
    467
    Détails du profil
    Informations personnelles :
    Âge : 50
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : juillet 2006
    Messages : 467
    Points : 342
    Points
    342
    Par défaut fosuserbundle erreure 404 apres déconnection de la page profile
    Bonjour, j'utilise symfony2 fosuserbundle 1.3
    quand je me déconnecte de la page profile j'ai une page 404.
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    No route found for "GET /" (from "http://localhost/symfonynv/web/app_dev.php/profile/")
    Quelqu"un pourrait il m'aider ? Merci

  2. #2
    Membre confirmé
    Avatar de vinmar
    Homme Profil pro
    Développeur Web
    Inscrit en
    août 2012
    Messages
    139
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Service public

    Informations forums :
    Inscription : août 2012
    Messages : 139
    Points : 516
    Points
    516
    Par défaut
    Salut,

    As-tu activé l'url_rewriting ? Parce que quand je vois ça : "http://localhost/symfonynv/web/app_dev.php/profile/", j'ai l'impression que non.

    Sinon, il te dit qu'il ne comprend pas l'url "/", l'as-tu définie dans un fichier de routes ?
    M. Lebowski : Avez-vous un emploi, monsieur ?
    Le Duc : Un emploi ?
    M. Lebowski : Ne me dites pas que vous cherchez un emploi dans cette tenue un jour de semaine ?
    Le Duc : Un jour de… Quel jour on est ?

  3. #3
    Membre averti
    Profil pro
    Inscrit en
    juillet 2006
    Messages
    467
    Détails du profil
    Informations personnelles :
    Âge : 50
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : juillet 2006
    Messages : 467
    Points : 342
    Points
    342
    Par défaut
    Merci pour ta réponse si rapide.
    Voici les routes
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
     
     _wdt                              ANY      ANY    ANY  /_wdt/{token}                     
     _profiler_home                    ANY      ANY    ANY  /_profiler/                       
     _profiler_search                  ANY      ANY    ANY  /_profiler/search                 
     _profiler_search_bar              ANY      ANY    ANY  /_profiler/search_bar             
     _profiler_purge                   ANY      ANY    ANY  /_profiler/purge                  
     _profiler_info                    ANY      ANY    ANY  /_profiler/info/{about}           
     _profiler_phpinfo                 ANY      ANY    ANY  /_profiler/phpinfo                
     _profiler_search_results          ANY      ANY    ANY  /_profiler/{token}/search/results 
     _profiler                         ANY      ANY    ANY  /_profiler/{token}                
     _profiler_router                  ANY      ANY    ANY  /_profiler/{token}/router         
     _profiler_exception               ANY      ANY    ANY  /_profiler/{token}/exception      
     _profiler_exception_css           ANY      ANY    ANY  /_profiler/{token}/exception.css  
     _configurator_home                ANY      ANY    ANY  /_configurator/                   
     _configurator_step                ANY      ANY    ANY  /_configurator/step/{index}       
     _configurator_final               ANY      ANY    ANY  /_configurator/final              
     _twig_error_test                  ANY      ANY    ANY  /_error/{code}.{_format}          
     fos_user_security_login           ANY      ANY    ANY  /login                            
     fos_user_security_check           POST     ANY    ANY  /login_check                      
     fos_user_security_logout          ANY      ANY    ANY  /logout                           
     fos_user_profile_show             GET      ANY    ANY  /profile/                         
     fos_user_profile_edit             ANY      ANY    ANY  /profile/edit                     
     fos_user_registration_register    ANY      ANY    ANY  /register/                        
     fos_user_registration_check_email GET      ANY    ANY  /register/check-email             
     fos_user_registration_confirm     GET      ANY    ANY  /register/confirm/{token}         
     fos_user_registration_confirmed   GET      ANY    ANY  /register/confirmed               
     fos_user_resetting_request        GET      ANY    ANY  /resetting/request                
     fos_user_resetting_send_email     POST     ANY    ANY  /resetting/send-email             
     fos_user_resetting_check_email    GET      ANY    ANY  /resetting/check-email            
     fos_user_resetting_reset          GET|POST ANY    ANY  /resetting/reset/{token}          
     fos_user_change_password          GET|POST ANY    ANY  /password/change-password

  4. #4
    Membre confirmé
    Avatar de vinmar
    Homme Profil pro
    Développeur Web
    Inscrit en
    août 2012
    Messages
    139
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Service public

    Informations forums :
    Inscription : août 2012
    Messages : 139
    Points : 516
    Points
    516
    Par défaut
    C'est donc cela : No route found for "GET /" veut dire que tu n'as pas définie de route pour "/". Elle n'est pas dans la liste.
    M. Lebowski : Avez-vous un emploi, monsieur ?
    Le Duc : Un emploi ?
    M. Lebowski : Ne me dites pas que vous cherchez un emploi dans cette tenue un jour de semaine ?
    Le Duc : Un jour de… Quel jour on est ?

  5. #5
    Membre averti
    Profil pro
    Inscrit en
    juillet 2006
    Messages
    467
    Détails du profil
    Informations personnelles :
    Âge : 50
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : juillet 2006
    Messages : 467
    Points : 342
    Points
    342
    Par défaut
    j'ai rajouter
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
     
    demo:
        resource: "@AppBundle/Controller"
        type: annotation
    et ça a créer homepage /
    Cela fonctionne maintenant. Merci beaucoup.

  6. #6
    Membre confirmé
    Avatar de vinmar
    Homme Profil pro
    Développeur Web
    Inscrit en
    août 2012
    Messages
    139
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Développeur Web
    Secteur : Service public

    Informations forums :
    Inscription : août 2012
    Messages : 139
    Points : 516
    Points
    516
    Par défaut
    De rien, n'oublie pas de mettre résolu.
    M. Lebowski : Avez-vous un emploi, monsieur ?
    Le Duc : Un emploi ?
    M. Lebowski : Ne me dites pas que vous cherchez un emploi dans cette tenue un jour de semaine ?
    Le Duc : Un jour de… Quel jour on est ?

Discussions similaires

  1. [SP-2007] Erreur 404 après ajout d'un nouvel element dans une liste
    Par peyrard dans le forum SharePoint
    Réponses: 6
    Dernier message: 26/10/2011, 19h20
  2. [Erreur 404]Probleme affichage de la page d'accueil
    Par grelon dans le forum Tomcat et TomEE
    Réponses: 4
    Dernier message: 15/05/2007, 16h44
  3. [Htaccess] Rediriger vers une page en cas d'erreur 404
    Par Alexandrebox dans le forum Apache
    Réponses: 8
    Dernier message: 12/01/2007, 08h01
  4. Erreur 404 - problème pour tester la page jsp
    Par zuzuu dans le forum Tomcat et TomEE
    Réponses: 10
    Dernier message: 05/07/2006, 17h55

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo