IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Web Perl Discussion :

Afficher "Hello world"


Sujet :

Web Perl

  1. #1
    Nouveau membre du Club
    Femme Profil pro
    En recherche d’emploi
    Inscrit en
    février 2014
    Messages
    62
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France

    Informations professionnelles :
    Activité : En recherche d’emploi

    Informations forums :
    Inscription : février 2014
    Messages : 62
    Points : 36
    Points
    36
    Par défaut Afficher "Hello world"
    Bonjour,

    Voilà, lorsque j'exécute mon script pour afficher "Hello world !!!" dans la console tout se passe bien mais via une page html il m'ouvre la boîte de dialogue pour télécharger le fichier .pl au lieu de d'afficher le texte.

    Mes fichiers de configuration sont normalement bien configurés pour les scripts cgi ...

    Mon script fichier.pl :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
     
    #!/usr/bin/env perl
     
    use strict;
    use warnings;
     
    print "Content-Type: text/html\n\n";
    print "<h2>Salut le monde!!!<h2>\n";
    Mon fichier html :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
     
    <!DOCTYPE html>
    <html>
    	<head>
    		<title>Page de test</title>
    		<meta charset="utf-8" media="all"/>
    	</head>
    	<body>
    		<h1>Bienvenue à vous!!</h1>
    		<a href="/cgi-bin/fichier.pl">fichier.pl</a>
    	</body>
    </html>
    Fichier de configuration script :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
     
    # SCRIPT CGI PL ...
    	ScriptAlias /cgi-bin/ /home/moi/www/cgi-bin/
    	<Directory "/home/moi/www/cgi-bin/">
    		AllowOverride None
    		Options +ExecCGI
    		AddHandler cgi-script .cgi .pl .py
    		Require all granted
    	</Directory
    Quelqu'un aurait-il une idée?

    Merci.

  2. #2
    Expert éminent Avatar de BufferBob
    Profil pro
    responsable R&D vidage de truites
    Inscrit en
    novembre 2010
    Messages
    2 994
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : responsable R&D vidage de truites

    Informations forums :
    Inscription : novembre 2010
    Messages : 2 994
    Points : 8 290
    Points
    8 290
    Par défaut
    salut,

    à tout hasard, tu as bien mis les droits d'execution sur ton script ?

  3. #3
    Nouveau membre du Club
    Femme Profil pro
    En recherche d’emploi
    Inscrit en
    février 2014
    Messages
    62
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France

    Informations professionnelles :
    Activité : En recherche d’emploi

    Informations forums :
    Inscription : février 2014
    Messages : 62
    Points : 36
    Points
    36
    Par défaut
    Bonjour,

    Oui j'ai mis les droits d’exécution du fichier.pl

    Dans la console, lors de l'exécution il m'affiche bien le résultat i.e "Salut le monde!!" mais lorsque j'exécute dans le navigateur (localhost/cgi-bin/fichier.pl), il m'ouvre la boîte de dialogue pour enregistrer le fichier au lieu d'afficher le résultat.

  4. #4
    Expert éminent Avatar de BufferBob
    Profil pro
    responsable R&D vidage de truites
    Inscrit en
    novembre 2010
    Messages
    2 994
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : responsable R&D vidage de truites

    Informations forums :
    Inscription : novembre 2010
    Messages : 2 994
    Points : 8 290
    Points
    8 290
    Par défaut
    la configuration a l'air correcte, tu as bien relancé apache ensuite pour prendre la configuration en compte ? (on sait jamais)
    sinon je vois pas d'où ça pourrait venir, un problème de cache de ton navigateur peut-être, à vérifier...
    si tu fais un curl ou un wget tu as le même problème ?

Discussions similaires

  1. hello world
    Par floorfille dans le forum CORBA
    Réponses: 3
    Dernier message: 26/07/2007, 14h34
  2. [STRUTS] hello world, bonjour le monde
    Par Celina dans le forum Struts 1
    Réponses: 3
    Dernier message: 19/04/2004, 15h41

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo