Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Installation, migration et administration Discussion :

Pb install version 6.0.1 TOS


Sujet :

Installation, migration et administration

  1. #1
    Membre régulier
    Pb install version 6.0.1 TOS
    Bonjour,

    Voilà deux jours que j'essaye d'installer TOS version 6.0.1.
    J'ai installé le jdk-8-windowsx64 sur mon poste C:/Java/jdk-8-windows-x64.
    J'ai installé TOS après .
    Je suis allé dans TOS_DI-20150908_1633-V6.0.1/TOS_DI-win-x86_64.init (paramètres de configuration), j'ai mis :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    -vm /Java/jdk-8-windows-x64/bin/java -Xms512m
    -Xmx1536m
    -XX:MaxPermSize=512m
    -Dfile.encoding=UTF-8


    Et j'obtiens le message suivant :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    SESSION 2015-09-28 11:45:06.707 -----------------------------------------------
    eclipse.buildId=unknown
    java.version=1.6.0_45
    java.vendor=Sun Microsystems Inc.
    BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
     
    !ENTRY org.eclipse.osgi 4 0 2015-09-28 11:45:07.034
    !MESSAGE error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator
    !STACK 0
    java.lang.UnsupportedClassVersionError: org/talend/osgi/configurator/JarLoaderConfigurator : Unsupported major.minor version 51.0
    	at java.lang.ClassLoader.defineClass1(Native Method)
    	at java.lang.ClassLoader.defineClassCond(Unknown Source)
    	at java.lang.ClassLoader.defineClass(Unknown Source)
    	at java.security.SecureClassLoader.defineClass(Unknown Source)
    	at java.net.URLClassLoader.defineClass(Unknown Source)
    	at java.net.URLClassLoader.access$000(Unknown Source)


    Je ne trouve pas ce qui ne va pas : le jdk est récent et je donne son chemin.
    Où dois-je regarder car apparemment il y des choses incompatibles entre elles ?????
    Merci d'avance pour votre aide ...
    NFHnv

  2. #2
    Membre averti
    Salut,

    Essaie avec Java 7.
    De mémoire, Talend n'est pas encore compatible avec Java 8.

  3. #3

  4. #4
    Membre averti
    Hum on dirait que j'ai dit une bêtise : https://help.talend.com/display/KB/Java+8+Support

    Ton problème doit peut-être venir de la configuration de Java 8 alors...

  5. #5
    Membre régulier
    merci pour toutes ces réponse ultra rapides ...je n'arrive pas à trouver jdk-7 : Est-ce que quelqu'un a un lien pour le télécharger ?
    Avant d'essayer le jdk-8 j'ai essayé le jdk-6 mais tjrs le même pb ????
    Merci ,

    NFHnv