IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Subversion Discussion :

Soucis avec subversion sur Debian Jessie


Sujet :

Subversion

  1. #1
    Membre à l'essai
    Inscrit en
    décembre 2009
    Messages
    39
    Détails du profil
    Informations forums :
    Inscription : décembre 2009
    Messages : 39
    Points : 11
    Points
    11
    Par défaut Soucis avec subversion sur Debian Jessie
    Bonjour à tous

    Je viens d'installer une vm de Debian jessie destinée à recevoir subversion.

    N'ayant jamais installé subversion j'ai donc suivi ce tuto à la lettre:

    http://denisrosenkranz.com/mise-en-p...ive-directory/
    et
    https://www.howtoforge.com/installin...debian-squeeze

    la machine est bien dans le domaine AD, et j'utilise openpbis pour cela (ca fonctionne parfaitement)

    j'ai essayé avec le fichier svn.conf comme dans le tuto

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    <VirtualHost *:80>
     
    #Config generale du Vhost
        ServerAdmin info@xxx.lan
    
        ServerName  subversion.xxx.lan
        ServerAlias subversion
    
        # Droits d'acces au repertoire
     
        <Directory /var/svn/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
        </Directory>
    
    <Location /var/svn>
            DAV svn
            SVNParentPath /var/svn
     
            #LDAP authentication
            AuthBasicProvider ldap
            AuthType Basic
            AuthzLDAPAuthoritative on
            AuthLDAPBindDN svnuser@xxx.lan #Un utilisateur capable de se connecter à l'AD)
            AuthLDAPBindPassword xxx #Mot de passe de cet utilisateur
     
            AuthName "Connection au dépôt de versionnage"
     
            AuthLDAPURL "ldap://172.16.0.253:389/CN=Users,DC=xxx,DC=lan?sAMAccountName?sub?(objectClass=*)"
            Require valid-user
            ErrorDocument 404 default
    </Location>
    ErrorLog /var/log/apache2/svn_error.log
        CustomLog /var/log/apache2/svn_access.log combined
    </VirtualHost>
    mais j'avais une erreur au restart de apache:

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    /etc/init.d/apache2 restart[....] Restarting apache2 (via systemctl): apache2.serviceJob for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
     failed!
    j'ai donc trouvé un autre exemple de fichier que j'ai modifié pour l'adapter a mon reseau.

    voila mon fichier de conf /etc/apache2/sites-available/svn.conf

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    <VirtualHost *:80>
     
    #Config generale du Vhost
        ServerAdmin info@xxx.lan
    
        ServerName  subversion.xxx.lan
        ServerAlias subversion
    
        # Droits d'acces au repertoire
     
        <Directory /var/svn/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
        </Directory>
    
    <Location /var/svn>
        DAV svn
        AuthType basic
        SVNParentPath /var/svn
        SVNListParentPath On
        AuthName "Subversion xxx"
        AuthBasicProvider ldap
        AuthLDAPURL "ldap://172.16.0.253:389/dc=xxx,dc=lan?sAMAccountName" NONE
        AuthLDAPBindDN "CN=svnuser,OU=users,DC=xxx,DC=lan"
        AuthLDAPBindPassword "xxx"
        #Require ldap-group CN=svn,OU=groups,DC=example,DC=com
        Require ldap-group CN=users,OU=groups,DC=xxx,DC=lan
    </Location>
    
        ErrorLog /var/log/apache2/svn_error.log
        CustomLog /var/log/apache2/svn_access.log combined
    </VirtualHost>
    svnuser est un simple user créé sous AD avec son mot de passe xxx (le temps du test)

    J'ai également fait tous les tests en remplaçant le login et mdp par mon login administrateur AD et mon mot de passe.

    Je n'ai pas touché aux autres fichiers

    le restart de apache se passe cette fois ci sans problème.

    seulement au lancement de l'interface j'ai le message suivant

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    svn info http://subversion.xxx.lan
    svn: E175002: Unable to connect to a repository at URL 'http://subversion.xxx.lan'
    svn: E175002: Unexpected HTTP status 504 'Gateway Timeout' on '/'
    svn: E175002: Additional errors:
    svn: E175002: Échec de la requête OPTIONS sur '/' : 504 Gateway Timeout
    si je vais voir dans /var/log/apache2/svn_error.log, j'ai
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    [Tue Sep 01 16:03:05.335057 2015] [:warn] [pid 10151:tid 140306901096192] [client 127.0.0.1:46347] [mod_vhost_ldap.c]: lookup failure, retry number #[1], sleeping for [2] seconds
    [Tue Sep 01 16:03:07.337249 2015] [:warn] [pid 10151:tid 140306901096192] [client 127.0.0.1:46347] [mod_vhost_ldap.c]: lookup failure, retry number #[2], sleeping for [3] seconds
    [Tue Sep 01 16:03:10.340463 2015] [:warn] [pid 10151:tid 140306901096192] [client 127.0.0.1:46347] [mod_vhost_ldap.c]: lookup failure, retry number #[3], sleeping for [5] seconds
    [Tue Sep 01 16:03:15.345707 2015] [:warn] [pid 10151:tid 140306901096192] [client 127.0.0.1:46347] [mod_vhost_ldap.c]: lookup failure, retry number #[4], sleeping for [8] seconds
    [Tue Sep 01 16:03:23.353946 2015] [:warn] [pid 10151:tid 140306901096192] [client 127.0.0.1:46347] [mod_vhost_ldap.c]: lookup failure, retry number #[5], sleeping for [13] seconds
    voila le fichier mod_vhost.ldap.conf

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    ### mod_vhost_ldap depends on mod_ldap ###
    ### you have to enable mod_ldap as well ###
    
    <IfModule mod_vhost_ldap.c>
        VhostLDAPEnabled on
        VhostLDAPUrl "ldap://127.0.0.1/ou=vhosts,ou=web,dc=localhost"
        VhostLdapBindDN "cn=admin,dc=localhost"
        VhostLDAPBindPassword "changeme"
    </IfModule>
    je l'ai donc corrigé pour avoir ça

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    ### mod_vhost_ldap depends on mod_ldap ###
    ### you have to enable mod_ldap as well ###
    
    <IfModule mod_vhost_ldap.c>
        VhostLDAPEnabled on
        VhostLDAPUrl "ldap://172.16.0.253:389/ou=vhosts,ou=web,dc=xxx,dc=lan"
        VhostLdapBindDN "cn=svnuser,dc=xxx,dc=lan"
        VhostLDAPBindPassword "xxx"
    </IfModule>
    et la au lancement, aprés restart de apache bien sur, j'ai

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    svn info http://subversion.xxx.lan
    svn: E175002: Unable to connect to a repository at URL 'http://subversion.xxx.lan'
    svn: E175002: Unexpected HTTP status 500 'Internal Server Error' on '/'
    svn: E175002: Additional errors:
    svn: E175002: Échec de la requête OPTIONS sur '/' : 500 Internal Server Error
    avec le message suivant dans /var/log/apache2/svn_error.log

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    [Tue Sep 01 16:12:51.279944 2015] [:warn] [pid 10421:tid 140209324807936] [client 127.0.0.1:46375] [mod_vhost_ldap.c] translate: translate failed; virtual host subversion.xxx.lan; URI / [Invalid credentials]
    et la je patauge, je ne vois vraiment pas ou est le soucis et comment le régler

    info complementaire
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    apache2 -v
    Server version: Apache/2.4.10 (Debian)
    Server built:   Aug  1 2015 20:53:57
    
    svn --version
    svn, version 1.8.10 (r1615264)
       compiled Aug  9 2015, 13:48:39 on x86_64-pc-linux-gnu
    
    Copyright (C) 2014 The Apache Software Foundation.
    This software consists of contributions made by many people;
    see the NOTICE file for more information.
    Subversion is open source software, see http://subversion.apache.org/
    
    Les modules d'accès à un dépôt (RA) suivants sont disponibles :
    
    * ra_svn : Module d'accès à un dépôt avec le protocole réseau propre de svn.
      - avec authentification Cyrus SASL
      - gère le schéma d'URL 'svn'
    * ra_local : Module d'accès à un dépôt sur un disque local.
      - gère le schéma d'URL 'file'
    * ra_serf : Module for accessing a repository via WebDAV protocol using serf.
      - using serf 1.3.8
      - gère le schéma d'URL 'http'
      - gère le schéma d'URL 'https'
    
    uname -a
    Linux subversion 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u3 (2015-08-04) x86_64 GNU/Linux
    merci beaucoup pour votre aide

  2. #2
    Membre à l'essai
    Inscrit en
    décembre 2009
    Messages
    39
    Détails du profil
    Informations forums :
    Inscription : décembre 2009
    Messages : 39
    Points : 11
    Points
    11
    Par défaut
    up

    quelqu'un peut me donner un coup de main svp?

Discussions similaires

  1. Connexion avec Instantclient sur Debian
    Par clem_alain dans le forum Installation
    Réponses: 7
    Dernier message: 17/04/2011, 18h45
  2. Souci avec hover sur plusieurs background
    Par nasuu dans le forum Mise en page CSS
    Réponses: 2
    Dernier message: 20/06/2009, 15h18
  3. Probleme avec evolution sur Debian Etch
    Par Eurico dans le forum Debian
    Réponses: 2
    Dernier message: 10/04/2008, 12h22
  4. [FLASH MX] Soucis avec text sur banniere flash
    Par BeRoots dans le forum Flash
    Réponses: 14
    Dernier message: 11/03/2006, 13h38

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo