Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

BSD Discussion :

Configuration clé 4G sous openBSD 4.7


Sujet :

BSD

  1. #1
    Membre éclairé
    Configuration clé 4G sous openBSD 4.7
    Bonjour,

    j'ai une installation d'OpenBSD tout à fait fonctionnelle. et j'aurais voulu lui connecter une clé 4G pour remplacer ma (lente, très lente) connexion ADSL.
    Je dispose donc d'une clé 4G Huawey E3272 avec la SIM qui va avec (bouygues telecom). je connecte la clé sur un PC windows, pas de soucis tout se connecte normalement, il y a du réseau, etc.

    quand je connecte au PC OpenBSD, il reconnait bien la clé (dmesg me renvoie bien au driver umsm)
    quand je fait un usbdevs je vois bien la clé connectée.

    Je coince à ce moment là: comment faire que cette diable de clé se connecte à internet et commence à dialoguer avec le PC?
    j'ai bien vu des truc avec ppp, mais le user-ppp a disparu depuis la version d'OBSD5.6...
    Je n'arrive pas à comprende le fonctionnement de pppd ni d'ifconfig avec ppp.
    est-ce que qu'un peut m'éclairer...

    Merci!
    il n'y a que ceux qui savent qui ne savent pas qu'ils savent...
    Libere-toi hacker, GNU's Not Unix!!!

  2. #2
    Expert éminent sénior
    Bonjour

    Euh... ce n'est pas l'USB qui fait la connexion, c'est le wifi. Ton pc OpenBSD a-t-il une carte wifi ?
    Cette réponse vous apporte quelque chose ? Cliquez sur en bas à droite du message.

  3. #3
    Membre éclairé
    Bonjour Flodelarab,
    Merci pour ta réponse.

    il s'agit d'une clé USB qui n'a pas d’émetteur wifi. lorsque je connecte sous windows, c'est bien l'USB qui fait la connexion.

    le dmesg me donne:
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    umsm0 at uhub0 port 7 configuration 1 interface 0 "HUAWEI Technology HUAWEI Mobile" rev 2.00/1.02 addr 2
    umsm0 detached
    umsm0 at uhub0 port 7 configuration 1 interface 0 "HUAWEI Technology HUAWEI Mobile" rev 2.00/1.02 addr 2
    ucom0 at umsm0
    umsm1 at uhub0 port 7 configuration 1 interface 1 "HUAWEI Technology HUAWEI Mobile" rev 2.00/1.02 addr 2
    ucom1 at umsm1
    umsm2 at uhub0 port 7 configuration 1 interface 2 "HUAWEI Technology HUAWEI Mobile" rev 2.00/1.02 addr 2
    ucom2 at umsm2
    et usbdevs -v:
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    addr 1: high speed, self powered, config 1, EHCI root hub(0x0000), NVIDIA(0x10de), rev 1.00
     port 1 powered
     port 2 powered
     port 3 powered
     port 4 powered
     port 5 powered
     port 6 powered
     port 7 addr 2: high speed, power 500 mA, config 1, HUAWEI Mobile(0x1001), HUAWEI Technology(0x12d1), rev 1.02, iSerialNumber FFFFFFFFFFFFFFFF
     port 8 powered
     port 9 powered
     port 10 powered
    Controller /dev/usb1:
    addr 1: full speed, self powered, config 1, OHCI root hub(0x0000), NVIDIA(0x10de), rev 1.00
     port 1 powered
     port 2 addr 2: low speed, power 350 mA, config 1, Ultra Flat Keyboard(0x00f2), Novatek(0x0603), rev 1.10
     port 3 powered
     port 4 powered
     port 5 powered
     port 6 powered
     port 7 powered
     port 8 powered
     port 9 powered
     port 10 powered


    J'arrive à dialoguer avec l'interface /dev/cuaU0 avec la commande 'cu' mais en gros, je sais pas trop quoi lui dire pour qu'il se connecte, et surtout comment l'ajouter à ifconfig pour avoir une interface réseau...
    il n'y a que ceux qui savent qui ne savent pas qu'ils savent...
    Libere-toi hacker, GNU's Not Unix!!!

  4. #4
    Expert éminent sénior
    Ok. Il faut GNU Linux, ModemManager et NetworkManager. Si tu as tout ça en place, tu as peut-être le même problème que là:
    modification des règles de démarrage.
    Et donc la solution est écrite.
    Cette réponse vous apporte quelque chose ? Cliquez sur en bas à droite du message.

  5. #5
    Membre éclairé
    Justement, je veux rester en OpenBSD...
    j'ai essayer certaines astuces trouvée ça et la sur le net en desactivant le driver umsm par exemple ou en le forçant à reconnaitre ma clé mais sans succès...

    Tant pis. de toute façon je suis tombé sur un autre soucis: j'ai comme l'impression que l'on ne peut pas accèder à une machine derrière une clé 4G:
    un ping de mon ip public (ou ce qui apparaît comme tel) depuis un ordinateur sur la toile (vers ma machine donc) ne donne pas de résultat... j'ai l'impression que l'ISP verrouille le réseau...
    il n'y a que ceux qui savent qui ne savent pas qu'ils savent...
    Libere-toi hacker, GNU's Not Unix!!!

  6. #6
    Expert éminent sénior
    N'importe quoi.

    Personne ne demande d'abandonner OpenBSD.

    Je parie que tu n'as même pas lu la réponse donnée, ni essayé de réparer.

    Quand tu ping de l'extérieur, il n'y a aucune chance que toutes les machines derrière ton point d'accès répondent... réfléchis. As-tu essayé de faire une redirection de port ?
    Cette réponse vous apporte quelque chose ? Cliquez sur en bas à droite du message.

  7. #7
    Membre éclairé
    Bon, j'ai résolu le problème en branchant la clé 4g sur un mini-router externe.
    du coup j'arrive maintenant à avoir ma double connexion en utilisant le multi-routing...
    effectivement, les ISPs sur les réseau 4G ne permettent pas le ping depuis l'extérieur (en gros on est connecter sur leur "réseau local" et le router qui est au bout ne fait pas de redirection... dommage)
    il n'y a que ceux qui savent qui ne savent pas qu'ils savent...
    Libere-toi hacker, GNU's Not Unix!!!