IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

WinDev Discussion :

Problème de connexion au serveur HFSQL [WD19]


Sujet :

WinDev

  1. #1
    Nouveau membre du Club
    Femme Profil pro
    Développeur informatique
    Inscrit en
    octobre 2014
    Messages
    27
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 62
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : octobre 2014
    Messages : 27
    Points : 29
    Points
    29
    Par défaut Problème de connexion au serveur HFSQL
    Bonjour,

    Je dois déployer pour la première une application client/serveur, et je dois me résoudre à demander de l'aide.

    Tout fonctionne sur mon poste de développement, en mode client/serveur, le serveur est sur le même poste. J'ai dû spécifier l'adresse du serveur comme suit : 127.0.0.1, car avec le nom du serveur, cela ne fonctionnait pas.

    J'ai installé l'app sur le poste serveur de mon client. Tout fonctionne. Le problème est quand je veux installer l'app. sur un poste client, au moment où je dois indiquer le nom du serveur qui est donc sur une autre machine, sur le réseau. J'ai tout essayé.... et je sèche complètement, j'ai lu la doc... rien n'y fait.

    Je précise qu'il s'agit d'un réseau sous windows8, groupe résidentiel. Tous les postes sont reconnus et accessibles dans ce réseau. Mais je dois avouer que je ne m'y connais pas en réseau...

    Si quelqu'un pouvait me sortir de mon ornière...

    Merci d'avance.

  2. #2
    R&B
    R&B est déconnecté
    Membre éprouvé
    Homme Profil pro
    Développeur informatique
    Inscrit en
    mars 2005
    Messages
    571
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Drôme (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Distribution

    Informations forums :
    Inscription : mars 2005
    Messages : 571
    Points : 1 260
    Points
    1 260
    Par défaut
    Bonjour

    Sur le serveur l'installation en utilisant le nom de la machine ne passe pas alors que 127.0.0.1 oui.
    Sur un poste client, rien ne passe.
    Il s'agit d'un problème de résolution de nom dans le réseau local.

    Sur votre serveur, il faut autoriser les autres postes (et donc le serveur lui même en résolution de nom) à exploiter les ports réservés à la communication Client Serveur du logiciel serveur HFSQL.
    Pour cela il vous faut ouvrir le port 4900 dans le pare-feu de votre serveur.

    Panneau de configuration>Pare feu WinDows
    règles de trafic entrant : activer HFSQL server sur TCP 4900

    Ainsi, l'accès aux données sur ce port sera disponible sur cette machine.

  3. #3
    Nouveau membre du Club
    Femme Profil pro
    Développeur informatique
    Inscrit en
    octobre 2014
    Messages
    27
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 62
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : octobre 2014
    Messages : 27
    Points : 29
    Points
    29
    Par défaut
    Bonjour et merci pour votre réponse.

    En effet, le port 4900 n'était pas ouvert !
    Mais il y avait un problème supplémentaire, une confusion, car le nom du serveur HFSQL était le même que celui de la machine. En changeant le nom de la machine, tout est rentré dans l'ordre.

    Maintenant tout fonctionne. Un grand merci

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 3
    Dernier message: 06/07/2006, 15h38
  2. [débutant] problème de connexion au serveur local
    Par iftolotfi dans le forum MS SQL Server
    Réponses: 5
    Dernier message: 02/06/2006, 08h43
  3. problème de connexion au serveur SOAP
    Par ep31 dans le forum C++
    Réponses: 5
    Dernier message: 02/11/2005, 18h34
  4. Problème de connexion au serveur MYSQL
    Par ETOKA dans le forum Outils
    Réponses: 2
    Dernier message: 27/11/2003, 09h28
  5. Réponses: 11
    Dernier message: 13/10/2003, 14h48

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo