IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

WinDev Discussion :

Incrémentation N° de facture [WD20]


Sujet :

WinDev

  1. #1
    Membre habitué
    Profil pro
    Inscrit en
    mai 2008
    Messages
    210
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2008
    Messages : 210
    Points : 164
    Points
    164
    Par défaut Incrémentation N° de facture
    Bonjour,

    J'incrémente actuellement un numéro de facture automatiquement avec le code suivant, mais malheureusement en réseau les n° sont souvent les mêmes pour les factures si plusieurs users crée des factures en même temps !


    Voici mon code, je charge mes paramètres de facture :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
     
    Charge_params_facture()
     
    PROCEDURE Charge_params_facture()
     
    ValNumfacture est un entier 
    ValInfacture est une chaîne 
     
    HBloqueFichier(Paramètres,hBlocageLectureEcriture)
    //Recherche du "paramétre.idparametre" sur clé composé que l'on connnait la valeur de l'Organisation  
    SI HLitRecherchePremier(Paramètres,IDOrganisationPARAM_Cles,[gnChoixorganisation,"DATEFAC"],hIdentique) ALORS
     
    	SI Paramètres.PARAM_Num=0 ALORS
    		//Recherche du "paramétre.idparametre" sur clé composé que l'on connnait la valeur de l'Organisation à la connexion 
    		SI HLitRecherchePremier(Paramètres,IDOrganisationPARAM_Cles,[gnChoixorganisation,"INDFA"],hIdentique) ALORS
    			ValNumfacture = Paramètres.PARAM_Num
    			ValInfacture= Paramètres.PARAM_Alphanumerique
    			RENVOYER ValInfacture+ValNumfacture +"-"+DateDuJour()
    		FIN
    	SINON
    		//Recherche du "paramétre.idparametre" sur clé composé que l'on connnait la valeur de l'Organisation à la connexion 
    		SI HLitRecherchePremier(Paramètres,IDOrganisationPARAM_Cles,[gnChoixorganisation,"INDFA"],hIdentique) ALORS
    			ValNumfacture = Paramètres.PARAM_Num
    			ValInfacture= Paramètres.PARAM_Alphanumerique
    			RENVOYER ValInfacture+ValNumfacture
    		FIN
     
    	FIN
     
    SINON
    	//Recherche du "paramétre.idparametre" sur clé composé que l'on connnait la valeur de l'Organisation à la connexion 
    	SI HLitRecherchePremier(Paramètres,IDOrganisationPARAM_Cles,[gnChoixorganisation,"INDFA"],hIdentique) ALORS
    		ValNumfacture = Paramètres.PARAM_Num
    		ValInfacture= Paramètres.PARAM_Alphanumerique
    		RENVOYER ValInfacture+ValNumfacture +"-"+DateDuJour()
    	SINON
    		Erreur("Paramètre facturaction non trouvé !")
    		RENVOYER Faux
     
    	FIN
     
    FIN
    HDébloqueFichier(Paramètres)
     
    et ensuite je modifie le N°
     
    //Incrémenter le paramètre
    Paramètres.PARAM_Num++
    SI HModifie(Paramètres)=Vrai ALORS
    	HDébloqueFichier(Paramètres)
    SINON
    	Erreur("Indice INDFA ,non trouvé sur le serveur !")
     
    FIN
    MERCI POUR VOTRE AIDE

  2. #2
    Rédacteur/Modérateur

    Avatar de dsr57
    Homme Profil pro
    Analyste programmeur senior
    Inscrit en
    octobre 2003
    Messages
    1 139
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 39
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Analyste programmeur senior
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : octobre 2003
    Messages : 1 139
    Points : 4 807
    Points
    4 807
    Billets dans le blog
    22
    Par défaut
    Bonjour


    J'appellerai la fonction HDébloqueFichier uniquement après la mise à jour du comteur.


    Pour une meilleur lecture et une meilleur compréhension penses à utiliser la balise

    Bon dev
    ------------------------------------------------------------------------------------------------------------------------------------------
    Mon message vous a aidé, pensez à remercier . La discussion est résolue, n'oubliez pas le tag
    ------------------------------------------------------------------------------------------------------------------------------------------
    Site perso : Formation, Expérience, Réalisations, ...
    Blog : Le Blog de DSR57 - Programmation WinDev

  3. #3
    Membre émérite
    Homme Profil pro
    Inscrit en
    octobre 2007
    Messages
    1 075
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations forums :
    Inscription : octobre 2007
    Messages : 1 075
    Points : 2 439
    Points
    2 439
    Par défaut
    Bonjour,

    Puis-je attirer votre attention sur l'utilisation de la balise # qui permettra l'affichage de votre code de manière standardisée. (vous pouvez encore modifier votre message)
    Nettement plus lisible et donc plus de réponses (a priori de meilleure qualité si vous êtes plus aisément lu et compris).

    Concernant votre problème, il vaudrait mieux commencer par une recherche sur ce forum et sur celui de PCsoft.
    Le problème que vous évoquez a déjà été traité à plusieurs reprises de manière assez complète et on a souligné tant ce qu'il ne faut pas faire que ce qu'il faudrait faire.
    Cette recherche sera donc une bonne mise en bouche et elle devrait être la règle générale avant d'interroger la communauté.

    Bon travail

    Hemgé

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Numéro de facture qui s'incrémente sans être numéroAuto
    Par joseedaccess dans le forum VBA Access
    Réponses: 15
    Dernier message: 05/09/2017, 11h26
  2. [WD17] Incrémentation de numéro facture
    Par tsihadino dans le forum WinDev
    Réponses: 11
    Dernier message: 11/03/2015, 15h28
  3. [AC-2010] Problème d'incrémentation numéro facture
    Par chris_firenze dans le forum IHM
    Réponses: 4
    Dernier message: 04/11/2011, 20h53
  4. auto incrémentation facture
    Par david29170 dans le forum Requêtes et SQL.
    Réponses: 2
    Dernier message: 31/05/2011, 14h25
  5. Incrémentation du numéro de facture
    Par Toison dans le forum Macros et VBA Excel
    Réponses: 7
    Dernier message: 23/05/2008, 15h09

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo