IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eclipse Modeling Discussion :

Erreur "The code for the static initializer is exceeding the 65535 bytes limit" [Xtext]


Sujet :

Eclipse Modeling

  1. #1
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    janvier 2014
    Messages
    14
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Maroc

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Enseignement

    Informations forums :
    Inscription : janvier 2014
    Messages : 14
    Points : 16
    Points
    16
    Par défaut Erreur "The code for the static initializer is exceeding the 65535 bytes limit"
    Bonjour,

    J’ai créé une grammaire xText qui ne contient aucune erreur mais quand je lance l'éditeur graphique de ma grammaire, l'erreur suivante s'affiche
    The code for the static initializer is exceeding the 65535 bytes limit
    J’ai cherché sur Internet et j'ai trouvé que cela vient d’une grammaire trop longue. Le problème est que je n’ai pas pu appliquer les solutions que j'ai trouvées sur Internet.

    Quelqu'un saurait-il m'indiquer comment résoudre ce problème ?

    Merci d'avance pour votre aide.

  2. #2
    Membre à l'essai
    Homme Profil pro
    Étudiant
    Inscrit en
    janvier 2014
    Messages
    14
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Maroc

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Enseignement

    Informations forums :
    Inscription : janvier 2014
    Messages : 14
    Points : 16
    Points
    16
    Par défaut
    J’ai trouvé que cette erreur vient du fait que ma grammaire est très longue. Le fichier Xtext ne peut pas être traité car il dépasse une taille limité. Alors après une recherche j’ai trouvé qu’il existe deux solutions pour cette erreur.

    1/ Soit on divise notre fichier en deux sous-fichiers, chacun sur un projet Xtext différent, sans oublier d’effectuer la gestion de dépendances entre les deux projets (Grammar Mixins).

    2/ La deuxième solution est la plus pratique. On va sur le fichier “Modeling Workflow Engine 2” (le fichier avec l’extension .mwe2), et on cherche les deux lignes :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    fragment = parser.antlr.XtextAntlrUiGeneratorFragment
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    fragment = parser.antlr.XtextAntlrGeneratorFragment
    On modifier les deux lignes par le code suivant :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
                fragment = parser.antlr.XtextAntlrGeneratorFragment auto-inject {
                   options = {
                        // backtrack = true
                        classSplitting=true
                        methodsPerClass = "100"
                        fieldsPerClass = "100"
                    }
                }
     
                ..............
     
                fragment = parser.antlr.XtextAntlrUiGeneratorFragment auto-inject {
                    options = {
                        // backtrack = true
                        classSplitting=true
                        methodsPerClass = "100"
                        fieldsPerClass = "100"
                    }
                }
    Voilà.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. error: Failed to generate code for the service reference
    Par technosmile dans le forum Silverlight
    Réponses: 2
    Dernier message: 18/12/2012, 16h38
  2. Réponses: 11
    Dernier message: 19/08/2010, 12h47
  3. The code of method . is exceeding the 65535 bytes limit
    Par bleporini dans le forum Langage
    Réponses: 6
    Dernier message: 17/03/2010, 16h00
  4. [RCP] Erreur "The site for a view must be an IViewSite"
    Par kmi70 dans le forum Eclipse Platform
    Réponses: 19
    Dernier message: 02/05/2008, 11h07
  5. [PPC][C#][Sql CE] erreur "no data exists for the row/column"
    Par Jessika dans le forum Windows Forms
    Réponses: 6
    Dernier message: 12/04/2007, 12h13

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo