IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Sécurité Discussion :

Portail Captif Coovachilli qui ne fonctionne pas avec le noyau Linux


Sujet :

Sécurité

  1. #1
    Nouveau membre du Club
    Homme Profil pro
    Etudiant en DUT Réseaux & Télécoms
    Inscrit en
    juillet 2014
    Messages
    41
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 26
    Localisation : Réunion

    Informations professionnelles :
    Activité : Etudiant en DUT Réseaux & Télécoms
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : juillet 2014
    Messages : 41
    Points : 28
    Points
    28
    Par défaut Portail Captif Coovachilli qui ne fonctionne pas avec le noyau Linux
    Bonjour à tous,

    Je dois mettre en place un portail captif Coovachilli + Freeradius dans une entreprise. Le portail captif fonctionne bien, la redirection se fait mais uniquement avec certains clients, à savoir les clients Windows et Mac/iOS. Avec les clients GNU Linux et Androïd, c'est le désert, aucune redirection possible et je n'ai même pas accès au script d'authentification du serveur, je peux pourtant bien communiquer avec l'AP par ping.

    La seule similarité que je vois entre les deux systèmes est le noyau... mais que viendrait-il faire là ?

    Je précise, pour ceux qui ont déjà manié Coovachilli ou ChilliSpot, que le fichier hotspotlogin.cgi a été remplacé par une version en PHP et apparemment ça m'aurait permis de faire fonctionner le script sous iOS (c'est dommage, j'ai pas pensé à testé avant sur cette plateforme.) Par contre, je suis sur que les terminaux Linux / Androïd n'ont jamais fonctionné.

    Si quelqu'un a une idée, j'ai malheureusement pas trop la possibilité de tester sous autre chose pour le moment (Ubuntu ou autre distrib linux) étant donné que je n'ai qu'une seule machine qui fait déjà tourner 3 systèmes... mais bon je le ferai si nécessaire.

    Merci d'avance.

    EDIT : j'ai oublié de préciser, ma middlebox (Coovachilli + FreeRadius) est installé sur une machine virtuelle Ubuntu 12.04 64 bits, mes tests clients se font sur mon système hôte Windows. Aussi je viens de lancer deux lives Linux (Ubuntu 14.04 64 et Kali Linux) toujours pas de portail captif sur les deux. Là vraiment je vois rien... j'espère ne pas devoir tout recommencer sur une autre plateforme du genre PfSense.

  2. #2
    Nouveau membre du Club
    Homme Profil pro
    Etudiant en DUT Réseaux & Télécoms
    Inscrit en
    juillet 2014
    Messages
    41
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 26
    Localisation : Réunion

    Informations professionnelles :
    Activité : Etudiant en DUT Réseaux & Télécoms
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : juillet 2014
    Messages : 41
    Points : 28
    Points
    28
    Par défaut
    J'apporte quelques précisions, j'ai pu faire des tests au niveau du pare-feu, j'ai tout autorisé des deux côtés (serveur et client) directement sur le système par ces 3 commandes :

    iptables -F INPUT && iptables -P INPUT ACCEPT
    iptables -F FORWARD && iptables -P FORWARD ACCEPT
    iptables -F OUTPUT && iptables -P OUTPUT ACCEPT

    et il n'y a toujours rien. Au niveau des analyses de trames avec Wireshark, avec un client Windows, dès le DHCP fonctionnel, je reçois et envoie tout un tas de requêtes au niveau du serveur : TCP, HTTP, DATA...

    Par contre, le DHCP est fonctionnel sous Linux, je reçois bien une adresse IP, mais niveau application ensuite, rien du tout niveau paquets... Je ne pense pas que ça soit le pare-feu du portail captif, mais là aussi du côté de coovachilli, j'ai mis toutes les valeurs à "ACCEPT".

    Je crois qu'on veut ma peau

  3. #3
    Inactif  


    Homme Profil pro
    Doctorant sécurité informatique — Diplômé master Droit/Économie/Gestion
    Inscrit en
    décembre 2011
    Messages
    9 014
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 28
    Localisation : France, Loire (Rhône Alpes)

    Informations professionnelles :
    Activité : Doctorant sécurité informatique — Diplômé master Droit/Économie/Gestion
    Secteur : Enseignement

    Informations forums :
    Inscription : décembre 2011
    Messages : 9 014
    Points : 22 976
    Points
    22 976
    Par défaut
    Bonjour,

    Si je comprend bien, au niveau DHCP, tout est bon.

    Par contre, je ne comprend pas exactement où se situe votre problème :
    • les paquets clients ne sont pas envoyés ;
    • les paquets clients envoyés ne sont pas reçus par le serveur ;
    • les paquets clients envoyés ne sont pas reçus par l'application serveur ;
    • les paquets serveurs ne sont pas envoyés ;
    • les paquets serveur envoyés ne sont pas reçus par le client ;
    • les paquets serveur envoyés ne sont pas reçus par l'application cible ;

  4. #4
    Nouveau membre du Club
    Homme Profil pro
    Etudiant en DUT Réseaux & Télécoms
    Inscrit en
    juillet 2014
    Messages
    41
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 26
    Localisation : Réunion

    Informations professionnelles :
    Activité : Etudiant en DUT Réseaux & Télécoms
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : juillet 2014
    Messages : 41
    Points : 28
    Points
    28
    Par défaut
    Alors, au niveau DHCP tout devrait bien fonctionner.

    Au niveau des paquets justement je ne sais pas ce qu'il se passe, il n'y pas d'échanges de paquets du tout, que ce soit d'un côté ou de l'autre.

  5. #5
    Expert confirmé Avatar de marsupial
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2014
    Messages
    1 357
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Autre

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2014
    Messages : 1 357
    Points : 5 149
    Points
    5 149
    Par défaut Départ de solution éventuelle
    J'imagine que la politique du Domaine laisse passer les kernels ? Sinon ce serait bien de les laisser passer. Il ne sert à rien de leur claquer la porte dans un environnement BYOD.

    Sinon j'ai une solution de sécurité qui permet de se passer de tout ce fatras : contacter la division sécurité de Thales, open source à un million de dollars la ligne de code. Licence inc.

    Déjà adoptée par l'Elysée, la Cour Européenne dans son ensemble, les 28, la famille royale du Royaume-Uni, le DOD, etc ...

    Edit : on a fait un prix de gros; ça aurait pu être au char. J'oublie la Russie et les Chinois dans les souscripteurs.

    Edit 2 : je précise breveté et sans doute normé mais pas vraiment pour tout de suite
    Repeat after me
    Le monsieur lutte pour la défense des libertés individuelles et collectives

    Repeat after me...

  6. #6
    Nouveau membre du Club
    Homme Profil pro
    Etudiant en DUT Réseaux & Télécoms
    Inscrit en
    juillet 2014
    Messages
    41
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 26
    Localisation : Réunion

    Informations professionnelles :
    Activité : Etudiant en DUT Réseaux & Télécoms
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : juillet 2014
    Messages : 41
    Points : 28
    Points
    28
    Par défaut
    Merci mais je n'ai pas le contact direct de Thalès, et encore moins de la famille royale (si seulement....)

    Si quelque chose te dérange dans ce sujet, soit tu le dis explicitement et dans ce cas j'accepte toute critique, soit tu ne réponds pas, soit tu le reportes aux modérateurs qui eux même prendront la décision de le fermer ou pas.

    C'est super en tout cas de se fiche des autres qui prennent des heures et des heures à régler leur problème (c'est pas le cas de tout le monde je le conçois) par eux même avant de venir dans des endroits comme ici.

    Bref, par contre, un point pour toi, j'avais oublié ce topic, je précise donc que j'ai changé de solution de portail captif, et ça marche mieux. Merci quand même à la personne qui m'a répondu.

  7. #7
    Expert confirmé Avatar de marsupial
    Homme Profil pro
    Retraité
    Inscrit en
    mars 2014
    Messages
    1 357
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Autre

    Informations professionnelles :
    Activité : Retraité

    Informations forums :
    Inscription : mars 2014
    Messages : 1 357
    Points : 5 149
    Points
    5 149
    Par défaut
    Citation Envoyé par Endast Voir le message
    Merci mais je n'ai pas le contact direct de Thalès, et encore moins de la famille royale (si seulement....)

    Si quelque chose te dérange dans ce sujet, soit tu le dis explicitement et dans ce cas j'accepte toute critique, soit tu ne réponds pas, soit tu le reportes aux modérateurs qui eux même prendront la décision de le fermer ou pas.

    C'est super en tout cas de se fiche des autres qui prennent des heures et des heures à régler leur problème (c'est pas le cas de tout le monde je le conçois) par eux même avant de venir dans des endroits comme ici.

    Bref, par contre, un point pour toi, j'avais oublié ce topic, je précise donc que j'ai changé de solution de portail captif, et ça marche mieux. Merci quand même à la personne qui m'a répondu.
    1- je ne me moquais pas
    2- l'option résolue est là pour éviter ce genre de désagrément de prendre son jugement sur soi-même pour une généralité

    Cordialement, Monsieur ^^
    Repeat after me
    Le monsieur lutte pour la défense des libertés individuelles et collectives

    Repeat after me...

  8. #8
    Nouveau membre du Club
    Homme Profil pro
    Etudiant en DUT Réseaux & Télécoms
    Inscrit en
    juillet 2014
    Messages
    41
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 26
    Localisation : Réunion

    Informations professionnelles :
    Activité : Etudiant en DUT Réseaux & Télécoms
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : juillet 2014
    Messages : 41
    Points : 28
    Points
    28
    Par défaut
    Tu ne te moquais pas ?

    Dans ce cas je n'ai strictement rien compris à ton post, dans son intention mais surtout dans son contenu....

    ça peut servir à d'autres et même à moi, même si je suis passé à autre chose.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Ancre qui ne fonctionne pas avec IE6
    Par bractar dans le forum Balisage (X)HTML et validation W3C
    Réponses: 2
    Dernier message: 03/06/2008, 17h17
  2. Problème de addEventListener qui ne fonctionne pas avec un attachMovie
    Par jeremie74 dans le forum ActionScript 1 & ActionScript 2
    Réponses: 1
    Dernier message: 27/09/2007, 11h47
  3. un For Each qui ne fonctionne pas avec une collection maison !
    Par grenouillesiverte dans le forum Windows Forms
    Réponses: 7
    Dernier message: 01/09/2007, 22h00
  4. tutoriel qui ne fonctionne pas avec glassfish
    Par dev7 dans le forum Glassfish et Payara
    Réponses: 1
    Dernier message: 13/04/2007, 18h25
  5. Réponses: 10
    Dernier message: 13/03/2007, 12h38

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo