Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Installation PostgreSQL Discussion :

pgAdmin 1.20 autonome bogué complet !


Sujet :

Installation PostgreSQL

  1. #1
    Membre émérite
    pgAdmin 1.20 autonome bogué complet !
    Installé sur le serveur Windows 2012 R2 avec le package complet de PostgreSQL 9.4 il est parfaitement fonctionnel. Mais je le voudrais, et rien que lui, sur un poste client Windows 8.1. Je télécharge et j'installe la version séparée de pgAdmin III v1.20 mais il ne se lance pas. Il demande un fichier msvcr120.dll et, si je lui donne (récupéré sur le serveur dans \System32), il plante.

    Le problème est-il connu où suis-je seulement visé par le proboscidien ?
    "Toute l'histoire de l'informatique n'a été que l'histoire des systèmes d'exploitations" (Le Manifeste du PC)

  2. #2
    Membre émérite
    Trouvé !
    Le gag provient de ce que "Visual C++ 2013 redistributable" n'est pas installé. Parce que dans mes "redistributable" j'ai bien à peu près tout mais là c'était la version 32 bits qui manquait et la seule copie du fichier incriminé était insuffisante.

    Toutefois je persiste à penser que l'installation, à défaut de le faire d'office (comme dans les jeux) ou, tout au moins, de le mentionner dans les "prérequis" est quelque peu boguée à ce niveau. En corrigeant ce gag ça éviterait à x personnes dans le vaste monde de se casser la tête pour comprendre ce qui ne va pas.

    C'est donc résolu !
    "Toute l'histoire de l'informatique n'a été que l'histoire des systèmes d'exploitations" (Le Manifeste du PC)

  3. #3
    Rédacteur/Modérateur

    Bonjour,

    J'ai exactement le même problème sous Windows 7 64 bits.
    Je l'ai fait remonter sur la mailing list de PgAdmin... Sur mon poste, j'ai bien Visual C++ 2013 redistributable, mais en version 64 bits. Et du coup, ça ne fonctionne pas...
    Rédacteur / Modérateur SGBD et R
    Mes tutoriels et la FAQ MySQL

    ----------------------------------------------------
    Pensez aux balises code et au tag
    Une réponse vous a plu ? N'hésitez pas à y mettre un
    Je ne réponds pas aux questions techniques par message privé, les forums sont là pour ça

  4. #4
    Membre à l'essai
    chez moi aussi ca marche pas sur W7 (manque la DLL MSVCP120.dll) . comment avez-vous résolu le pb ?

    merci

    Joel

  5. #5
    Rédacteur/Modérateur

    Pour moi, la seule solution à ce jour a consisté à installer PostgreSQL 9.4. Là, la version de PgAdmin 1.20 qui va avec fonctionne...
    Mais PgAdmin 1.20 seul, ça ne fonctionne toujours pas dans mon cas.
    Rédacteur / Modérateur SGBD et R
    Mes tutoriels et la FAQ MySQL

    ----------------------------------------------------
    Pensez aux balises code et au tag
    Une réponse vous a plu ? N'hésitez pas à y mettre un
    Je ne réponds pas aux questions techniques par message privé, les forums sont là pour ça