Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

JDeveloper Java Discussion :

Echec de connexion à la BDD


Sujet :

JDeveloper Java

  1. #1
    Membre du Club
    Echec de connexion à la BDD
    Bonjour,

    Je travaille sur un windows serveur 2008 64 bits.

    J'ai installé dessus une database 11G enterprise edition

    J'ai fait mon installation complète de mon environnement en utilisant ce lien : Tuto install

    Mais j'ai un souci pour la connexion de Jdevelopper à ma database. J'utilise une version 12c de Jdevelopper (le tuto utilise une 11 il me semble).

    Quoi qu'il en soit, voici mes informations de connexion (tout est en local sur le serveur)

    Username : sys
    Role : sysdba
    Password : mon_mdp
    Driver : thin
    Hostname : localhost
    JDBC port : 1521
    SID : orcl

    L'erreur : Test failed: IO Error: The Network Adapter could not establish the connection

    Si je passe en service name : CLRExtProc (celui que me donne la commande lsnrctl status) j'ai la même erreur.

    Si je change le hostname en mettant l'adresse ip de mon serveur, même problème.

    Mon tnsnames.ora :

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    # tnsnames.ora Network Configuration File: C:\oracle\Database\product
     
    \11.2.0\dbhome_1\network\admin\tnsnames.ora
    # Generated by Oracle configuration tools.
     
    ORACLR_CONNECTION_DATA =
      (DESCRIPTION =
        (ADDRESS_LIST =
          (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
        )
        (CONNECT_DATA =
          (SID = CLRExtProc)
          (PRESENTATION = RO)
        )
      )
     
    ORCL =
      (DESCRIPTION =
        (ADDRESS = (PROTOCOL = TCP)(HOST = 10.0.2.15)(PORT = 1521))
        (CONNECT_DATA =
          (SERVER = DEDICATED)
          (SERVICE_NAME = orcl.0.2.15)
        )
      )


    Mon tnsping :

    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    Fichiers de paramÞtres utilisÚs :
    C:\Oracle\Database\product\11.2.0\dbhome_1\network\admin\sqlnet.ora
     
     
    Adaptateur TNSNAMES utilisÚ pour la rÚsolution de l'alias
    Tentative de contact de (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = 10.0.2
    .15)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = orcl.0.2
    .15)))
    OK (0 msec)


    Le truc qui me parait bizarre c'est le service_name ... orcl.0.2.15 ? ça devrait pas être orcl tout court ? Quoi qu'il en soit, que ce soit ça, orcl, ou CLRExtProc le tnsping fonctionne bien.

    Le listener est démarré et la base aussi vu la connexion fonctionne bien.

    Une idée ?

    Merci d'avance

  2. #2
    Membre du Club
    Problème résolu.

    Après avoir supprimé ma VM, et refait une installation complète, j'ai pu me connecter à ma base de données du premier coup, et sans absolument aucun souci.

    Bref, j'avais tellement bricolé sur cette VM puisque c'était mes premiers essais et que j'ai eu pas mal de souci de compatibilité (donc que j'ai dû installer/désinstaller pas mal de trucs) qu'il devait rester des trucs foireux d'anciennes installations.

    Résolu

###raw>template_hook.ano_emploi###